Skip navigation

The "alt, ctrl and shift" on the left side of my keyboard keys integrated notebook did not work. What should I do?

773 Views 1 Reply Latest reply: Dec 11, 2013 12:53 PM by ariel s RSS
Luis Fernando Garcia Calculating status...
Currently Being Moderated
Dec 8, 2013 8:56 PM

The "alt, ctrl and shift" on the left side of my keyboard keys integrated notebook did not work. What should I do?

MacBook (13-inch Mid 2010), OS X Mountain Lion (10.8.3), Itunes
  • ariel s Community Specialists Community Specialists (1,685 points)

    Hi Luis Fernando Garcia,

     

    Thanks for using Apple Support Communities.  This article has troubleshooting for keys not working on your keyboard:

     

    One or more keys on the keyboard do not respond

    http://support.apple.com/kb/ts1381

    Some keys don't work as expected

    1. From the Apple menu, choose System Preferences.
    2. From the View menu, choose Speech.
    3. Click the Text to Speech tab.
    4. If "Speak selected text when the key is pressed" is enabled, the key or key combination set to speak text cannot be used for other purposes or used to type text--click Set Key and change it to a less-commonly used key combination (try to use modifier keys such as Shift, Command, Option, and Control). Or, disable the "Speak selected text when the key is pressed" option.
    5. Click the Universal Access pane in System Preferences, click the Keyboard tab.
    6. Make sure that Slow Keys is turned off. With Slow Keys on, you need to press a key for a longer period of time for it to be recognized.
    7. In the Universal Access pane, click the Mouse tab, and make sureMouse Keys is turned off. With Mouse Keys enabled, you cannot use the Numeric Keypad to enter numbers--instead the keypad moves the pointer (cursor). (There is an option to enable Mouse Keys with five presses of the Option key; you may want to turn that option off to avoid accidentally enabling it.) If Mouse Keys is enabled and you are using a keyboard with no numeric keypad or Num Lock function, seeUnable to type while Mouse Keys is enabled in Mac OS X.
    8. If the function keys on the top row of the keyboard are not working as expected, see Mac OS X: How to change the behavior of function keys.
    9. If the issue persists, use Keyboard Viewer to help isolate the issue:
      1. Click the Language & Text pane (Mac OS X v10.6) or International pane (Mac OS X v10.5.8 or earlier) in System Preferences.
      2. Click the Input Sources tab (or Input Menu tab in Mac OS X 10.5.8 or earlier).
      3. Click the Keyboard & Character Viewer "On" checkbox to select it (click the Keyboard Viewer "On" checkbox in Mac OS X 10.5.8 or earlier).
      4. From the Input (flag) menu, choose Show Keyboard Viewer.
        TS1381-02_en.png
      5. If the keyboard is connected and detected by Mac OS X, the keys you type will highlight in the Keyboard Viewer window. Open TextEdit (or any text application), and try to type something using the keys that were previously not responding to see if they highlight in Keyboard Viewer.

     

    Cheers,

    - Ari

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.