11 Replies Latest reply: Dec 14, 2013 9:28 AM by Kurt Lang
gailrooney Level 1 Level 1 (0 points)

Please advise:  I have a Mac OS10.7  What is the earliest version of Adobe CS will work on it?


iMac, Mac OS X (10.7)