Skip navigation

Windows Stuck In Akward Positions After Maverick Update

5968 Views 48 Replies Latest reply: Mar 21, 2014 10:12 AM by amityuk RSS Branched to a new discussion.
  • sekrof Calculating status...

    This 'Stuck Window' issue has been reported in several places on the boards here since the upgrade to Mavericks, but there doesn't appear to be an official confirmation from Apple about whether it is a defect with Mavericks or a 3rd App causing it.

     

    It would help us all if people could note which Apps were open when the issue appears.  So far from my own experience I've noticed the following Apps are usually open, and it only happens when the Mac enters 'Sleep' mode:

     

    * Chrome

    * Evernote

    * Calendar

    * Finder

     

    If you experience the problem the best work around (until we get a definitive fix) is to:

     

    1. Open System Preferences > Dock

    2. Change the dock locatin using 'Position on screen' to anything else

    3. Change the 'Position on screen' setting back to your normal one

    4. Exit System Preferences.

     

    This will "unstick" your windows from the top left-hand corner and allow you gain control over your workspace again.

     

    Best

    A>

  • Michael Lindner1 Level 1 Level 1 (15 points)

    This happened to me when I upgraded. Over time it has mostly cleared itseld up. I say "mostly" because it happens rarely now. After my upgrade it took several days and a few dozen reboots before things started working. I have a 13" macbook pro laptop 2.8 GHz i7 and 16 GB ram.

     

    To the person who refuses to try "safe mode" - this is not them asking you to "fix" it by using safe mode - they are asking you to see under what conditions it happens so they can fix the problem. If you called your mechanic and said the car was making a noise they might ask you to try driving a certain way to see if it goes away as a means to diagnose what is wrong. Or they might ask you to bring it in and they would drive it. Likewise you should either start it in safe mode and report the result here, or bring your machine in to a service place for an Apple employee to do it. To refuse to give someone information they need to help them fix your machine is childish.

     

    I would be happy to try starting mine in safe mode, but since I can't predict when the problem will appear, starting it in safe mode would not give any useful information (unless it did happen in safe mode, and as I said it happens rarely now).

     

    So, those of you still affected routinely by this, please give it a try and let the rest of us know. Thank you.

  • nicnerd Calculating status...

    For the record, this happens in safe mode as well.  To me this implies that it is not a third party app, rather a problem in Mavircks under some certain conditions (wish I knew waht it was).  The Apple support advice about reinstalling Mavericks is also a collosal waste of time.

     

    Forum rules prohibit me from saying anything further about the issue.

  • Rafael Marino Level 3 Level 3 (550 points)

    10.9.1 is out and it does not solve the problem. C'mon Apple, fix the **** bug. It's more than annoying.

  • Andrei Gladkyi Calculating status...

    Completely agree, this annoys alot because you have to relaunch all your stucked applications each time.

    And the question: do you experience this issue in dual monitor configuration only? In my case I have a work setup with two monitors and different resolutions: 1680x1050 and 1920x1080 (main screen) and I constantly see this problem. Also I have a Mackbook Air (single monitor ) where this problem never happens.

  • Michael Lindner1 Level 1 Level 1 (15 points)

    Happens to me on Macbook pro with no external monitor.

  • sekrof Level 1 Level 1 (0 points)

    Nope happens in single monitor set-up as well.

     

    You don't have to close all your apps (see my post above) - it's not a fix, but it's less painful.

  • tbrams Calculating status...

    Just purchased the most expensive personal computer I have ever purchased - an iMac 27'' 3.4 GHz Intel Core i5, 32GB memory 1600 MHz DDR3, NVIDIA GeForce GTX 780M 4096 MB system running OS X 10.9.1 (13B42).

     

    I have this problem constantly with all applications - even Finder. It always presents itself when I chose "Login Window..." to let another user roam the system and then return to my session by loggin in again.

     

    This is a single monitor, out of the box product from Apple. Less than a week old.

     

    So disappointed...

  • alphabc Level 1 Level 1 (0 points)

    I'm experiencing this bug on my iMac too, ever since upgrading to Mavericks. (I'm currently on 10.9.1)

     

    I use fast-user switching, leaving my userid logged in but showing the login window when I'm not at the computer (several family members each have accounts and share the iMac).  when I log back into my userid, I sometimes randomly find some window collapsed to a narrow vertical height and top edge of the menu above and to the left of the viewable edge of the display, so that I cannot click on the red/yellow/green buttons on the window.

     

    I'm guessing it happens to whatever window happened to be on top when I logged out.  and it doesn't happen every time, maybe just once every few days.

     

    it just happened again today, and the only apps I have running are Safari, Excel, iTunes and Finder.

     

    it had been bugging me ever since updating to 10.9, but then I found this thread, and sekrof's tip of changing the position of the dock "unstuck" the window.

     

    very annoying.

  • alphabc Level 1 Level 1 (0 points)

    a quick update:

     

    it happened again today, but this time I was still logged in and my apps and windows still visible (not the login screen) - went away from the iMac for only just a few minutes and when I came back, the frontmost window (Safari) was shrunk and off the top left corner of the screen. another Safari window behind that was also shrunk.

     

    apps running at the time were Safari, iTunes, Preview and Excel.  repositioning the dock moved the offending window down where I could close it.

     

    no idea what triggers this bug...

  • Readmore Calculating status...

    Same problem here. One screen, using a late-2012 Mac Mini, latest OSX upgrade (Mavericks). My mini is built up a little, with 8 gigs of RAM, a bit faster i5 chip. I find that this happens when the machine is idle for 10 minutes or more. It does not happen while the computer is in active use, no matter how many apps I have open.

     

    I usually run a mix of Apple, MS Office  and other applications at the same time. Outlook, Chrome and Safari, Contacts, Dictionary, Activity Monitor, Dropbox in the background, etc.

     

    There does not appear to be any pattern of open programs that triggers this. The only constant is absence for 10 minutes or more.

     

    It would be very good if Apple would fix this persistent problem. The existing suggested fixes--safe mode, etc.--have no effect.

     

    Finally, I run a similar setup on a late 2013 Macbook Pro, and there I have no problems. Strange, but welcome.

  • binbash Calculating status...

    I have the same annoying problem (MacBook Pro, ca 2011).

     

    Could it be related with the use of full screen apps? I work with a lot of apps in that mode. Anybody else does that who sees this problem?

     

    I hope they fix this soon, because this is unacceptable...

  • alphabc Level 1 Level 1 (0 points)

    In my case, I never use apps in full screen mode yet I have this problem

  • tbrams Level 1 Level 1 (0 points)

    This is what it looks like on my system imgur.com

    :-(

  • sekrof Level 1 Level 1 (0 points)

    Still trying to glean more information about this bug. 

     

    I'm not sure if any tech support are watching this thread, but I found the following entries posted in my Console > All Messages log just after an occurance:

     

    iMac, 27", was in Login screen mode for around 1.5hrs prior to me returning and loggin into my normal account:

    06/01/2014 18:31:13.991 WindowServer[107]: CGXDisplayDidWakeNotification [359740953282402]: posting kCGSDisplayDidWake

    06/01/2014 18:31:13.991 WindowServer[107]: handle_will_sleep_auth_and_shield_windows: Deferring.

    06/01/2014 18:31:26.242 SecurityAgent[32493]: User info context values set for <snip>

    06/01/2014 18:31:26.399 SecurityAgent[32493]: Login Window login proceeding

    06/01/2014 18:31:26.576 loginwindow[32482]: Login Window - Returned from Security Agent

    06/01/2014 18:31:26.605 WindowServer[107]: Session 260 released (1 references)

    06/01/2014 18:31:26.614 WindowServer[107]: transition_init_devices: Abandoning transition due to insufficient VRAM

    06/01/2014 18:31:26.614 WindowServer[107]: Session 256 is switching to console

    06/01/2014 18:31:26.636 WindowServer[107]: Session 256 retained (2 references)

    06/01/2014 18:31:26.636 WindowServer[107]: Session 260 released (0 references)

    06/01/2014 18:31:26.637 loginwindow[32482]: CGError CGSGetDisplaySystemState(uint64_t, CGSDisplaySystemState **): MIG error 0xfffffecc: (ipc/mig) server died

    06/01/2014 18:31:26.637 loginwindow[32482]: CGError CGSGetDisplaySystemState(uint64_t, CGSDisplaySystemState **): MIG error 0xfffffecc: (ipc/mig) server died

    06/01/2014 18:31:26.637 loginwindow[32482]: CGError CGSGetDisplaySystemState(uint64_t, CGSDisplaySystemState **): MIG error 0xfffffecc: (ipc/mig) server died

    06/01/2014 18:31:26.637 loginwindow[32482]: CGError CGSGetDisplaySystemState(uint64_t, CGSDisplaySystemState **): MIG error 0xfffffecc: (ipc/mig) server died

    06/01/2014 18:31:26.643 airportd[99]: _doAutoJoin: Already associated to “<SNIP>”. Bailing on auto-join.

    06/01/2014 18:31:26.694 WindowServer[107]: run_timer_pass: Session 260 is defunct for callback to 0x7fff8ff17d9a

     

    Looks like a WindowServer issue?  Interesting entry at "06/01/2014 18:31:26.614 WindowServer[107]: transition_init_devices: Abandoning transition due to insufficient VRAM" .. unlikely to be due to a lack of Disk or RAM as I have around 500GB spare and 32GB of RAM ... and an NVIDIA GeForce GTX 780M with 4GB of onboard RAM - rogue graphics process perhaps?

     

    A WindowServer issue would also be consistent with the fact Paralells is also affected (if it's running), whereby all it's MS windows are also resized. 

     

    As we haven't seen any official response from Apple yet on this defect, it would be useful if others could check there own Console.app logs to see if they see anything similiar ?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.