Skip navigation

My Iphone 4S no longer connects to wifi networks

939 Views 2 Replies Latest reply: Dec 19, 2013 10:37 AM by LisainNJ RSS
LisainNJ Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 13, 2013 9:31 AM

My  smart-phone is not so smart and hasn't been since the last OS update.


I've  tried to decipher where the problem is and it appears it occurs on  networks where there is a "pop-up" asking you your log-in credentials  (ie. airport hotspots, cable hotspots, hotels, etc.). The phone is not automatically finding and asking to join those networks. If I manually select the network in settings I get the unhelpful message that the phone is "unable to connect" to the named network

 

The forums suggest  resetting the network but that's not an option in these cases.

 

I've tried resetting the phone, forgetting the network and trying again. etc. etc. but the problem persists. I thought the update to the update would fix it, but so far there is no change. I've tried manually connecting but that requires that I know the network password, protocol, etc and in most cases I don't.

 

It was a major problem on vacation, where I did not have cell service. The hotel had free wifi but the iphone 4S was unable to connect. (My friend's Android did, for what it's worth, and so did my ipad).

 

I'm one frustrated Apple consumer.

iPhone 4S, iOS 7.0.4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.