9 Replies Latest reply: Feb 1, 2014 6:09 AM by DaveAinVa
delfinariuma Level 1 Level 1 (0 points)

i instal OS X Maverics and camera always not working. sometimes is working but always never working and its start anoying a lot. can anyone help me?


MacBook Air, OS X Mavericks (10.9)
  • 1. Re: camera always not working after installing OS X Maverics
    Linc Davis Level 10 Level 10 (118,525 points)

    Does it work with Photo Booth?

  • 2. Re: camera always not working after installing OS X Maverics
    delfinariuma Level 1 Level 1 (0 points)

    When my macbook air cant find the camera, then is not working with non of programs. But this morning is working again even i couldnt fix that problem yesterday so i dont understant. Sometimes is working sometimes is not and i dont understant what problem is cousing that. When is working is working fine, but when is not working then even in the system i can't find it. and its quite anoying as when i need camera is not here. anyone know why is this problem?

  • 3. Re: camera always not working after installing OS X Maverics
    Linc Davis Level 10 Level 10 (118,525 points)
    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It changes nothing, and therefore will not, in itself, solve your problem.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The procedure will help identify which such modifications you've installed, as well as certain other aspects of the configuration that may have a bearing on the problem. Don’t be alarmed by the apparent complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode, if possible. If you’re now running in safe mode, reboot as usual before continuing. If you can only boot in safe mode, you can still use this procedure, but not all of it will work. Be sure to mention that in your reply, if you haven't already done so.

     

    Below are instructions to enter UNIX shell commands. The commands are safe and do nothing but produce human-readable text output, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects. I am not asking you to trust me. If you can't satisfy yourself that these instructions are safe, don't follow them.
        
    The commands will line-wrap or scroll in your browser, but each one is really just a single long line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then copy it.
       
    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. Step 1 should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.
       
    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Triple-click anywhere in the line of text below on this page to select it:
    { echo "Loaded kernel extensions:"; kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'; echo $'\n'"Loaded user agents:"; launchctl list | sed 1d | awk '!/0x|com\.apple|org\.(x|openbsd)|\.[0-9]+$/{print $3}'; echo $'\n'"Inserted libraries:"; launchctl getenv DYLD_INSERT_LIBRARIES; echo $'\n'"User cron tasks:"; crontab -l; echo $'\n'"System launchd configuration:"; cat /e*/lau*; echo $'\n'"User launchd configuration:"; cat .lau*; echo $'\n'"Login items:"; osascript -e 'tell application "System Events" to get name of login items' | sed $'s/, /\\\n/g'; echo $'\n'"Safari extensions:"; /usr/libexec/PlistBuddy -c Print L*/Saf*/*/E*.plist | awk -F'= ' '/Bundl/{print $2}' | sed 's/\..*$//;s/-[1-9]$//'; printf "\nRestricted user files: %s\n" $(find ~ $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 \) | wc -l); echo $'\n'"Extrinsic loadable bundles:"; cd; find -L /S*/L*/E* {,/}L*/{Ad,Compon,Ex,In,Keyb,Mail/Bu,P*P,Qu,Scripti,Servi,Spo}* -type d -name Contents -prune | while read d; do /usr/libexec/PlistBuddy -c 'Print :CFBundleIdentifier' "$d/Info.plist" | egrep -qv "^com\.apple\.[^x]|Accusys|ArcMSR|ATTO|HDPro|HighPoint|driver\.stex|hp-fax|JMicron|print|SoftRAID" && echo ${d%/Contents}; done; echo $'\n'"Unsigned shared libraries:"; find /u*/{,*/}lib -type f -exec sh -c 'file -b $1 | grep -qw shared && ! codesign -v $1' {} {} \; -print; echo; ls -A {,/}L*/{La,Priv,Sta}* L*/Fonts; } 2> /dev/null | open -ef
     
    Copy the selected text to the Clipboard by pressing the key combination command-C. Then click anywhere in the Terminal window and paste (command-V). I've tested these instructions only with the Safari web browser. If you use another browser, you may have to press the return key after pasting.
      
    The command may take up to a few minutes to run, depending on how many files you have and the speed of the computer. A TextEdit window will open with the output. Post the contents of the TextEdit window (not the Terminal window) — the text, please, not a screenshot. You can then close the TextEdit window. The title of the window doesn't matter, and you don't need to post that. No typing is involved in this step.
        
    Step 2

     

    Remember that you must be logged in as an administrator for this step. Do as in Step 1 with this line:
    { echo "Loaded system agents:"; sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix\.cron)|org\.(amav|apac|cups|isc|ntp|postf|x)/{print $3}'; echo $'\n'"Login hook:"; sudo defaults read com.apple.loginwindow LoginHook; echo $'\n'"Root cron tasks:"; sudo crontab -l; echo $'\n'"Log check:"; syslog -k Sender kernel -k Message CReq 'GPU |hfs: Ru|I/O e|find tok|n Cause: -|NVDA\(|pagin|timed? ?o' | tail | awk '/:/{$4=""; print}'; } 2> /dev/null | open -ef
      
    This time you'll be prompted for your login password, which you do have to type. Nothing will be displayed when you type it. Type it carefully and then press return. You may get a one-time warning to be careful. Heed that warning, but don't post it. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.
        
    You can then quit Terminal.
      
    To prevent confusion, I'll repeat: When you type your password in the Terminal window, you won't see what you're typing.
        
    Note: If you don’t have a login password, set one before taking Step 2. If that’s not possible, skip the step.
         
    Important: If any personal information, such as your name or email address, appears in the output of these commands, anonymize it before posting. Usually that won't be necessary.
        
    Remember, Steps 1 and 2 are all copy-and-paste — no typing, except your password. Also remember to post the output as text, not as a screenshot.
       
    Please post the contents of the TextEdit window, not the Terminal window.
  • 4. Re: camera always not working after installing OS X Maverics
    delfinariuma Level 1 Level 1 (0 points)

    this information was too much for me. Could you explain easier?

  • 5. Re: camera always not working after installing OS X Maverics
    Linc Davis Level 10 Level 10 (118,525 points)

    I'm asking you to copy and paste text from one window to another. You don't have to know what the text means. But if you don't understand the instructions, you shouldn't try to follow them. Instead, I suggest you make a "Genius" appointment at an Apple Store for someone to help you in person. If that's not possible, go to a local computer consultant who specializes in Macs.

  • 6. Re: camera always not working after installing OS X Maverics
    Jal1980 Level 1 Level 1 (0 points)

    Hi @Linc Davis, I'm having a similar problem.

    I have a 2013 MacBook Air with 10.9.1. Results of your code lines are below this explanation.

     

    Apparently there is some sort of conflict with the MacBook Air Facetime HD Camera between different applications.

     

    In my case I mainly use Google Hangouts, Skype, and sometimes Facetime. The problem lies that the camera sometimes works and sometimes it doesn't.

     

    I usually reboot the camera with 'sudo killall AppleCameraAssistant' and that makes it work, but it shouldn't be like that.

     

    Please note that this was not happening with my 2010 MacBook Pro with Mavericks. I changed to this new 2013 MacBook Air only 3 weeks ago. Nevertheless, people that I work with (who use retina macbooks with Mavericks) are not having this issue.

     

    Last week I had to install a plugin (in chrome) for a new online site similar to Hangouts called BlueJeans. Bluejeans very seldomly recognizes the cam, only when I reboot it. The people I work with didn't have any issues, so I suspect this has to do with 2013 MacBook Air's Facetime HD cameras which might be different to the rest, or too new on the market.

     

    It's as if when I start using it in Hangouts and then hang, later it might not work in Skype, or viceversa.

     

    If you can help, that'll be great, and I appreciate it. Otherwise don't worry. Nevertheless, I feel Apple must take care of this in the next Mavericks update (many people are having camera issues).

     

    -------------------------------------------------------------------------------- -------------------------------

     

    Loaded kernel extensions:

    com.Cycling74.driver.Soundflower (1.6.2)

     

     

    Loaded user agents:

    com.google.GoogleTalkPluginD.83984.4DFC3217-4A43-437C-8487-EBD789CE4B49

    com.paragon.ntfs.upd

    com.paragon.ntfs.trial

    com.google.keystone.system.agent

    com.adobe.ARM.df0ab5bbe6f698196fcc21e3c1e66dcb758bd911f4d637272d9d8109

     

     

    Inserted libraries:

     

     

    User cron tasks:

     

     

    System launchd configuration:

     

     

    User launchd configuration:

     

     

    Login items:

    iTunesHelper

    Dropbox

    VMware Fusion Start Menu

    Plex Media Server

     

     

    Safari extensions:

     

     

    Restricted user files: 502

     

     

    Extrinsic loadable bundles:

    /System/Library/Extensions/Soundflower.kext

    Library/Address Book Plug-Ins/SkypeABDialer.bundle

    Library/Address Book Plug-Ins/SkypeABSMS.bundle

    Library/Internet Plug-Ins/bjninstallplugin_2.4.139.8.plugin

    Library/Internet Plug-Ins/bjnplugin_2.4.139.8.plugin

    Library/Internet Plug-Ins/rbjninstallplugin_2.3.130.8.plugin

    Library/Internet Plug-Ins/rbjnplugin_2.3.130.8.plugin

    /Library/Internet Plug-Ins/AdobePDFViewer.plugin

    /Library/Internet Plug-Ins/Flash Player.plugin

    /Library/Internet Plug-Ins/googletalkbrowserplugin.plugin

    /Library/Internet Plug-Ins/npgtpo3dautoplugin.plugin

    /Library/Internet Plug-Ins/o1dbrowserplugin.plugin

    /Library/PreferencePanes/Flash Player.prefPane

    /Library/PreferencePanes/NTFSforMacOSX.prefPane

    /Library/Spotlight/Microsoft Office.mdimporter

     

     

    Unsigned shared libraries:

    /usr/lib/libgcc_s.10.5.dylib

    /usr/lib/libUFSDNTFS.dylib

     

     

    /Library/LaunchAgents:

    com.adobe.AAM.Updater-1.0.plist

    com.google.keystone.agent.plist

     

     

    /Library/LaunchDaemons:

    com.adobe.SwitchBoard.plist

    com.adobe.fpsaud.plist

    com.google.keystone.daemon.plist

     

     

    /Library/PrivilegedHelperTools:

     

     

    /Library/StartupItems:

     

     

    Library/Fonts:

     

     

    Library/LaunchAgents:

    com.adobe.ARM.df0ab5bbe6f698196fcc21e3c1e66dcb758bd911f4d637272d9d8109.plist

     

    -------------------------------------------------------------------------------- -------------------------------

     

    Loaded system agents:

    com.adobe.fpsaud

    com.google.keystone.daemon

    com.adobe.SwitchBoard

     

     

    Login hook:

     

     

    Root cron tasks:

     

     

    Log check:

    Jan 17 12:35:28  kernel[0] <Debug>: Sound assertion - Command/Response TIMED OUT and ( kRequestStateMatch == fCodecRequest->state = 2 ), fCodecRequest->command->codec: 0xffffff801efdb300, fCodecRequest->command->verb: 0x1F0500, fPoweredDown: 0

    Jan 17 12:35:29  kernel[0] <Debug>: Sound assertion - Command/Response TIMED OUT and ( kRequestStateMatch == fCodecRequest->state = 2 ), fCodecRequest->command->codec: 0xffffff801efdb300, fCodecRequest->command->verb: 0x170500, fPoweredDown: 0

    Jan 17 12:35:30  kernel[0] <Debug>: Sound assertion - Command/Response TIMED OUT and ( kRequestStateMatch == fCodecRequest->state = 2 ), fCodecRequest->command->codec: 0xffffff801efdb300, fCodecRequest->command->verb: 0x1F0500, fPoweredDown: 0

  • 7. Re: camera always not working after installing OS X Maverics
    DaveAinVa Level 1 Level 1 (0 points)

    Using OS 10.9.1 with

    FaceTime HD Camera (Built-in):

     

      Product ID:    0x8509

      Vendor ID:    0x05ac  (Apple Inc.)

      Version:     5.16

    Camera stops working.  Sometimes a reboot, then use Skype pref. to turn on camera.  Sometimes leaving Skype turns off.  Works in PhotoBooth if on after Skype, otherwise, I cannot turn off.

     

    Any permanant fix?

    DaveAinVa

  • 8. Re: camera always not working after installing OS X Maverics
    Suzhouman Level 1 Level 1 (0 points)

    The only way I have found to activate the camera when using Skype with Maverick OS is to "force quit" ALL programs open on my machine and then reopen Skype on its own and then the camera works.  This seems to work for me.

  • 9. Re: camera always not working after installing OS X Maverics
    DaveAinVa Level 1 Level 1 (0 points)

    Yes, Suzhouman, this works. 

    But going to Skype's Prefs, Audio/Video setting turns on the camera and it usually stays on until sleep or shutdown.

    But, APPLE, SKYPE, WHY???

    thanks,

    David