Skip navigation

kernel_task taking up more than 100% CPU

802 Views 4 Replies Latest reply: Dec 17, 2013 7:21 PM by DJWebDUck RSS
shthap3ns Calculating status...
Currently Being Moderated
Nov 30, 2013 2:38 PM

I know this has been asked many, many times, and I've done countless google searches on this, but I'm having this problem. It comes and goes, and seems to be random, usually can be solved by closing off all my browsers, although it takes a little while for kernel_task to die down a bit. It's also not a silver bullet, sometimes closing off all programs doesn't do anything.

 

I've checked all my LaunchAgents and I don't have any heavy modifications to my system. It's just a bit annoying when it flares up from time to time, and it slows my system down to a crawl, which makes getting any work done impossible. I'm a web developer, so I can't just shut off my browsers whenever the problem happens.

 

I'm on the verge of trying a clean install, but I wanted to post here to see if anyone can spot anything weird about my system configuration in my EtreCheck report below.

 

Please help! Thank you!

 

Hardware Information:

          MacBook Pro (Retina, Mid 2012)

          MacBook Pro - model: MacBookPro10,1

          1 2.6 GHz Intel Core i7 CPU: 4 cores

          16 GB RAM

 

Video Information:

          Intel HD Graphics 4000 - VRAM: 1024 MB

          NVIDIA GeForce GT 650M - VRAM: 1024 MB

 

Audio Plug-ins:

          BluetoothAudioPlugIn: Version: 1.0 - SDK 10.9

          AirPlay: Version: 1.9 - SDK 10.9

          AppleAVBAudio: Version: 2.0.0 - SDK 10.9

          iSightAudio: Version: 7.7.3 - SDK 10.9

 

System Software:

          OS X 10.9 (13A603) - Uptime: 0 days 4:43:53

 

Disk Information:

          APPLE SSD SM512E disk0 : (500.28 GB)

                    EFI (disk0s1) <not mounted>: 209.7 MB

                    Macintosh HD (disk0s2) /: 499.42 GB (46.64 GB free)

                    Recovery HD (disk0s3) <not mounted>: 650 MB

 

USB Information:

 

          Apple Inc. FaceTime HD Camera (Built-in)

 

          Apple Inc. Apple Internal Keyboard / Trackpad

 

          Apple Inc. BRCM20702 Hub

                    Apple Inc. Bluetooth USB Host Controller

 

 

          Apple Inc. iPhone

 

          Mitsumi Electric Hub in Apple Extended USB Keyboard

                    Mitsumi Electric Apple Extended USB Keyboard

 

          Apple Inc. Display Audio

 

          Apple Inc. FaceTime HD Camera (Display)

 

          Apple Inc. Apple Thunderbolt Display

 

FireWire Information:

 

Thunderbolt Information:

          Apple Inc. thunderbolt_bus

                    Apple Inc. Thunderbolt Display

 

Kernel Extensions:

          at.obdev.nke.LittleSnitch          (4050 - SDK 10.8)

          org.virtualbox.kext.VBoxDrv          (4.1.23)

          org.virtualbox.kext.VBoxUSB          (4.1.23)

 

Problem System Launch Daemons:

 

Problem System Launch Agents:

 

Launch Daemons:

          [loaded] at.obdev.littlesnitchd.plist

          [loaded] com.adobe.fpsaud.plist

          [not loaded] com.adobe.SwitchBoard.plist

          [loaded] com.google.keystone.daemon.plist

          [loaded] com.microsoft.office.licensing.helper.plist

          [loaded] org.macosforge.xquartz.privileged_startx.plist

 

Launch Agents:

          [loaded] at.obdev.LittleSnitchUIAgent.plist

          [loaded] com.google.keystone.agent.plist

          [loaded] org.macosforge.xquartz.startx.plist

 

User Launch Agents:

          [loaded] com.spotify.webhelper.plist

          [loaded] homebrew.mxcl.mongodb.plist

          [loaded] homebrew.mxcl.mysql.plist

          [failed] homebrew.mxcl.postgresql.plist

 

User Login Items:

          Flux

          iTunesHelper

          gfxCardStatus

          uTorrent

 

3rd Party Preference Panes:

          Flash Player

          SpeedLimit

 

Internet Plug-ins::

          JavaAppletPlugin: Version: 14.9.0 - SDK 10.7 Outdated! Update

          o1dbrowserplugin: Version: 4.6.3.15268

          Unity Web Player: Version: UnityPlayer version 4.2.1f4 - SDK 10.6

          Default Browser: Version: 537 - SDK 10.9

          Silverlight: Version: 5.1.10411.0 - SDK 10.6

          FlashPlayer-10.6: Version: 11.9.900.117 - SDK 10.6

          Flash Player: Version: 11.9.900.117 - SDK 10.6 Outdated! Update

          QuickTime Plugin: Version: 7.7.3

          googletalkbrowserplugin: Version: 4.6.3.15268

          SharePointBrowserPlugin: Version: 14.2.0 - SDK 10.6

          AdobePDFViewer: Version: 10.1.1

          npgtpo3dautoplugin: Version: 0.1.44.29 - SDK 10.5

          MeetingJoinPlugin: Version: (null) - SDK 10.6

 

User Internet Plug-ins::

          CitrixOnlineWebDeploymentPlugin: Version: 1.0.94

          Dashlane: Version: Dashlane 1.0.0 - SDK 10.7

 

Bad Fonts:

          None

 

Old applications:

          Microsoft Alerts Daemon:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Alerts Daemon.app

          Microsoft AutoUpdate:          Version: 2.3.3 - SDK 10.4

                    /Library/Application Support/Microsoft/MAU2.0/Microsoft AutoUpdate.app

          Microsoft Chart Converter:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Chart Converter.app

          Microsoft Clip Gallery:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Clip Gallery.app

          Microsoft Database Daemon:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Database Daemon.app

          Microsoft Database Utility:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Database Utility.app

          Microsoft Document Connection:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Microsoft Document Connection.app

          Microsoft Error Reporting:          Version: 2.2.8 - SDK 10.4

                    /Library/Application Support/Microsoft/MERP2.0/Microsoft Error Reporting.app

          Microsoft Excel:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Microsoft Excel.app

          Microsoft Graph:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Graph.app

          Microsoft Language Register:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Additional Tools/Microsoft Language Register/Microsoft Language Register.app

          Microsoft Lync:          Version: 14.0.2 - SDK 10.5

                    /Applications/Microsoft Lync.app

          Microsoft Office Reminders:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Office Reminders.app

          Microsoft Office Setup Assistant:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Office Setup Assistant.app

          Microsoft Outlook:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Microsoft Outlook.app

          Microsoft PowerPoint:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Microsoft PowerPoint.app

          Microsoft Ship Asserts:          Version: 1.1.3 - SDK 10.4

                    /Library/Application Support/Microsoft/MERP2.0/Microsoft Ship Asserts.app

          Microsoft Upload Center:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Microsoft Upload Center.app

          Microsoft Word:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Microsoft Word.app

          My Day:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/My Day.app

          Open XML for Excel:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Open XML for Excel.app

          SLLauncher:          Version: 1.0 - SDK 10.5

                    /Library/Application Support/Microsoft/Silverlight/OutOfBrowser/SLLauncher.app

          Solver:          Version: 1.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/Add-Ins/Solver.app

          Spotify:          Version: 0.8.8.450.gd9413516 - SDK 10.5

                    /Applications/Spotify.app

          SyncServicesAgent:          Version: 14.2.0 - SDK 10.5

                    /Applications/Microsoft Office 2011/Office/SyncServicesAgent.app

          WhatSize:          Version: 5.1.1 - SDK 10.5

                    /Applications/WhatSize.app

          WhatSize:          Version: 5.1.1 - SDK 10.5

                    /Users/calvin/Software/WhatSize 5.1.1/WhatSize.app

          dynamiclinkmanager:          Version: 6.0.0 - SDK 10.5

                    /Library/Application Support/Adobe/Common/dynamiclink/CS6/dynamiclinkmanager.app

          dynamiclinkmediaserver:          Version: 6.0.0 - SDK 10.5

                    /Library/Application Support/Adobe/Common/dynamiclinkmediaserver/1.0/dynamiclinkmediaserver.app

 

Time Machine:

          Time Machine not configured!

 

Top Processes by CPU:

               2%          WindowServer

               2%          uTorrent

               2%          EtreCheck

               1%          Activity Monitor

               1%          node

 

Top Processes by Memory:

          606 MB             mds_stores

          442 MB             zeus command: server

          344 MB             Safari

          311 MB             Finder

          265 MB             WindowServer

 

Virtual Memory Statistics:

          6.95 GB            Free RAM

          6.77 GB            Active RAM

          785 MB             Inactive RAM

          1.51 GB            Wired RAM

          7.23 GB            Page-ins

          0 B                Page-outs

MacBook Pro (Retina, Mid 2012), OS X Mavericks (10.9)
  • petermac87 Level 5 Level 5 (4,065 points)
    Currently Being Moderated
    Nov 30, 2013 2:46 PM (in response to shthap3ns)

    I would try uninstalling Homebrew for a start, as per the manufacturers instructions, but I don't know how to tell what damage it may have already done or how compatable it even is with 10.9

     

    Cheers

     

    Pete

  • Linc Davis Level 10 Level 10 (107,860 points)
    Currently Being Moderated
    Nov 30, 2013 3:28 PM (in response to shthap3ns)

    The kernel is using excessive processor cycles. Below are some possible causes for the condition.

    Throttling

    When it gets high temperature readings from the hardware, or a low-voltage reading from the battery, the kernel may try to compensate by interrupting the processor(s) to slow them down and reduce power consumption. This condition can be due to

     

    • a buildup of dust on the logic board
    • high ambient temperature
    • a worn-out or faulty battery in a portable
    • the malfunction of a cooling fan or sensor

     

    Note that if the problem is caused by a sensor, there may be no actual overheating or undervoltage.

    If the computer is portable, test with and without the AC adapter connected. If kernel_task hogs the processor only on battery power, the fault is in the battery or the logic board. If it happens only on AC power, charging is causing the machine to heat up. That may be normal on some models. CPU usage should drop when charging is complete.

    The Apple Hardware Test or Apple Diagnostics, though not very reliable, is sometimes able to detect a bad fan or sensor.

    If nothing is wrong with the hardware, then whatever you can do to improve cooling may help.

    Installed software

    User-installed software that includes a device driver or other kernel code may thrash the kernel. That category includes virtualization software, such as Parallels and VMware, as well as most commercial "anti-virus" products. Some system-monitoring applications, such as "iStat," can also contribute to the problem. You can test for this possibility by completely disabling or removing the software according to the developer's instructions, or booting in safe mode. Note, however, that disabling a system modification without removing it or booting in safe mode may not be as easy as you think it is.

    Corrupt NVRAM or SMC data

    Sometimes the problem is cleared up by resetting the NVRAM or the SMC.

    External display

    Connecting an external LCD display to some MacBook Pro models may cause this issue. If applicable, test by disconnecting the display. You might get better results with a newer LED display.

  • DJWebDUck Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 17, 2013 7:21 PM (in response to shthap3ns)

    I was having the same problem but after days of googling I finally found a working solution:

     

         Mavericks System CPU Spikes When Unplugged

     

    It worked for me. Hopefully it'll work for a few of you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.