Skip navigation

delete songs off iphone with ios 7

41765 Views 25 Replies Latest reply: Apr 1, 2014 6:10 AM by diabster RSS
  • bren2019 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2013 5:07 PM (in response to kathmmakin)

    Try going to your music albums, open 1 album and swipe each songs to the left instead of right. It may take time but it works.

  • ahmadtaib10 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2013 7:28 PM (in response to kathmmakin)

    Hey I found that if you select all of your music on your iPhone when it's plugged in and choose to create it as a playlist, it automatically updates your phone and the songs you deleted. Then you can just go back or on your iPhone choose to delete the playlist you just created.

  • hypin7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2013 7:31 PM (in response to ahmadtaib10)

    Experiencing this. iphone 5, 7.0.4.

     

    Can only delete songs manually by swiping left on phone; cannot delete when connected into iTunes.

  • Tony Giordano Level 2 Level 2 (330 points)
    Currently Being Moderated
    Dec 18, 2013 6:02 PM (in response to kathmmakin)

    Since this thread seemed dead-on to my problem I thought I'd post here.

     

    When I turn off "Show All Music" my problem goes away. If I only delete the songs, on my iPhone, I get the download cloud symbol for each song I delete. My question is how did these songs get in the cloud in the first place?

  • rockmyplimsoul Level 5 Level 5 (5,375 points)
    Currently Being Moderated
    Dec 18, 2013 6:13 PM (in response to Tony Giordano)

    Tony Giordano wrote:

     

    My question is how did these songs get in the cloud in the first place?

    You bought them from iTunes, thus they are in the cloud and available to re-download.

  • Tony Giordano Level 2 Level 2 (330 points)
    Currently Being Moderated
    Dec 18, 2013 6:25 PM (in response to rockmyplimsoul)

    Well that's embarrassing . Totally forgot that I did. Thanks

  • lafargeboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2014 8:43 PM (in response to sattycommo)

    PLEASE TO ALL:

     

    to you all having problems removing music from your play list (that has an icloud next to the track

     

    click the link posted below and go to listing #6

     

    http://www.news.com.au/technology/smartphones/really-simple-fixes-for-your-apple -ios-7-problems/story-fn6vihic-1226726240594

     

     

    has simple step by step instructions on how to do it. i done it myself and it works.

    iPhone 5
  • Common iphone user Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2014 8:56 PM (in response to kathmmakin)

    Delete the songs from the all songs lists which you will find in the bottom next to more

    Scroll down instead of searching and then swipe from right to left to delete the song

    Sometimes songs are automatically synced back when connected to the laptop

    To prevent this, connect phone to laptop and then delete songs

    This will solve your problems

  • avstoloff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2014 6:44 PM (in response to kathmmakin)

    None of the above worked for my son's iphone, but the following taken from a news.com.au article did:

    Settings > Music > and toggle the Show All Music button to off.

    This will prevent any music that has been downloaded or that is being stored in the cloud from being displayed your phone.

    Then plug in your phone to your iTunes and sync only the music you want to your phone. Sometimes it’s better if you delete all music from your phone and start again but that’s a personal decision.

    Important: It is essential that you upgrade your iTunes to the latest version (11.1) or iOS 7 will not function properly.

    To check for an update on a Mac open iTunes, click the Apple logo in the top left corner of the screen and select “Check for updates,” download the update and sync your device to your iTunes.

  • bigjohnsta Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2014 12:51 PM (in response to kathmmakin)

    I did the following and posted it on another thread here at Apple. Just trying to help others out.

     

    • iPhone 5c
    • iOS 7.1

     

    1. Go to Settings > General > Usage > Music (loading) > Edit > Tap the red Negative Circle > and tap Delete.
    2. Go to Settings > Music > turn off Show All Music
    3. Go to your Music App, all music should be gone
    4. Plug iPhone back into PC and open iTunes
    5. Go to your iPhone in iTunes and click on the Music tab
    6. Check Sync Music and choose an option below it. I selected Entire Music Library
    7. Re-Sync iPhone

     

    All duplicate music should now be gone.

  • diabster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2014 6:10 AM (in response to bigjohnsta)

    bigjohnsta Thank you very much! you're a life saver..

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.