Skip navigation

Mavericks: Spotlight Indexing Forever!

37118 Views 87 Replies Latest reply: Apr 16, 2014 1:01 PM by mw.overflow RSS Branched to a new discussion.
  • markusm73 Calculating status...
    Currently Being Moderated
    Dec 18, 2013 8:28 AM (in response to sageonthehill)

    The latest update (10.9.1) didn't solve my Spotlight indexing problems.  I had to turn it off again, because it continued eating all my RAM until my machine started swapping.

  • jjspr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2013 11:12 AM (in response to sageonthehill)

    Sorry, I was unclear - with "apparently solved" I only meant: in this discussion thread your problem is marked at the top with "This solved my question". So that looks like you think it is solved.

     

    I did *not* mean, "really solved by some update or other".

     

    Because your system.log shows I/O errors, that highly likely means the slowdown you are or were seeing is being caused by a (slowly) failing harddisk. I would replace that disk quickly, and make sure you have a good backup!

     

    See also for instance:

     

    https://discussions.apple.com/message/23622242#23622242

     

    http://superuser.com/questions/627882/macbook-freezes-console-printing-kernel-di sk0s2-i-o-error

  • GinoTheCop Calculating status...
    Currently Being Moderated
    Dec 19, 2013 1:38 PM (in response to sageonthehill)

    OK I was having the same problem.

     

    I have one SSD where my Maverick 10.9.1 is running and then a HDD with two partitons for my data etc. I am also using an USB external SSD drive for data swapping.

     

    I have a Time Capsule for backups as well.

     

    First I tried adding to "privacy" tab of spotlight my USB drive then removing it as described in this thread but that did not work.

     

    So in my case I believe it was a double trouble as my Time Machine backups were not working either!

     

    What I did was added my external USB and other two data partitions to "privacy" and then removed them from my Time Machine backups as well.

     

    That did the tric and spotight stopped indexing and time machine back up started to work.

     

    The funny thing is I can not search on my data nor back it up!

     

    Funny eh?

     

    Will try sychronized settings on both spotlight and time machin in "exclude" lists to see if that will work. But this is a temporary solution at least for me for now.

     

    Hope this helps some of you guys as well

  • putnik Level 3 Level 3 (620 points)
    Currently Being Moderated
    Dec 20, 2013 1:26 AM (in response to GinoTheCop)

    If the disks are permanently connected, leaving them to index overnight should make things better.   Future indexing would only be minimal unless there is something else going on.  Dropbox syncing of large file collections etc.  I also heard that Norton antivirus background scanning produces thousands of small files, so this kind of activity may contribute to the problem.

  • B. Kennedy Calculating status...
    Currently Being Moderated
    Dec 23, 2013 8:09 PM (in response to sageonthehill)

    I have an external 3TB drive that's been indexing for over a week since I upgraded to Mavericks. My other 2 external drives index fine. The drive with the problem is formatted as ExFAT.

  • GinoTheCop Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 25, 2013 2:19 AM (in response to B. Kennedy)

    My external drive that takes too long indexing is also formatted ExFAT so maybe thats where the problem is.

  • Giorgio118 Calculating status...
    Currently Being Moderated
    Dec 29, 2013 4:53 AM (in response to GinoTheCop)

    Greetings to all, and sorry for any spelling errors, I'm Italian and I use Google translator.

    It 'a long time since I follow this topic because I have your same problems (I), indexing Endless, Time Machine out of order .. I had tried everything, I even opened a practice to Apple but for now no solution.

    In the end, who is in despair I played my last card, even if the support page of Apple, my iMac did not have symptoms that make it necessary intervention (http://support.apple.com/kb/ht1379), in Simply put i reset the NVRAM, I dropped in Spotligh the HD disc in the privacy, and everything is back to normal, now indexing is OK, as well as time Machine does not work anymore.

    If you can be useful to have a late 2008 iMac Intel Core 2 Duo and 4 GB of ram ..

    Let me know if any of you this procedure worked ...

  • nobodyshome101 Calculating status...
    Currently Being Moderated
    Dec 29, 2013 12:26 PM (in response to sageonthehill)

    Hey I/O errros are normally an indication of a failing hard drive. You should make a backup of your data if you havent already and take your computer to an Apple Store or Apple Authorized Service Provider so that they can check your hard drive to make sure its ok.

  • Giorgio118 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2013 1:10 AM (in response to nobodyshome101)

    Already done, the disc is OK, checked for bad sectors, was smart, etc., everything normal.

  • Giorgio118 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2013 1:16 AM (in response to sageonthehill)

    I agree that for us to talk to each dbbiamo still use Google products ...

    But what is worse, that after a few ignition my IMac returned to have the same flaws ... I therefore had to disable Spotlight yet ... If you do not find a solution to downgrade mandatory, I'm really tired of working for a Mac, when it should be the Mac to work for me ..

  • Imtiredofchoosingnames Calculating status...
    Currently Being Moderated
    Jan 14, 2014 8:32 AM (in response to duz10)

    I have an external drive causing this. It's formatted exFAT, which is what SD cards use. The issue may be exFAT compatibility.

  • jalbert.j Calculating status...
    Currently Being Moderated
    Jan 15, 2014 9:50 PM (in response to sageonthehill)

    i had the same problem of infinite time indexing.  my computer was also heating up quite a bit.  i excluded one hard drive partition that was formated as ExFat (from the System Setting->Spotlight->Privacy sections) and the issue went away.  not sure how long it would have taken to index the non-mac partition though...

  • Emmadukew Calculating status...
    Currently Being Moderated
    Jan 18, 2014 7:42 AM (in response to tylerabell)

    Oh, thank you so much for that solution! I was blaming Timemachine rather than Spotlight - and the constant sounds from the HD that it's on were driving me mad!

    I now have silence - bliss

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.