Skip navigation

email identity

127 Views 3 Replies Latest reply: Dec 22, 2013 6:22 PM by randers4 RSS
PapaMagnus Calculating status...
Currently Being Moderated
Dec 20, 2013 3:59 PM

when I send an email from my iCloud account the recipient sees an email from "MobileMe" in their inbox.  I think some of my emails aren't getting through or opened because they don't have my name attached.  How can I change this so my emails have my name name attached?

  • randers4 Level 9 Level 9 (53,115 points)
    Currently Being Moderated
    Dec 20, 2013 5:47 PM (in response to PapaMagnus)

    Are you are talking about the sender's name (the one that appears on the "From:" line on your email message) when using your iCloud email account?

  • randers4 Level 9 Level 9 (53,115 points)
    Currently Being Moderated
    Dec 22, 2013 6:22 PM (in response to PapaMagnus)

    You set the sender name for iCloud email sent from your Mac by going to, signing into your account, opening Mail, clicking the gear shaped icon on the bottom left and choosing Preferences, going to the Accounts tab and entering the name you want to use in the Full Name field and clicking Done.  Then quit Mail on your Mac and re-open it and you sending name should appear in the drop-down list when you compose a new email.


    I'm not sure if that is you problem, but you might check to see if "MobleMe" was somehow listed in the Full Name field in your Mail preferences on


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.