Skip navigation

Warning: SUID file "System/Library/CoreServices" has been modified and will not be repaired.

110605 Views 71 Replies Latest reply: Apr 2, 2014 6:12 PM by BillBlaakk RSS Branched to a new discussion.
  • Cadent Level 1 Level 1 (0 points)

    I stumbled on this thread when searching for this exact warning. I must say that the responses of just "ignore it" do nothing to reassure people who have this problem.

     

    Firstly, why is this error there in the first place? If it's benign and Apple have a list of files where the permissions do not matter (see the linked kb article), why don't they build this exception list into Disk Utility? If they truly believe this is a false positive, they really should exempt it from being scanned and fixed. As it stands, this is just creating needless panic and confusion.

     

    Secondly, how do you know it's benign? ARDAgent.app has been exploited before, so suspicion is not unwarranted. Factor in the raft of RAT exploits out in the wild, this paranoia is even more justified.

     

    While this is the Snow Leopard (10.6) forum, this particular problem still exists in Mavericks (10.9). I have no solution to this, but I know I will be keeping a very close eye on my firewall logs.

  • 55plus Level 1 Level 1 (10 points)

    Hello Cadent,I had big problems with this because when that permisssion is not repaired Apples professional[??] recording sofware "Logic Pro" loses its audio output.

     

    Re installing the OS[10.8 in my case] does fix that but some posters were suggesting that zipping that app might keep it from being modified from outside, I certainly don't need or use it, but am not smart enough to know if that would work.

     

    Yesterday I downloaded an update for 10.8.5 that had a new version of that app, but again apple are not very interested in what they are doing since the unfortunate passing of Steve Jobs, they certainly don't look at these forums and and most people report that only calling them will get any results, the result I got was that I should re install the OS it does work but I too find the support under the present management sub par,to say the least.

     

    You sound like someone who knows a lot more than me so if you think zipping the app would help please post back.

     

    I fear zipping it might change its permissions and mean another 3 hour re install.

  • Roger Wilmut1 Level 9 Level 9 (64,100 points)

    The best place to ask about this would be in the Logic Pro forum.

  • 55plus Level 1 Level 1 (10 points)

    Hi Varjack, this unrepaired permission does cause serious problems if one is using apples so called "Proffessional" app Logic Pro- all audio output is gone[ safari and iTunes still have audio  output] but Logic loses it when this appears in the list of repaired permissions, or should I not say NOT repaired.

     

    I called apple care and was told to reinstall the OS[10.8 in my case] that did put a new copy in place but I don't think I will try repairing permissins again until I have moved some important work to a more dependable system.

     

    I did get an update yesterday that included a new version of the ARD app; it said th it would solve some issues with the firewall, we shall see.

  • magnusalpha Calculating status...

    As mentioned previously by a few people, Disk Utility hasn't been updated recently to reflect certain changes in the OS, and as such they pop up at permission exceptions. They don't cause a problem on their own however.

  • yadavshai Level 1 Level 1 (0 points)

    i have also got this message will it cause any damage.....????

  • Roger Wilmut1 Level 9 Level 9 (64,100 points)

    yadavshai wrote:

     

    i have also got this message will it cause any damage.....????

    Very unlikely. When you do a Permissions Repair you will get a long string of 'errors': as long as at the bottom of the list it says 'Permissions Repair completed' you can ignore them.

  • Barry Clarke Level 1 Level 1 (115 points)

    I just noticed this warning on doing a permission repair and searched and came here.

     

    I noticed that ARDAgent.app was Created September 13, 2013 at 1:16 am

     

    This was modified Tuesday December 3, 2013

     

    Last opened at the same date and time

     

    The Version is 3.7.1

     

    Immediately prior to September 13, the Version was 3.7

     

    At various dates backwadrs the Version was 3.6.x etc

     

    There were modification a few trimes between Version change

     

    I do not use Screen Sharing or Remote Management

     

    Hope this helps

  • Darosicam Level 1 Level 1 (0 points)

    I also have this problem with permissions.  I am running Mavericks.  I decided to try the Repair Permissions facility in Drive Genius 3 because I read above that this problem is directly related to the NON updating of Disk Utility by Apple.  Surprise, surprise,  I get exactly the same result from Drive Genius !

     

    So,  is it a problem or not?

     

    Maybe Drive Genius is simply using already built-in facilities and therefore selling the 'King's New Cloths'.  If that's NOT the case,  then this would appear to be a more serious problem.  If it IS the case,  then maybe further investigation of just what we are paying for might be in order !  It leaves a nasty taste with me if I feel that I am being ripped off,  or misled.

     

    Hope this adds something worthwhile.

  • joema Level 1 Level 1 (0 points)

    Roger Wilmut1 wrote:

    ... as long as at the bottom of the list it says 'Permissions Repair completed' you can ignore them.

    Thanks for helping clarify this. As you said, the Apple KB article says it's normal.

     

    However -- in the interest of accuracy, is it "Permissions Repair completed", or "Permissions verification complete", and does this vary based on whether you're doing a Permissions Verify or Repair?

  • Roger Wilmut1 Level 9 Level 9 (64,100 points)

    'Permissions Verification' consists of checking the disk to list any Permissions errors but does not take any action. 'Permissions Repair' consists of also repairing any errors that can be repaired. You get the 'complete' message relevant to the process you instigated. As said, there are a lot of errors which aren't actually errors and don't get 'repaired'.

  • EDvSchleck Level 1 Level 1 (0 points)

    I would take it serious.

    the same here, exactly as reported before but w. Mavericks 10.9.1 !

    "My MBP just started getting this error and it also has started slowing way down.  Don't ignore the error.  It's clear there is a relation."

     

    For those who wrote

  • 55plus Level 1 Level 1 (10 points)

    I spoke with Apple Care Netherlands[where I live] and they said use the much beter version of disk Utility in the recovery mode and it did repair permissions without damaging Logic pro and I was able to repair my home folders permissions [ACL's ]  there by opening terminal there and typing res and then pressing tab that brught up the reset password box but I didn't want to reset the password and under the reset password box is another for repairing one users home folder,since I am the only user my user name appeared in the correct place and I could repair my home folders permissions-this was advice from Logic Pro entrprise support and it did fix several issues Mr. Wilmut.

  • Mad Dog The Englishman Calculating status...

    Hi everyone

     

    I do love a good debate. The users saying that this message isn't a problem seem to be correct, Apple themselves have confirmed that this is nothing to worry about.

     

    I am posting to support the fact that this is not limited to Snow Leopard where I first came across the problem a few years ago, I am now using Mavericks. After upgrading I ran disk utility to repair my permission which it did, I always re-run it a second time as a 'peace of mind' it's usually unnecessary but that is just what I do. On the second run after installing Mavericks the message appeared.

    This is a random error, sometimes it will appear and others it won't, I have fixed it in the past on Snow Leopard but I can't for the life of me remember which method I used.

     

    For those worried, I would suggest doing a safe boot and running disk utility during the safe boot, but you will find that even after what feels like the problem has been fixed at some point it will randomly re-appear.

  • bibistrikesback Level 1 Level 1 (0 points)

    Good debate, but... I'm a bit paranoid. So the idea to have some unknown stuff that do something isn't really pleasing me, especially in the post Snowden era... This (old) article is giving an interesting hindsight:

    http://www.macworld.com/article/1134165/ardagent.html

    I didn't have though to Zip and just deleted the folder. No more permission issues. But as I said, I'm a bit paranoid...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.