Skip navigation

Mavericks Caching Server Doesn't Work

18580 Views 103 Replies Latest reply: Feb 21, 2014 4:27 AM by Richard Cartledge RSS
  • UKenGB Level 2 Level 2 (270 points)
    Currently Being Moderated
    Dec 19, 2013 5:52 AM (in response to raimattern)

    raimattern wrote:

     

    http://support.apple.com/kb/HT6018?viewlocale=en_US

    What we're saying is that is not happening.

     

    It's quite clear that Apple are claiming that an iOS 7 device, when updating its own apps or software will utilise the caching service. But this is what is NOT occurring. When OSX is doing the downloading, it uses Caching, but iOS 7 does not. At least, not for me and it appears some others and maybe many others who haven't thought to check.

     

    It cannot be anything to do with location etc since both my Mac and iOS devices are all in the same location (within feet of each other), use the same Apple ID and the same (Mac) App Store and Apple agrees they are all in the UK. It cannot be a location problem.

     

    There appears to a problem with iOS 7. It should "just work", but sadly, it "just doesn't".

  • Soubinet Calculating status...
    Currently Being Moderated
    Dec 21, 2013 6:30 AM (in response to UKenGB)

    Same problem for me. The caching is working for all my OSX devices but not for my IOS 7 devices (2 iPhone and 5 iPad). I'm located in China and all my devices are conneced to the same French Apple Store account...

    I have bought a Mac Mini especially for caching, due to poor internet speed connection......

    Searching for help !

  • raimattern Level 1 Level 1 (95 points)
    Currently Being Moderated
    Dec 21, 2013 7:59 AM (in response to UKenGB)

    Can confirm your statement. I wasn't having any problems while updating my ios6 devices. Now the Cache Serice is pretty useless (with iOS devices). But I'm not sure if iOS7 is the root cause . Maybe the 10.9.1 update ?

  • raimattern Level 1 Level 1 (95 points)
    Currently Being Moderated
    Dec 21, 2013 9:35 AM (in response to raimattern)

    Cache Service does work again. Bildschirmfoto 2013-12-21 um 17.55.54.jpg

    iOS 7 is not responsible for the failure of Cache Service.

     

    Server Service Logs:

    Cannot lock /Library/Server/Caching/Logs/AssetCache.pid: Permission denied; is Caching Server already running?

    Unable to save preferences to /Library/Server/Caching/Config/Config.plist

     

     

    Since I changed with chmod the permissions of  these two files, the Cache Service does work again as supposed.
    Know, this is a quick & dirty solution.

    PS

    sudo touch AssetCache.pid

     

    Message was edited by: raimattern

  • shuether Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 21, 2013 9:45 AM (in response to raimattern)

    So iOS 7 devices are using the caching server for you now? Hmm I'll try that out.

  • raimattern Level 1 Level 1 (95 points)
    Currently Being Moderated
    Dec 21, 2013 10:07 AM (in response to shuether)

    Just tested with an iOS7 device again: 100 %

  • UKenGB Level 2 Level 2 (270 points)
    Currently Being Moderated
    Dec 22, 2013 11:01 AM (in response to raimattern)

    A point about raimattern's post of the Caching Service server panel, although it shows iOS Apps being cached, it makes no reference to whether those were downloaded by OSX (iTunes) or iOS. I do NOT have a problem with the former, only the latter. If I use iTunes to update all my iOS apps, everything goes through the Caching Server. But if I try to update an app using the actual iOS device, the download is directly to the iOS device and NOT via the server.

     

    I can see this by watching the traffic through my router as it tells me to where the data is being downloaded, so if it's being downloaded by the Server, or my Mac or an iOS device, it is 100% clear which it is. If an iOS device is downloading updates, ALL the data goes to the iOS device and the server gets NOTHING. This is wrong. When OSX downloads updates, all the data is actually being downloaded by the Server. As I said, it's quite clear what is happening (and what is not).

     

    The issue with permissions raises 2 questions:-

     

    What are the permissions that were apparently wrong and what did you change them to that seemed to make it work?

     

    Why are the permissions only a problem for iOS 7 devices trying to update whereas when OSX downloads updates the permissions are apparently NOT a problem?

  • shuether Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2013 11:07 PM (in response to UKenGB)

    Interestingly, my iOS devices are now using the caching server. I'm not sure whats changed, but the bytes used now increases when I download an app on an iOS device (tewted on iPhone 5s running 7.1b2). Running "sudo serveradmin fullstatus caching | grep CacheDetails" before and after shows an increase in bytes used for IOS Apps.

  • Simon Comeau Maretl Calculating status...
    Currently Being Moderated
    Jan 1, 2014 12:01 AM (in response to t.pawelek)

    Same thing here. It looks like it's finally working correctly. iPhone 5, iOS 7.04, on the Canadian App Store.

  • Simon Comeau Maretl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 1, 2014 12:14 AM (in response to Simon Comeau Maretl)

    As expected, caching doesn't seems to work under iOS 6.1.5 (iPod Touch 4th gen).

  • yesdevnull Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 1, 2014 12:20 AM (in response to Simon Comeau Maretl)

    @Simon Comeau Maretl: Caching Server 2 is for iOS 7 and above.  See http://www.yesdevnull.net/2013/10/os-x-mavericks-server-setting-up-caching-serve r/.

  • UKenGB Level 2 Level 2 (270 points)
    Currently Being Moderated
    Jan 1, 2014 1:56 AM (in response to t.pawelek)

    As for you others, I am now seeing that iOS 7 is caching correctly.

     

    I can be 100% certain that this was NOT occurring but now IS. By watching the traffic through my router, previously I could see that when downloading something appropriate on my Mac, all the data streaming from the Internet was going to the server, but when doing the same thing on any iOS device, the data was going to the device and NOT the server, i.e. caching was NOT working.

     

    Just tried again a download to my iPad and all the data went to the server, so caching is definitley now working correctly to iOS. There is no ambiguity here as I can see exactly to which device the data is being downloaded.

     

    There's been no upgrades to iOS 7, but has there not been an update to Server.app? Whatever, I have changed nothing within my network so it must have been a problem within Apple's software somewhere about which they've been rather quiet and has now been fixed without any admission of guilt. Hey, I'm grateful it's been fixed, but the perpetrators (i.e. Apple) really should put up their hands and say sorry.

  • Richard Cartledge Level 2 Level 2 (435 points)
    Currently Being Moderated
    Feb 21, 2014 4:27 AM (in response to UKenGB)

    Just a heads up, for future googlers, mine didn't work due to the hardware serial number being over 12 characters because our Xserves are running VMWare ESXi hosting Mavericks Server and Windows 2012 server. ESXi gives a 18 character serial number to the OS X VMs which stops cachings erver working. The solution was to update from ESXi 5.1 to 5.5 which pruned the serials to 12 characters. If you server has had a new motehrboard and so a blank serial, you may also have the same problem as me.

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.