Skip navigation

can't scan anymore since Mavericks update

4710 Views 10 Replies Latest reply: Mar 8, 2014 2:59 PM by Da3dalus1 RSS
dark fader II Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 19, 2013 3:10 PM

I use Image Capture to connect to my Canon Pixma MP450 printer/scanner via USB. Never any problem whatsoever until the update to Mavericks.

Printing will still work ( ! ) but Image Capture will tell me there is no scanner connected.

reinstall/reboot/pull out usb... doesn't work. Can't find any drivers on the Canon site.

any help please?

iMac, OS X Mavericks (10.9)
  • Carolyn Samit Level 10 Level 10 (84,145 points)
    Currently Being Moderated
    Nov 19, 2013 3:11 PM (in response to dark fader II)

    Try using the Image Capture app in your Applications folder for scanning.


     

    Connect the scanner to your Mac whether Wi-Fi or USB.

     

    Launch Image Capture.

     

    Click the very small black box Image Cap black box icon asc.jpg bottom left side of the Image Capture window.

     

    You'll see this pop up menu:   Connecting this (device) opens:

     

    You can select a default app to scan (Image Capture) and select a folder from the Imort To pop up menu on the right to save scanned files to.

     

    Mac Basics: Using a scanner

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 19, 2013 3:48 PM (in response to dark fader II)

    The last scanner driver that Canon released was for 10.7. You may be able to install and use this driver on 10.9, but to install it you will have to get past Gatekeeper because the driver is not signed. To do so, Control-click on the Installer and select Open from the pop-up menu that appears. You will now be given the option to install the driver.

     

    Here is a link to the scanner driver.

     

    With the driver installed you will need a scanning application. Image Capture requires an ICA driver and as Canon has not released one for this model for 10.9, you will not be able to use this application. So you could see if Canon's MP Navigator application will install and operate. Like the scanner driver, it was last updated for 10.7 so you will have to use the same procedure to install it on 10.9.

     

    Here is a link to MP Navigator v2.0.7

  • Richard Gilpin Level 2 Level 2 (165 points)
    Currently Being Moderated
    Dec 13, 2013 12:39 PM (in response to Carolyn Samit)

    I have perhaps the same problem.  I use a UMAX Astra 1220u.  It's old, but until Mavericks, it worked.  I have installed Matthias Ellert's SANE v. 3.2.   That software does not work.

     

    I have followed Mr. Ellert's recomendation to use Terminal:

     

    Start the Terminal application (it should be located in the Utilities folder within the Applications folder), then type in the Terminal window the command:

    scanimage > test.pnm

     

     

    Terminal does scan my documents.   But Terminal is rather limited as a scanning application.   My scanner won't work with Image Capture or Vue Scan.   Both of those applications report that they cannot find the scanner.   And the "Printer & Scanner" Preference does not see the scanner, either. 

     

    Any gueses as to how to get a proper scanner application to see the scanner?  TIA

  • hansyd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 19, 2013 2:18 PM (in response to PAHU)

    Yep, dark fader's right, you rock. Thanks

  • mgw1970 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 1:47 AM (in response to PAHU)

    PAHU has the best solution (cheers!!):

    You need this 2 steps approach, first download the Mac OS software file via Canon: mpnosx207ej7.dmg and before installing use CTRL -CLICK FILENAME and then Open (rightmouse click) the file to install. This works fine.

    Next step is to download right (latest) driver file via Canon which is:  msd_-mac-mp450-12_13_3-ej7.dmg. Also use the procedure to CTRL - CLICK FILENAME and then Open (right mouse click) the file to install.

    Ready to scan again. Thanks and happy with this Apple support posts!

  • Mitchell Hennes Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 24, 2014 11:56 AM (in response to PAHU)

    Fixed mine too! Thanks for the simplest correct solution.

  • sqwark Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2014 7:44 PM (in response to dark fader II)

    Try this URL. Basically it is the way to reset the printers on your iMac 10.9.1. The first reset reinstals the scanner on the Scanner & Printer Preferences page. The next step is to add another printer icon. On the Add page a Canon MP495 series AND a Canon MP495 series xxxxxxxxxxxx wil both show. The first is the Scanner the second is the Apple installed Printer vide Bonjour the second is the Printer (thanks??? to Canon).

    Hope this helps as I discovered this URL by chance.

    P.S. Of course you need to have the latest MP495 scanner and printer drivers off the Canon/downloads&drivers site (as per above post) on your machine. Hope this is not the way of the future with Apple updates.

     

    http://www.justanswer.com/printers/5t3kl-need-know-setup-canon-mp-495-mac.html

  • Da3dalus1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2014 2:59 PM (in response to dark fader II)

    I found this great step-by-step video on YouTube to install old Canon drivers and utilities in Mavericks.  My MP450 prints and scans, and MP Navigator 2.0 works fine:

     

    http://www.youtube.com/watch?v=OWnYeAniGUo

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.