Skip navigation

Thunderbolt disconnects when MacBook sleeps

8333 Views 73 Replies Latest reply: Apr 13, 2014 6:55 PM by Richroller RSS
  • skiphunt Calculating status...
    Currently Being Moderated
    Dec 20, 2013 10:42 AM (in response to nicosen)

    I've been battling this problem for over a month. Nothing has worked and I'm on my 3rd thunderbolt display. Apple support suggested I restart in recovery mode, repair disk & permissions. I thought this worked but it only lasted for a couple days before it came back. I'm running 10.9.1 and that didn't solve it either.

     

    Just tried this yesterday. pmset yesterday morning. So are, so good.

  • Braden Brook Calculating status...
    Currently Being Moderated
    Dec 20, 2013 10:52 AM (in response to g8k3pr)

    I applied the setting several days ago and haven't had any issues at all.

    Thanks for saving me a trip to the Apple store, g8k3pr.

  • Stjerne Calculating status...
    Currently Being Moderated
    Dec 22, 2013 1:38 AM (in response to One of the users)

    Yes, I have applied it two days ago, and I haven't had any problems since setting the hibernatemode to 0 on 10.9.1.

     

    5 of my colleages with Thunderbolt displays did the same. They are all working now.

     

    I don't understand that a problem introduced with OSX 10.9 is not solved yet by Apple.

  • skiphunt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 23, 2013 4:17 PM (in response to nicosen)

    Well, at the risk of jinxing it... it's now been 5 days since I did the pmset to 0, and have had no problems at all. As a matter of fact, I was having a second problem as well, that the power port wasn't always recognizing and lighting up to charge until I'd plug and unplug the magsafe 2 a couple times.

     

    After the pmset to 0, that problems went away as well. YES!!!

     

    Does anyone know of any potential downsides of having the pmset to 0?

  • One of the users Calculating status...
    Currently Being Moderated
    Dec 23, 2013 6:08 PM (in response to skiphunt)

    So far, the only downside, for me at least, is the declining faith in:

    1. Apple's testing capabilities,
    2. Apple's Release management (the solution seems very, very simple and trivial - how hard is it to implement it in 10.9.x?), and finally
    3. Apple's customer relations.  It's their tendency to be so isolated from the end users (one thing Microsoft is better than Apple - is their transparency when a known defect exists - they would just say it on the MS website so no need to guess if you're doing something wrong if there is a bug).

     

    Lessons learned: after a major release, go to Apple's forums to see what people struggle with and... wait for the 2 minor releases down the road.  BTW, I can tell you now what the issues will be next: WiFi and sleep...  as always.

     

    Good luck everyone. 

  • riflores Calculating status...
    Currently Being Moderated
    Dec 26, 2013 4:53 PM (in response to g8k3pr)

    g8k3pr. It's been over a week since I applied your solution and I have not had any problems. Thanks!!!

     

    Curious...how did you find this solution?

  • g8k3pr Calculating status...
    Currently Being Moderated
    Dec 27, 2013 5:12 AM (in response to riflores)

    Well, I suspected that the problem was with sleep mode set to 3 (the default) because of the way it stores a backup copy of memory contents to disk in that mode.  And, since most new Macbook Pro/Air computers now come with Flash storage by default, there is very little time delay with reading and writing that information from/to disk.  However, with an older Macbook Pro, which does have a normal hard drive (mine is a 750 GB 7200rpm disk), they must have changed something in Mavericks with respect to the timing and disk access.  It is for this reason, I hypothesize that setting the sleep mode to 0 helps. I say this because by taking the disk access out of the picture, it seems to remedy the issue (even if it is just backing up memory contents in mode set to 3).  And while this is fine for when I use my MBP as a desktop machine attached to my TBD and always plugged into power, it may not be the best solution when I'm on the road.  It's for this reason I'll tend to set it back to 3 or 25 (Hibernate mode) for peak battery performance when using it as a laptop.

     

    You can view the man page for pmset here but the main explanation of each of the three main settings from the Apple site man page follows:

     

    • hibernatemode = 0 (binary 0000) by default on supported desktops. The system will not back memory up to persistent storage. The system must wake from the contents of memory; the system will lose context on power loss. This is, historically, plain old sleep.
    • hibernatemode = 3 (binary 0011) by default on supported portables. The system will store a copy of memory to persistent storage (the disk), and will power memory during sleep. The system will wake from memory, unless a power loss forces it to restore from disk image.
    • hibernatemode = 25 (binary 0001 1001) is only settable via pmset. The system will store a copy of memory to persistent storage (the disk), and will remove power to memory. The system will restore from disk image. If you want "hibernation" - slower sleeps, slower wakes, and better battery life, you should use this setting.

     

    Hope that helps explains things.

  • skiphunt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 27, 2013 7:18 AM (in response to g8k3pr)

    Thank you so much for sharing this! I took back 3 different TBDs, made one trip to the "genius" bar, and another long phone support call. I was ready to believe BestBuy that the problem was my MBP's graphic card that had just gone out of warranty. The pmset has solved ALL of my problems for over a week now.

     

    Apple should give you some props, or a cookie, or something dang it!. Also, would be cool if there was a simple app to quickly change the pmsetting without having to copy/remember the string. I'd gladly pay for that since I'd like to quickly set to 25 when traveling and not using my TBD.

     

    Thanks again for sharing your findings on this and saving me any more unnecessary aggravation.

  • g8k3pr Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 27, 2013 8:37 AM (in response to skiphunt)

    Your very welcome.  Believe me, I too struggled with this issue for many weeks before coming up with this solution. And, your wish for an app is my command and it's free

     

    You can download a quick little Applescript Application called SetSleepMode.  You can download the zip archive containing the app and script here:

     

    https://dl.dropboxusercontent.com/u/2534919/SetSleepMode%20AppleScript.zip

     

    that I wrote (complete with AppleScript source) that you can run anytime you need to change the sleep mode.   It's simple but effective.  Once you launch the app, it will ask for your password so it can execute "pmset" command using sudo.  After it runs the command with the selected mode, you are all set.  I have confirmed it works by calling "pmset -g" from the command line to verify the "hibernatemode" is set to the selected value I chose. Enjoy!

     

    Stuart

  • skiphunt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 27, 2013 10:02 AM (in response to g8k3pr)

    Awesome! Thanks again!

     

    You're like some kind of Apple Jambi Genie! http://www.youtube.com/watch?v=C-LLCpM27WE

  • Glymph Calculating status...
    Currently Being Moderated
    Dec 30, 2013 7:26 PM (in response to nicosen)

    Thanks g8k3pr!!  You are truly a life saver.  I have returned by TBD to Best Buy 3 times over the Christmas holiday and no one could solve the problem.  Not only did you come up with a solution, you also created a trusted app to solve the problem.   I just used the app and problem fixed!!!  

     

    Can't thank you enough!!

     

    Have a great Holiday Season.

  • Brian Mull Calculating status...
    Currently Being Moderated
    Jan 1, 2014 8:35 PM (in response to g8k3pr)

    So after you run this script, is there anything else that needs to be done? I've tried reconnecting and restarting. I've tried completely unplugging the display. I've tried unplugging and replugging the Thunderbolt cable. My display still won't wake up when my air is plugged into it. I did run script and set to 0.

  • Karl Kaufmann Calculating status...
    Currently Being Moderated
    Jan 2, 2014 5:42 AM (in response to g8k3pr)

    Thanks--your suggestion did the trick for me.

     

    It's been about a week now since applying that solution, and so far, so good, including waking from sleep, removing the MBP and redocking, and restarts.

     

    At least the frustration is finally over, for now.

  • Kibuk Calculating status...
    Currently Being Moderated
    Jan 8, 2014 1:21 AM (in response to nicosen)

    I have same problem with an Acer display connected to Mac MIni mid 2011 using DVI -> Thunderbolt adapter.

    The problem appeared when upgraded to Maverick, never before with Lion. Any time the system goes to sleep the display doesn't wake up.

     

    Hibernatemode 0 doesn't work for my Mac Mini.

  • schreibers Calculating status...
    Currently Being Moderated
    Jan 12, 2014 5:46 AM (in response to nicosen)

    Thanks for everyone's contributions regarding this issue.

     

    We have two Mid 2012 MBA's in our household which were running ML.  On either MBA we would use a Monoprice TB to HDMI adapter plugged into our Sony LCD to view BR movies and stream content via an extended desktop setup.

     

    Once we upgraded to Mavericks we were no longer to do this on either MBA.  Post upgrade if we plugged in this same cable arrangement into any of the 3 HMDI inputs on our TV, the TV would not even recognize anything was plugged in which to me signified the TB port was somehow asleep/off. 

     

    Like many I tried different accounts/SMC reset/etc.  I did run the hibernation 0 script but this did not completely resolve my problem. 

     

    Now when I plug this setup in my TV does recognize a source! Yay!  My MBA screen also "flickers" like it's trying to switch.  However my TV does not detect any signal nor do I get the standard extended display background on my TV like we used to Pre-Mavericks.  There are no additional displays shown under Display Settings and I have tried checking/unchecking "Displays have seperate spaces" under Mission Control settings to no avail.

     

    I've tried different HDMI cables (though I just have the one TB to HDMI adapter), however I find it hard to believe the issue lies in anything other than our MBA's.

     

    Thanks for your suggestions!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.