3 Replies Latest reply: Feb 5, 2014 2:26 AM by thedems
Tim Baker Level 2 Level 2 (280 points)

Ever since upgrading to Mavericks, my Exchange account is listed twice under my calenards (so I'm seeing to instances of each event under it). I'm able to deselect one of them from view as a temporary workaround but would love to have just the one.

 

When I go to my internet accounts settings under system preferences, there's only one entry for Exchange there. Any ideas?

  • 1. Re: Exchange Account showing up twice in calendar
    reggiem3 Level 1 Level 1 (10 points)

    Tim,

     

    I have the same issue. Although I couldn't get rid of the duplicate account, I was able to disable one of them from appearing in the Calendar app by doing this:

     

    1) Opened the Calendar app

    2) Went to the "Calendar" file menu and clicked on "Accounts".

    3) Click on the exchange account and uncheck the "Calendars" (don't worry, we'll re-enable this later)

    4) Close the Internet Accounts window and go back into Calendar. You'll see that you'll only have ONE instance of your Exchange calendar enabled and that one is the duplicate.

    5) Go back to the "Calendar" file menu and select "Preferences".

    6) Click on the "Accounts" button

    7) You'll see the only enabled Calendar for your exchange, click on it and uncheck the "Enable this account" option.

    8) Lastly, go back to where you were in Step 2 and 3 and re-enable the "Calendars" option.

     

    I unchecked the "Calendars" option in step 3 rather than just going to step 5 is because I wanted to make sure that I was using the Calendar associated with the one from the System Preferences - Internet Accounts. Hope this helps you! I did this for both my iMac and MacBook Pro and days later still working!

  • 2. Re: Exchange Account showing up twice in calendar
    fance Level 1 Level 1 (5 points)

    I have the same issue and found the same partial solution, the reason I say partial is that Calendar appointments arent always showing up now...

     

    Anyone logged a defect?

  • 3. Re: Exchange Account showing up twice in calendar
    thedems Level 1 Level 1 (0 points)

    Hi reggiem3,

     

    I had the same Issue and found the same way around but there is still some "cosmetic" defect:

    The second exchange Account stays there in Calendar Preferences grayed out undeleteable.

    Any idea how to repair this totally?

     

    TIA,

    dems