Skip navigation

"Ghost" Songs Create Sync Error in iTunes

19844 Views 36 Replies Latest reply: Mar 16, 2014 10:25 PM by xoxoboi24 RSS
  • r.hudson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 11, 2012 12:57 AM (in response to rockmyplimsoul)

    I had this problem today so here's what I did. I'm not sure if this is going to help anyone BUT after not having iTunes Match turned on on my iPhone when I synced etc I went into settings turned on iTunes Match along with the other 2 options it consequently reveals. I then checked my iTunes library on the phone and the albums weren't there so I went back and turned off iTunes Match, 'checked' those albums in iTunes on the Mac and resynced them and Voila! No ghost albums!!

     

    I hope this helps someone.

  • duncboy Calculating status...
    Currently Being Moderated
    Sep 9, 2012 7:53 AM (in response to rockmyplimsoul)

    So I've had this problem for a number of months and have searched all over the web trying new things to no avail - resyncing, unsyncing, deleting, resetting my phone, yada yada yada.  For some people those things worked, for me they did not....and then I figured out something else to try.

     

    1. On your iphone, goto iTUNES (not your Music, but iTUNES)

    2. In iTunes, goto More > Downloads

    3. Delete the downloads causing duplicate songs in your Library here - you can delete a song by swipping your finger across the song name in the list of downloads. 

     

    For me, this is what was causing the duplicates.

  • leeg330 Calculating status...
    Currently Being Moderated
    Sep 20, 2012 3:55 AM (in response to rockmyplimsoul)

    So after a lot of messing around with iTunes on my mac and iPhone I finally got rid of them (ghost songs in iTunes that aren't showing on iPhone). Hopefully this will help other people too.

     

    I followed the instructions in another thread and downloaded a program called PhoneView (the demo version worked fine, no need to pay).

     

    Connect your iPhone to mac, open PhoneView, go to Settings>Show entire disk. Here I would recommend you back up all the contents of your phone.

     

    Now this isn't my most technical piece of work but I went on a bit of a deleting spree (again make sure you've backed up everything).

     

    I deleted the contents of the following folders:

    Purchases,

    Downloads,

    iTunes Control>Sync>Media,

    iTunes Control>Music


    Then I deleted the following files from iTunes Control>iTunes:

    MediaLibrary.sqlitedb
    MediaLibrary.sqlitedb-shm
    MediaLibrary.sqlitedb-wal

    (and maybe a couple of others but these are the ones I remember).

     

    I then reset the iPhone (Hold the Home and Power buttons for 5 secs), synced with iTunes and they had gone. Rejoice.

  • peter.j.kim Calculating status...
    Currently Being Moderated
    Sep 30, 2012 8:57 AM (in response to leeg330)

    Thank you, leeg330! Your advice (Sep 20, 2012 3:55 AM) worked!

     

    I used i-FunBox instead but any iPhone file manager application will work for this issue. Also, I just had to delete the 'Purchases' folder to remove all the "ghost" songs. Thanks, again!

  • Lowpro71 Calculating status...
    Currently Being Moderated
    Dec 22, 2012 12:29 PM (in response to leeg330)

    Thanks leeg330.  Your suggestion worked for me as well.  Finally got rid of several ghost music entries on my iPhone which I was unable to remove via any other method short of a restore.  Thanks again!

  • AppleLiv Calculating status...
    Currently Being Moderated
    Dec 29, 2012 6:36 AM (in response to rockmyplimsoul)

    the second one made ALL of my music become grey :/

  • Yin26 Calculating status...
    Currently Being Moderated
    Apr 29, 2013 11:07 AM (in response to duncboy)

    Thank you!  This was exactly what solved this problem for me.

     

     

    duncboy wrote:

     

    So I've had this problem for a number of months and have searched all over the web trying new things to no avail - resyncing, unsyncing, deleting, resetting my phone, yada yada yada.  For some people those things worked, for me they did not....and then I figured out something else to try.

     

    1. On your iphone, goto iTUNES (not your Music, but iTUNES)

    2. In iTunes, goto More > Downloads

    3. Delete the downloads causing duplicate songs in your Library here - you can delete a song by swipping your finger across the song name in the list of downloads. 

     

    For me, this is what was causing the duplicates.

  • Harry Brindley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 1:43 PM (in response to rockmyplimsoul)

    I too have suddenly have sync problems with music between my Mac iTunes 11.1.3(8) on my iPad mini under iOS 7. Many of my tunes show up as "ghost songs" on my iPad. I initially had a problem with Movies and TV Shows not syncing up (they showed up with zero byte length) so I restored from backup -- which fixed my video problem but then created the Music nightmare.

     

    I can't vouch for whether this proposed solution will stand the test of time, but I've managed to get back all my PURCHASED songs that were ghosted.

     

    On your WiFi connected device (iPad or iPhone) launch your iTunes app (not the Music player app). I did not have my device tethether to my Mac, my device was logged into my iTunes account and it had an active WiFi connection.

     

    Launch iPad iTunes ...

    Purchased>Music

    Select "Not on this iPad" then "Download All"

    ... wait for the download to complete.

     

    Launch iPhone iTunes ...

    More>Purchased>Music

    Select "Not on this iPhone" then "Download All"

    ... wait for the download to complete.

     

    After you sync with your Mac you'll see that for many of your "ghost songs" you have a duplicate real song -- so I do not think this is elegantly fixed. Fortunately my Playlists all still work in spite of the ghosts.

  • Harry Brindley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 3:10 PM (in response to rockmyplimsoul)

    @https://discussions.apple.com/people/rockmyplimsoul

     

    Yes, I believe so, to the first and when my iPad is tethered to Mac iTunes, where I once saw mostly ghosts in my Music library, I now see the ghost and a duplicate by the same name (presumably from the purchased download I just got from the cloud). I got back nearly 180 songs, most of which I still wanted.

     

    You could selectively download which songs to download from the cloud but what a schlep that would be -- for me, anyway.

  • noelboling03 Calculating status...
    Currently Being Moderated
    Jan 7, 2014 12:00 PM (in response to rockmyplimsoul)

    I NEED HELP! I have tried deleting some of my purchased music and it still shows up on my ipod through my iphone. It has a little icloud download next to it, but doesnt show up on my itunes account through my lap top when I log into itunes. I went to my "downloads" setting through my phone and they're all listed there under "purchased" and "not on this iphone" , I just want to know how to delete them completely. I also have two or three songs that are showing up on my ipod, however not my itunes account through my lap top.

  • FrankiLogan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2014 7:49 PM (in response to rockmyplimsoul)

    Thank you for "Settings/ General/ Usage/ Music, then swipe across "All Music" and press Delete" That fixed my issue and it was driving me crazy!

    F.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.