Skip navigation

Dyld Error Message: Symbol not found - ruby not working - what's wrong?

354 Views 6 Replies Latest reply: Jan 7, 2014 1:47 PM by Schurrle RSS
Schurrle Calculating status...
Currently Being Moderated
Jan 7, 2014 8:47 AM

Hi,

 

I'm relatively new to using Mac. My OS is 10.5.8. Yesterday I tried to install Tunnelblick but it did not work properly so I used the Tunnelblick Uninstall Disk Image to remove it.

 

However, now when I boot up my Macbook - I receive an error messages saying that 'the application ruby has quit unexpectedly' and prompting me to relaunch, ignore or report.

 

Here is the report associated with the error:

 

Process:                ruby[128]

Path:                      /Users/N/.pia_manager.app/Contents/MacOS/osxruby/ruby

Identifier:               ruby

Version:                 ??? (???)

Code Type:            X86 (Native)

Parent Process:     ruby [98]

 

OS Version:           Mac OS X 10.5.8 (9L31a)

Report Version:     6

 

Exception Type:    EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0

 

Dyld Error Message:

  Symbol not found: _getgroups$DARWIN_EXTSN

  Referenced from: /Users/N/.pia_manager.app/Contents/MacOS/osxruby/ruby

  Expected in: /usr/lib/libSystem.B.dylib

 

 

 

Could someone please tell me how to fix this?

 

Thanks

MacBook Pro, Mac OS X (10.5.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.