Skip navigation

Roland PC-300, not supported by Lion?

10592 Views 47 Replies Latest reply: Mar 9, 2014 2:17 PM by Miss Bailey RSS
  • Petturur Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2013 1:28 AM (in response to Petturur)

    Sorry. It works now, i just had to delete RDUSB. Thanks!

     

    P

  • wehateyou Calculating status...
    Currently Being Moderated
    Dec 22, 2013 10:25 AM (in response to Grant Mac)

    HI Guys,

    does anyone know if this the xcode work around will work for 10.7? I know that xcode 5 wont work below 10.8, but am downloading 4.0.6.

    Just bought one of these keyboards, and it wont work!!!!!!!

    thanks.

    b..

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2013 12:09 PM (in response to Grant Mac)

    Sorry, me again.

    I have followed all the instrutions, and just can't get it to work. Very much a newbie on Xcode, but have found the .plugin in the developer folder and put it into the system library. Tried deleting the RDusb plugin. nothing!

    Any ideas?

    I have also tried plugging the PC300 midi out into my Audio kontrol 1 midi in, and nothing seems to be coming out. Also tried changing the USB cables. Is there a reset i need to do on the PC300? .

     

    When I bought it (second hand) the guy had it plugged into his (white ibook) mac and it worked, every key!

    I am doomed? Should i just get rid of it to a PC user?

     

    so close to admitting defeat!

     

    AAAARGH!

     

    b..

  • Ehtalas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2013 11:38 AM (in response to wehateyou)

    Hi b alias wehateyou,

     

    Do you use GarageBand or Logic to test the keyboard?

     

    Have you copied the file GenericUSBMidi.plugin to your Macintosh HD -> Library -> Audio -> MIDI Drivers?

     

    After having copied the file to this path, the only thing you need to do is to Shut Down and Reboot your Mac. Then open for example GarageBand and your Keyboard should work.

     

    Just describe a little more the things you have tried. Maybe I can help.

     

    PS: why do you have such an angry nickname?

     

    Best,

     

    Yves

     


  • Ehtalas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2013 11:46 AM (in response to wehateyou)

    other things that came to my mind

     

    - you need to create a new project in GarageBand such that the keyboard works.

    - have you switched the keyboard to the ON (USB) mode?

    - have you turned up all possible volume controls?

     

    The solution to technical problems is almost always quite simple (remove the bug) but finding the bug is hard.

     

    Regards,

     

    Yves

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 12:52 AM (in response to Ehtalas)

    Ha ha, It's an old name I used to DJ and run parties under, it's the only one I could think of thast wasn't taken! It's tongue in cheek, I promise!

     

    I am running Lion 10.7.5 on a MacBook Pro

     

    I have checked that the plugin is in HD>LIBRARY>AUDIO>MIDI DRIVERS (i moved it in there, didn't copy it. Should it still be in the developers folder too..?) Should I copy it to the user library aswell?

     

    Initally was using Ableton Live Suite 9.1 (as you can see midi messages recieved across all channels) but have tried it with Garage Band too and nothing. THere is power going to the keyboard.

    THe only way I have had it working is to install the roland drivers on my old Ibook and then run midi out into my Audio Kontrol 1, which is a faff to say the least! Have checked all leads and switches.

     

    In Xcode 4.6 I opened your proj file, then clicked play. I then found the .plugin file in the developers folder in finder and moved it out. I didn't archive anything in Xcode.

     

    Thanks so much for taking the time to make the plugin and also replying to this cry for help. I bet this is like when i have to talk my mum through using Skype!

     

    b..

  • electronicwomble Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 1:11 AM (in response to wehateyou)

    Have you made sure there are no other plugins in the midi drivers folder? Sounds a weird fix, but that got it working for me!

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 1:44 AM (in response to electronicwomble)

    WIll that not mess up the other things i use? I also have a Novation remote 25SL  (though that does work through Atuomap) and am using an Audio Kontrol 1 (but dont use the buttons on that)

     

    I'd LOVE to get this thing working, its exactly what I want/need! **** Roland for not updating the drivers. How can they possibly justify it...?!?!

  • electronicwomble Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 1:54 AM (in response to wehateyou)

    I don't know. Make a backup, give it a try and see if it works!

     

    It would be nice if Roland supported their older products.

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 2:08 AM (in response to electronicwomble)

    My god! IT WORKS!!!!!

    So pleased.

    Thanks so much for your help guys. I will credit you on the first number one produced on the kyeboard !( I am surre it will happen....)

     

    Thanks Yves and Electronicwomble. You are the best.

     

    I could kiss you.

    b..

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 9:06 AM (in response to Grant Mac)

    One last question, will this fix work if I upgrade to Maverick? Has anybody tried?

    Thanks.

    B.

  • electronicwomble Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 10:15 AM (in response to wehateyou)

    Haven't updated myself, mainly because i'm expecting loads of incompatibilities. Would be interested to know though!

  • wehateyou Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2013 11:41 AM (in response to electronicwomble)

    My brother has just updated. Will try and get him to install the plugin and will let you know how it goes!

  • Ehtalas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2013 11:07 AM (in response to wehateyou)

    I tried it recently with Mavericks and it worked without any problems. I didn't have to recompile the plugin, it worked right away. Then I recompiled it and it still worked.

     

    Yves

  • bexjones Calculating status...
    Currently Being Moderated
    Jan 7, 2014 3:31 PM (in response to Ehtalas)

    Hi Yves,

     

    Thanks very much for making the generic driver - much appreciated!

     

    I think it's almost working for me, but still not quite there.

     

    I have a 2011 MacBook Pro running Mavericks, and a Roland PC-300. In "Audio MIDI Setup" I can see the a device called "Roland PC-300 USB Keyboard" so it seems like it's connected. In GarageBand preferences, I can see "1 MIDI Input(s) detected". However, nothing happens when I press keys on the keyboard. I must be doing something simple wrong. Any pointers for things I could try to complete the final step?

     

    thanks!

     

    Bex

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.