1 2 3 4 Previous Next 46 Replies Latest reply: Mar 24, 2014 11:47 AM by BDAqua
Adam Simpson5 Level 1 Level 1 (35 points)

Hello everyone

 

 

I should firstly add that I have been having display trouble for a few years now (only showing video after a few restarts), so this may have something to do with what happened the other day, which is as follows:

 

 

I was online but on the phone to a friend, then all of a sudden the fans of my PowerPC G5 started going wild, as if the room temperature rapidly increased (I've had this issue before too). The screen cursor from my tablet pen (little arrow) was frozen (don't recall this happening for a long time), so the only thing I could do was a forced restart from the main power button at the front of the G5. It did start up again, but with messed up video (as if I pulled the power cable out of a TV). I thought not to worry, as I usually have video issues and a few restarts usually sorts it out, however the next forced restart produced no video (just a black screen) and more to my concern, no white light or start up chime! Following restarts have been the same.

 

 

There is a start up sound when I press the power buttton (I think maybe some brief fans as well), but no light or that power on chime noise. My feeling is that I now have the original video issues combined with a failure of somekind! Please help as I am really worried that this might be something serious.

 

Does this sound fixable to you guys??

 

Thanks for reading,

 

Adam


PowerMac, Mac OS X (10.5.8), PowerPC G5 1.6GHz
  • 1. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    Hi Adam,

     

    Have you blown the dust out of it lately? Especially the Graphic card, Power Supply, & CPU heatsinks?

  • 2. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hello BDAqua, and thanks for your reply.

     

    Interesting you mention dust, as I have been thinking of that, my G5 is not totally covered at the back, where the PCI slots are. I'll open it up and have a look. It'll be great if that resolves it!

     

    Apart from that, I have some updates. I disconnected everything from my G5, just plugged my G5 into a wall socket (previously it was plugged into an extension). Pressed the power on button, first time it started the same way, no chime or light, but the second time it started with the chime and light! Then it kept on starting like this so I had a go at connecting the cinema display back, to see if I could get an occasional video start up.

     

    On the first power up, the light and chime worked, but no video on the display, just black. On the second attempt, the problem returned with no light or chime (or video). I disconnected the display again and powered up, still no chime or light. Could connecting the display be making matters worse?

     

    Next morning, with display disconnected, G5 starts again with chime and light (as if it recovered from display cable infection).

     

    As there was occasionally no light/chime, even with the display disconnected, I'm not sure where the problem is rooted. I read an article saying that I should change my video card, if video only comes on after a few restarts (problem I've had for years prior to these new issues). Could it be that an issue between video card and display, when left unresolved for years, has now begun to affect the general start up of my G5? The article said if I have card model ATY,RV350, I may need to replace it, and that's what I have. I'm wondering if this is the root cause, but I'll have a look at the dust, and maybe try resetting PRAM, NVRAM and PMU.

     

    Thanks for your help.

  • 3. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    Adam, do do the dust first thing.

     

    Might be time to replace the PRAM Battery, 4 years is close to their lifespan, far less if ever without AC power, & can cause strange startup problems...

     

    See which one your G5 has...

     

    http://eshop.macsales.com/item/Newer%20Technology/CR2032/ 

     

    http://eshop.macsales.com/item/Newer%20Technology/BAA36VPRAM/

  • 4. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hi again BDAqua, I gave my G5 as good a clean as I could yesterday, there was a lot of dust inside. I couldn't reach everything so there was a lot of blowing lol.

    Afterwards, I powered up the G5 without the display connected. I had the power light and chime (chime not on every restart though). I also connected my keyboard and noticed that the computer didn't seem to respond to the keyboard, no caps lock lights or eject button working.

    I then tried to start up with the display connected. This seemed to knock out the power light on the G5, no start up chimes or video either, just a sort of half-hearted power up sound. Also, after a few minutes, the fans start going crazy!

    Okay, so the cleaning hasn't seemed to work. I haven't replaced any batteries ever (bought it in 2005) so I'll give that a go, thanks.

    If that fails, would you recommend me trying the video card replacement, or do you think that has nothing to do with start up chimes and lights?

    Thanks for bothering to help out!

    Adam

  • 5. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    Whew, it could easily be the Video card, but sadly it still could be other things too, we might tell more with a new PRAM Battery, at least it's the cheapest option to get anywhere at all, Like if it recognizes the KB on startup, or more reliable startup sound.

     

    PRAM reset, CMD+Option+p+r...

     

    http://support.apple.com/kb/HT1379

     

    In fact, do 3 in a row, takes a bit of time.

     

    How to reset the SMU/PMU on a Power Mac G5 (Late 2004) or Power Mac G5 (Late 2005) ...

     

    http://support.apple.com/kb/HT1436

     

    Earlier G3, G4, G5 models...

     

    http://support.apple.com/kb/HT1939

  • 6. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    I've ordered a new battery. My keyboard seems to be having trouble communicating with the G5 (no caps lock light or ejecting tray), so I don't know if I'll be able to do a PRAM reset at the moment. I'll try and if no luck, put in the battery then try again. I'll try the PMU button reset.

     

    Could these resets affect any work that I have stored on the G5 by the way?

     

    I have the mid-2003 G5 I believe (1.6 GHz).

     

    Thanks very much

  • 7. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    It shouldn't be possible for those resets to hurt anything, just do one of the PMU resets though.

     

    I'm hoping the new PRAM Battery might help the KB situation.

  • 8. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hello, I tried the PRAM reset (with the display disconnected). There was no restart. As I suspected, by no caps lock light or ability to eject the tray, I think there is another issue preventing the PRAM reset at the moment, or any keyboard communication with the G5.

     

    I'll write back after trying the PMU reset, but have a feeling they may be more successful after the battery is put in.

     

    Thanks very much

  • 9. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    OK, fingers crossed here!

  • 10. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hi, last night I tried the PMU button (with display disconnected) and it started up the same way, no chime or light etc.

    I'm hoping that the battery is responsible for preventing all these things. I guess the next step is to wait for the battery and see if there are any improvements. Failing that, then I'll consider getting a new video card. Last resort I'll take it in somewhere.

     

    Thanks for your advice and will post back after the battery.

  • 11. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hello BDAqua,

     

    Yesterday I put in the new PRAM battery, but the problems are still the same - no chime, no power light, no proper start-up sounds or communication between the G5 and keyboard!

     

    I do suspect that my AGP card might have been causing problems with the cinema display, originally, but I don't know if that would explain all the other issues I've been experiencing. I don't want to just go and buy a new AGP card and still have no light, chime etc etc. Have you any other gut feelings about what may be causing this?

     

    This is the article saying I may have to get a new video card:

     

    http://support.apple.com/kb/TS1935

     

    Thanks for your advice, it might be time to book the Genius Bar now lol

  • 12. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    I doubt the Genius bar will help with a G5, they may not even know what one is, & Apple no longer works on them or has parts.

     

    If we can't figure this out you might find an AASP in your area that'd be willing to look at it...

     

    https://locate.apple.com/#

     

    I forget, is there 1 LED lit on the Logic board when AC is plugged in?

  • 13. Re: PowerPC G5 1.6GHz not starting up..please help!
    Adam Simpson5 Level 1 Level 1 (35 points)

    Hello

     

    I spoke to the Apple phone advisers today, and they told me not to bother bringing it in to the Genius Bar. They gave me some contact details though, but it is starting to look like I might have to buy something new.

     

    Errmm, regarding the LED, do you mean a light you can see from the front or back of the G5 (I assume you don't mean plug it in with the side covers off)? I'll have to check again, but from what I recall, there are no lights. I remember a red light in the optical audio in/out (at the back) before, but not even that comes on anymore. The phone adviser thinks there is a logic board problem, as the keyboard doesn't work either. He said logic board work can be expensive. What do you think? Say there are no lights visible, does that mean it's more serious and looking like it might not be worth the costs to repair?

     

    You also asked about the hard drive spinning up, not sure what you mean, but there are some noises/sounds when I put the power on. Disk Utlity told me the hard drive was fine, just before these problems happened. If the hard drive is okay, can someone take the data which was on it, and transfer it onto an external drive or something?

     

    I'm trying to work out what to do next, without incurring unnecessary expense. Maybe I'll contact some of these AASPs, explain the problem, and see what they say, and estimated costs etc.

     

    Sorry to go on!

     

    Thanks for the advice.

  • 14. Re: PowerPC G5 1.6GHz not starting up..please help!
    BDAqua Level 10 Level 10 (116,465 points)

    No lit LED would mostly indicate PSU problems, long shot but reseating & cleaning the PSU to Logic board connectors may help.

     

    Logic Board repair would likely cost more than another, faster G5...

     

    http://www.ebay.com/bhp/powermac-g5

     

    Yes, open the side door to see LED or if you can fell the HDD spinning up.

1 2 3 4 Previous Next