Skip navigation

Mail under 10.9.1 super slow

1181 Views 18 Replies Latest reply: Jan 17, 2014 3:35 PM by Ed RSS
1 2 Previous Next
Ed Level 1 Level 1 (60 points)
Currently Being Moderated
Jan 6, 2014 12:54 PM

I'm unable even to reliably type into a compose window.

 

Can't select mail messages in the list and move them without long delays.

 

I've turned off SpamSieve (2.9.12) hoping that would help but it didn't do much if anything.

 

I'm on 10.9.1 with fully updated software.

 

Any ideas ?

iMac, OS X Mavericks (10.9.1), 20GB RAM, SSD boot drive, i7
  • LynnRCarter Calculating status...
    Currently Being Moderated
    Jan 7, 2014 8:01 PM (in response to Ed)

    I have no solution, but I've noticed that Mail is hogging the CPU.  The only task that has consumed more CPU time since my last reboot has been kernel_task 10:13:03.4.  Mail is next at 7:38:22.02.  Then WindowServer at 6:04;26.38. Skype at 3:40:18.66.   There are only 1329 message in my inbox and I don't send more than maybe 50 emails a day.  What in the world is mail doing?

     

    How much is your CPU been used by the mail app?

     

    I too am on 10.9.1 and am fully up-to-date.

  • mcozturk Calculating status...
    Currently Being Moderated
    Jan 11, 2014 7:00 PM (in response to Ed)

    I have upgraded to 10.9.1 and my e-mail is super slow as well.  It seems like the email program wants to organize my e-mails almost every time I start the program and I hear a lot of hard drive clicking in the background. I see the spinning wheel for minutes.

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Jan 12, 2014 8:17 AM (in response to Ed)

    Hi Ed,

     

    Try this ...

     

    Empty the Caches in Mail.

     

    Quit Mail when running ...

     

    Open Finder>Home folder>Library>Caches>Mail folder>Cache.db

     

    Empty the trash can.

     

    Open Mail application.

     

    How is it NOW?

     

    Post back.

     

    Dimaxum

  • Eric Root Level 6 Level 6 (13,830 points)
    Currently Being Moderated
    Jan 12, 2014 9:22 AM (in response to Ed)

    You will need to make your user library visible to try Dimaxum's suggestion. Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J.  When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder.

  • LynnRCarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 12, 2014 9:53 AM (in response to Dimaxum)

    Inside of my user home folder, I found the "Library" folder (thank you Eric), and the "Caches" folder within it.  I'm *not* able, however, to find a folder named "Mail" within the "Cahces" folder.

     

    If I can find that folder, I'm assuming you are asking me to move the Cache.db into the trash.  Right?

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Jan 12, 2014 10:57 AM (in response to LynnRCarter)

    Hi Lynn ......

     

    Sorry my fold ...

     

    You have to look for the com.apple.mail folder.

     

    Than trash the Cache.db file.

     

    Post back ...

     

    Dimaxum

  • LynnRCarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 12, 2014 1:10 PM (in response to Dimaxum)

    Thanks again Dimaxum, 

     

    There is no "com.apple.mail" folder within the "Caches" folder within my user's "Library" folder.  I see the following when listing alphabetically:

     

    com.apple.iTunes (a folder)

    com.apple.mcc.accounts (a document)

    com.apple.Messages (a folder)

    com.apple.nssservicescache.plist (a document)

     

    I see exactly the same items in the "Caches" folder on another older MBP running 10.9.1 Mavericks that does *not* have this slow email problem.

     

    Lynn

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Jan 13, 2014 2:00 AM (in response to LynnRCarter)

    Hi Lynn,

     

    Finally I found the file Cache.db.

    In Mavericks the file is on a different place as before.

    Follow this pad ...

     

    ~/Library/Containers/com.apple.mail/Data/Library/Caches/com.apple.mail/Cache.db

     

    Post back with the results.

     

    Dimaxum

  • LynnRCarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2014 8:07 AM (in response to Dimaxum)

    Hi, Dimaxum.

     

    I  stopped Mail, found and deleted the Cache.db and restarted Mail.

     

    After about 60 seconds of startup and interacting with my four imap servers, all of the activities in the Mail Activity window stopped.  At that point, mail was consuming about 50% of a cpu.  It has slowly worked it's way back up to almost 100% of a cpu.  I now see it is 95.9% with a total CPU time of 33:37.42 in less than an hour.  I have 471 messages in my four imap mailboxs.

     

    Sorry, but that fix does not appear to be the solution to my problem on this otherwise wonderful Retina MBP.

     

    Lynn

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Jan 13, 2014 11:00 AM (in response to LynnRCarter)

    Hi Lynn,

     

    Sorry to hear that this not working for you.

     

    Did you reboot your MBP and try again Mail application.

     

    Also you can do is to deactivate ALL of your mail account EXCEPT for on active in Preferences>Accounts

     

    Now Quit Mail and reopen it ... How does Mail behave?

    If it's OKAY activate the second on and quit and reopen Mail.

    Any differences?

     

    You can activate de mail account one by one ... Quit and Reopen Mail ... until you find the account that is coursing the issue (delay).

     

    Dimaxum

  • LynnRCarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2014 12:17 PM (in response to Dimaxum)

    Hey, Dimaxum!

     

    I quit mail.  Discarded the Cache.db again.  Rebooted the machine.  Restarted Mail. Took all four of my imap accounts off line.  The startup activities in the Activity window finished much faster.  The Activity window shows no activity now, but the cpu utilization allocated to Mail was 40% and has been climbing ever since.  It is now 60% whith CMU Time of 6:00:17 and it is still going up.

     

    So this is definitely not about interacting with imap servers.  This looks like a cpu loop or some form of deadlock. Such a loop or deadlock would also explain the poor response to typing the I've been experiencing when the cpu gets up toward 100%.

     

    Lynn

     

    p.s. it is now 65.4% and 7:47.69  lrc

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Jan 13, 2014 2:30 PM (in response to LynnRCarter)

    Hi Lynn,

     

    I found this a intersting discussion here ...

     

    Give it a try ... otherwise Google for "High CPU in Mavericks Mail" as I did.

     

    https://discussions.apple.com/message/24163714#24163714

     

    Let me know how it ent.

     

    Dimaxum

  • LynnRCarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2014 2:49 PM (in response to Dimaxum)

    Excellent!  Thank you Dimaxum.  I went to that discussion thread and found that the following fixed my problem.  I very much appreciate you hanging in there with me!

     

    In just a minute after my Mail app restarted, with the shift key pressed down, the Activity window went crazy as it always does at startup.  When it stopped, I let go of the shift key and my cpu usages quickly went down to 0.1% and it is now showing 0.0%.

     

    I'm very please to have my quiet machine back!

     

    I hope this helps Ed and the others who been following his thread.

     

    Lynn

     

     

    Reported by:

     

     

    This solution, from Apple Support, worked for me.  It is much simpler, quicker, and less technical than others posted here:

     

    1.  Quit your Mail app.

    2.  While holding down the Shift key, restart Mail.  This will delete the "temp saved app states that might have accumulated, confusing the OS."

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.