5 Replies Latest reply: May 20, 2014 9:41 AM by jnojr
walshp Level 1 Level 1 (0 points)

Trying to connect to a Jabber service in Mavericks. Same server & config worked just fine in Snow Leopard, Lion and Mountain Lion.

 

Configuration is:

          Server: chat.dco.dod.mil

          Port: 5222

          Use SSL: (unchecked)

 

 

I get an error that:

     "Messages can't verify the identity of "chat.dco.dod.mil".

     An SSL error has occured and a secure connection to the server cannot be made"

 

 

It presents the option to 'Always trust "chat.dco.dod.mil" when connecting to "chat.dco.dod.mil".' However, the server cert, the intermediate cert and the root cert are all already valid so I shouldn't have to. Nevertheless, if I check the box to tell it to trust, it still fails with the same message.

 

 

Corresponding Console log:

11/18/13 4:43:17.975 PM imagent[222]: CFNetwork SSLHandshake failed (-9820)

11/18/13 4:43:17.975 PM imagent[222]: [Warning] SocketStream: error Error Domain=NSOSStatusErrorDomain Code=-9820 "The operation couldn’t be completed. (OSStatus error -9820.)" occurred on input stream

 

Things I have tried:

          - manually approving certs (same behavior)

          - selecting "Automatically find server and port" in config (same behavior)

          - selecting "Use SSL" with port 5223 (just hangs, no Console entries)

          - selecting "Use SSL" with port 5222 (immediately disconnects with same Console log as above)


MacBook Pro (15-inch Mid 2010), OS X Mavericks (10.9)
  • 1. Re: Messages SSL Error
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    I have come across a strange answer to this.

     

    If you have an AIM account logging in with SSL try Disabling the SSL there and if the Jabber account logs in then you can turn the AIM SSL back on again.

     

     

     

     

    3Sigcopy2.png
    11:03 pm      Monday; November 18, 2013

     

      iMac 2.5Ghz 5i 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • 2. Re: Messages SSL Error
    Pfeifler Level 1 Level 1 (0 points)

    Did you ever find a solution?

     

    Thanks

    Mark

  • 3. Re: Messages SSL Error
    walshp Level 1 Level 1 (0 points)

    No solution yet. I have been using Adium (with an iChat skin) to get by for now.

  • 4. Re: Messages SSL Error
    mgrass Level 1 Level 1 (0 points)

    Same behavior experienced here with near-identical logs.  Adding the certificates into the keychain doesn't seem to resolve the certificate issue.  Adium is still working like a champ, though it would be lovely to streamline down to one messaging app (messages).

  • 5. Re: Messages SSL Error
    jnojr Level 1 Level 1 (0 points)

    I've been using Adium to use DCO chat.  But I was just trying to help someone else with Adium who's getting a 405 error.  FWIW I sent an email to the DCO help desk