1 3 4 5 6 7 Previous Next 99 Replies Latest reply: Jun 24, 2014 12:49 AM by staffsergeant Go to original post
  • 90. Re: maverick os x, time machine won't work
    NickA58 Level 1 Level 1 (0 points)

    I have the same black rectangle appearing on my main monitor, but I am also unable to actually restore anything despite the backup working fine, as none of the files that appear in the finder windows under TimeMachine are selectable.

     

    I can get round the black rectangle by moving the dock and finder window to the second monitor then entering TM from there. It is, of course, a total waste of time due to the aforementioned problem!

     

    Does anyone have any suggestions about a fix for this?

  • 91. Re: maverick os x, time machine won't work
    schwinbp Level 1 Level 1 (0 points)

    Just an update here on the status of my issue. TimeMachine Backup just started working. I have no idea why. I haven't done anything to try to change the situation either. I saw it was sitting there running and I went to kill it since I figured it was probably stuck again and noticed that the size backed up was changing. I left it go and it actually finished. I have no idea! Sorry I don't have any real conclusions for anyone.

  • 92. Re: maverick os x, time machine won't work
    hyperlinked Level 1 Level 1 (0 points)

    +1 for deleting the Time Machine plist preferences file. I've had my backup stuck for over a day and while I've had plenty of headaches because of Mavericks, this one had nothing to do with Mavericks.

     

    I've had this very problem on and off with Time Machine and usually after being very patient for several days, the backup will finish and from that point on Time Machine behaves normally. I was about to tough it out again, but I decided to check online for a fix.

  • 93. Re: maverick os x, time machine won't work
    drbobw Level 1 Level 1 (0 points)

    After installing Mavericks (10.9.2) my (125) installed programs worked well except for Time Machine which was  stuck in a “preparing backup” mode .  At that point, I used EasyFind to locate Time Machine .plist files in the Home directory and delete them.  To do this I used Mountain Tweaks to change Mavericks settings and allow access to the Library and System files (click in Mountain Tweaks enable “Show the user Library folder”). 

    I also entered  Time  Machine preferences>options>and removed all HDs and SSDs except for Time Machine.  (If you “excluded” any disk with the home directory or data, then it wouldn’t be backed up!)

     

    I also went into System Preferences>Sharing> and disabled "File Sharing" since no other computers accessed my files.

     

    After all of the above, I shut down the Mac restarted in “Safe Mode”; and after the Safe Mode came up, waited ~ 4 minutes, then restarted the machine in the regular fashion.  Finally Time Machine worked and did a full back up.

  • 94. Re: maverick os x, time machine won't work
    mkoth Level 1 Level 1 (0 points)

    My impression is that there are still some unpredictable corners in the time machine envirionment. I am running time machine on 5 computers at home (2 mac minis, 1 mba, 2 iMacs of different generations) all on Mavericks 10.9.2. Except one iMac with an external drive all time machine backups use time capsules (on the latest sw revision) from 2nd to the 4th generation. Four of these machines backup correctly every hour when active. Only on 1 mac mini that is configured as a server (on the latest sw revision) the backup only works occasionally and after my manual stop and start. The backup goes to a 3rd generation time capsule but I also tried a 4th generation device which showed exactly the same behaviour.

     

    I tried out all the valuable tips in this stream including several complete resets and deletions of the backup sparsebundle but the problem staid. I monitored the backup in the log file but also with opensnoop -n backupd. There is nothing special neither in the log nor in the opensnoop trace except that in some cases backupd just stops. opensnoop doesn't show anymore opnening files and the process is stuck there for days.

     

    Once I stop the backup and restart (sometimes several times) time machine runs as it should and completes the backup. Below I attached 2 opensnoop traces. The first one that got stuck in preparing and the second one that worked normally. The process always stops at the same position after having openend the file with the exclusion list. I am running out of ideas where to look at. Maybe one of you has an idea.

     

    The trace that got stuck  in "Preparing":

     

    0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /Users              

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/Info.plist

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  31466 backupd        5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/English.lproj

                  0  31466 backupd       -1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/Base.lproj

                  0  31466 backupd        5 /System/Library/OpenDirectory/request-schema.plist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  31466 backupd        5 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

     

     

    Success:

     

      0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /Users              

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/Info.plist

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources

                  0  72118 backupd        4 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/English.lproj

                  0  72118 backupd       -1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Resources/Base.lproj

                  0  72118 backupd        4 /System/Library/OpenDirectory/request-schema.plist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.pl ist

                  0  72118 backupd        4 /.vol/16777226/22   

                  0  72118 backupd        4 /.vol/16777226/22   

                  0  72118 backupd        4 /Volumes/Time Capsule/machine_id.sparsebundle/.dat19b6.002

                  0  72118 backupd        4 /.vol/16777226/22   

                  0  72118 backupd        4 /Volumes/Time Machine Backups/Backups.backupdb/machine_id/2014-03-16-010741

                  0  72118 backupd        4 /.vol/16777226/22   

                  0  72118 backupd        4 /.vol/16777226/22   

                  0  72118 backupd       -1 /Volumes/Time Machine Backups/Backups.backupdb/machine_id/2014-03-16-114220.inProgress/Contents/PkgIn fo

                  0  72118 backupd       -1 /Volumes/Time Machine Backups/Backups.backupdb/machine_id/2014-03-16-114220.inProgress/Contents/PkgIn fo

                  0  72118 backupd        4 /.vol/16777226/22   

        0  72118 backupd        4 /Volumes/Time Machine Backups/Backups.backupdb/machine_id/2014-03-16-010741

     


  • 95. Re: maverick os x, time machine won't work
    cedrus_libani Level 1 Level 1 (0 points)

    I had this problem. I set Time Machine to do a one-time backup, then connected to the drive. It sat in "Preparing Drive" for ~2.5 hours, then backed up normally with no further intervention.

     

    I have a 500 GB RAID1 partition with 200 GB occupied, fwiw.

  • 96. Re: maverick os x, time machine won't work
    mkoth Level 1 Level 1 (0 points)

    For sure I would be patient for 2.5 hours but I have been waiting for 3 full days (72 hours) without anything moving in the backupd process. Currently I succeed to get one or two backups per day by just stopping the backup and hoping that the next one will work. Sometime it works, sometimes it doesn't and I didn't discover the prerequisite condition for a successful backup.

     

    I have nearly given up on this problem and I am waiting for the next MacMini generation to replace my current server hardware. As the OS installation will start from scratch I hope that the problem will disappear.

  • 97. Re: maverick os x, time machine won't work
    Kiero60 Level 1 Level 1 (0 points)

    Hi everyone, this is what I did

     

    1. upgrade disks to the latest firmware

    2. de-install ntfs-3g and MacFuse.

    3. Install NTFS 3G  without Macfuse.

    4. Next step: Install OSXFUSE latest version with selection MacFUSE compatibility layer.

    5. Last step: Install Fuse Wait

     

    Note: between steps 2 and 5, I restarted my machine.

     

    It worked for me.

     

    While I’m happy for anyone to tell me whats not necessary, after 4 hours, i’m simply letting you know what worked for me.

  • 98. Re: maverick os x, time machine won't work
    Eileen Shepherd Level 1 Level 1 (0 points)

    I have the same problem running my Macbook Pro and a second monitor. Same black rectangle the same size as the laptop screen, obscuring the time machine window on the second monitor. Move the open desktop window to the laptop screen and try again. No rectangle but can't open anything on the time machine windows. Can select a backup but can't type into search box or click on anything. Time Machine won't work and won't load onto the laptop screen. I've even reformatted my backup drive having stashed a DMG of backups to date onto another hard drive (which is a pain in the butt if I want older backup files). The fix is to disconnect the second monitor and open Time Machine on the laptop display - and, hey presto, it works... I wish I'd found that out before reformatting my back-up drive. Bah!

  • 99. Re: maverick os x, time machine won't work
    staffsergeant Level 1 Level 1 (0 points)

    I was having similar problems on my Mac but I was reading through this thread and the light dawned. I had 2 external hard drives connected  that were FAT32 and although these were shown in the exclusion list TimeMachine was a non starter. I ejected and disconnect both these HDDs  and tried TimeMachine again. Bingo - all is now whizzing along as it should be.

     

    Chris

1 3 4 5 6 7 Previous Next