Skip navigation

Screen Sharing doesn't work after updating to Remote Desktop 3.6.1

9270 Views 27 Replies Latest reply: Jan 21, 2014 12:01 PM by Dreyfuzz RSS
  • dakasner Calculating status...

    I have the same issue. After updating a lab to Mountain Lion, ARD Screen Sharing won't work with more than 1 computer at a time. Sharing with multiple computers causes the client computers to display a black screen, on the Admin station everything looks like its crashing or shutting down here. Screen Sharing with 1 computer works fine. I'll try expermenting with downgrading the admin software.

  • jkking2000 Calculating status...

    I'm having the exact same problem.  I thought I found a workaround but that didn't hold up long.  I found that if I log onto each computer one at a time then I could share my screen with the lab computers.  That worked once then never again.  Working for a large school system I'm hearing other schools having the same problem.  I've been searching for an answer since October 2012. 

  • Henry Rexroad Level 1 Level 1 (80 points)

    i got burned by this in the 3.6.1 update last fall. made the mistake of doing it while i was REALLY remote too... lost access to my server until I could get remote hands on the machine. managed to downgrade back to 3.5 and all was well and right in the world again.


    yesterday I was doing some work on the server and saw there was a 3.6.2 update. went ahead and installed it. BIG MISTAKE! same problem happens all over again. Thankfully this time I was in the same building as the server so I was only locked out for about 20 minutes.


    Unbelievable a bug like this has been kicking around for six months with no fix. Are the Apple engineers even testing their code before they release it? This seems like a pretty significant problem for a fair number of people.

  • dknchin Calculating status...

    I found out a quick fix that worked for me. I just connected to the Mac I want to control via Curtain Mode. The display worked. Without Curtain Mode, the display was black.



  • knotquiteawake Calculating status...

    We are having the same issue in our school district as well.  The Mac Lab Teachers are getting really agitated about it.  Has anyone found any better solutions?  We've tried all the workarounds listed above (other than rolling versions back). 

    Apple has something seriously broken here and we really don't want to pay $6000 for a 1 year enterprise support contract with Apple.


    Also, we have one lab that is using 10.7 still and ARD 3.6.2 and they are working fine!  Only the labs that were upgraded to 10.8 are having the issue with ARD 3.6.2.

  • knotquiteawake Level 1 Level 1 (0 points)

    Thanks for the information.


    I've got a good lead on a workaround that doesn't involve using the ARD at all.

    So far in small scale its worked perfectly.

    Here is what I'm trying to setup (hopefully it doesn't confuse the teacher or student too much):

    1. Install Vine Server 4.01 on the teacher's computer.

    2. Setup Vine Server to allow multiple connections, and disable Keyboard, Mouse, and Clipboard input from incoming connections.

    3. Turn on the Vine Server.

    4. Create a desktop shortcut to use Apples VNC Client with the IP address of the Teacher's computer.

    5. When student's click on this they will connect to the teacher's screen but not be able to control, only observe.

    6. Teacher can disable the Student's access simply by turning the Vine Server back off.


    So far in small scale with 5 computers its worked well (Better than ARD at least!).  Not sure how its going to do with a class of 27 computers.  We DO have gigabit ethernet.

  • knotquiteawake Level 1 Level 1 (0 points)

    Has anyone checked out ARD 3.7 yet?  Just wondering if anyone has updated all their clients and admin with this ARD 3.7 update?  Did it help at all?

  • Dave Essel Calculating status...

    Yes, I  have upgraded to osx10.9  running ARD 3.7 from 10.8.5 and whereas I had no problems before (strange, given the existence of this discussion), I am now experiencing what is described above and looking for a solution, which is why I find myself here.

  • Dreyfuzz Level 1 Level 1 (0 points)

    I had a lot of trouble downgrading ARD using Pizzy's method. After throwing out Remote Management, I got errors during the install like "Client version is newer than Admin version." Then I tried throwing out various plists associated with the client and got "Cannot find Remote Deskotp on this computer." What eventually worked was forcing the package to run from the terminal:


    1. Download the installer package from
    2. Open the dmg
    3. In terminal, enter sudo installer -pkg <remote desktop package path> -target /
    4. Enter your admin password to run the installer


    Note, this method wiped all my ARD preferences, lists, commands, etc. You can get the package path by dragging the package icon (the yellow box) into the terminal window.

  • Dreyfuzz Level 1 Level 1 (0 points)

    Update: I was on Mountain Lion when I posted previously. Can't do this any longer in Mavericks. ARD 3.5.1 is no longer supported.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.