Skip navigation

preview print to pdf crash fix?

152 Views 3 Replies Latest reply: Feb 4, 2014 4:06 PM by PAHU RSS
hotwheels 22 Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 2, 2014 1:41 PM

i get a repeatable crash out (the application closes) /any/ time i try to print to PDF out of preview. i've posted on this before and been unable to fix it and i have sent in crash reports.


right now i am finding that my printing out of Acrobat Pro doesn't work as a workaround because i basically want to print a "contact sheet" of images that are 4 or 6 or 8 to a page. preview used to be wonderful for this but since i can't get to pdf any more i am hurting a bit.


i am on 10.7.5 and unable to upgrade to mavericks due the age of my mac pro.


any ideas?


can i clear the cache or delete a plist or something...?



Mac Pro, Mac OS X (10.7.5), Boot Camp of Windows 7 + Windows XP
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 2, 2014 4:22 PM (in response to hotwheels 22)

    Working on the theory that the crash is driver related, I would try creating a dummy printer using the Generic Postscript driver included with OS X. Then with this printer selected in the Preview print dialog, you could then select to create a PDF and see if this printer has the same symptom.


    To create a dummy printer, open Print & Scan and select to add a printer. Select the IP icon and enter an IP address Then change the name to Dummy and select Generic Postscript in the Use menu. Then click Add to complete the printer creation.


    Also, you mention having Acrobat Pro. So in the PDF menu in the print dialog, you should also have an Adobe PDF option as shown below. Do you get a crash if you select this?

    Adobe PDF.png

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 4, 2014 4:06 PM (in response to hotwheels 22)

    hotwheels 22 wrote:


    first, can you tell me if there is a protocol that i should be using when creating the dummy account? it looks for a long time and cannot create one but i have LPD selected and maybe i should use HPP or socket?  (i'd post images but the add image UI is acting funky on me).

    Any of the protocols should work. If LPD is failing (it can take a while in the "configure" stage but you should be able to skip) then try HP Jetdirect.


    hotwheels 22 wrote:


    also, on the theory of driver related crash. i have an HP and a Epson Wide Format and a little Brother Label Writer. i am not real clear on when drivers are being used but i /selected/ the pulldown for both the Espon and the Brother printers and tried a print to PDF and these also crash. does this mean that it is application related somehow or not necessarily.

    Then this would suggest that it is not driver related but something to do with the printing system. All print jobs start as PDF on OS X and are then converted by plugins (filters) often provided by the vendor to support the selected printer. So with the crash occurring with different drivers it would suggest that it is not driver related. But...


    hotwheels 22 wrote:


    i did find the Save as Adobe PDF (thanks!) and it does in fact save out multiple images to a multipage PDF. this is actually a big time saver as i was opening acrobat in the past and trying to remember each time which Create item i had to select and then i was dragging files into acrobat, etc, etc etc. so again a thank you on this one.

    with Save as Adobe PDF working it would counter the previous assumption that it was the OS X printing system. From what I have read the Adobe PDF plugin still relies on the OS X printing system creating the initial PDF file before it is passed to the Adobe subsystem.


    To test this, instead of selecting "Save as PDF" or "Save as Adobe PDF" select "Save as Postscript"? Does this crash or give you the option to save the file?


    hotwheels 22 wrote:


    i simply opened the images and then selected the 6 up black and white or 8 up color or whatever preset i have and i then selected the print to pdf.

    Does this still work correctly with the preset selected but then selecting "Save as Adobe PDF"?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.