Skip navigation

Cannot connect to Netgear wifi network on iphone or ipad

364 Views 4 Replies Latest reply: Feb 5, 2014 4:18 PM by Lyssa RSS
sh00kie Calculating status...
Currently Being Moderated
Feb 4, 2014 3:13 PM

I have an ipad 3 and iphone 5S. Since my HUAWEI wifi router died I have brought back my Netgear DG834N wireless router and also configured a second Netgear DGN2000 wireless router. Both work well with my iMac, either connected by ethernet or wirelessly. Both have been set up with WPA2 security.

However, both iOS devices (running latest version of iOS7) recognise the two wifi routers wirelessly but reject the password, even though I have attempted this dozens of times and verified they work on my iMac (running Snow Leopard). Message is: Cannot connect to network.

I have trawled through the router setup endlessly and cannot figure why the connection is constantly rejected

(Although this may or may not be relevant, a Panasonic smart TV in another room also rejects connection to the DG834N's wireless network

iPhone 5s, iOS 7.0.4
  • wifiguru Level 2 Level 2 (230 points)

    Have you tried turning Keychain syncing off on the iPhone and then tried ?

  • Lyssa Level 6 Level 6 (14,780 points)

    I would try setting a simpler password (say, just a series of numbers and letters, no special characters) to see if your other devices can connect.

     

    Also worth trying removing the password entirely, just to see if the iPad, iPhone & TV can connect to the routers.

     

    If still no joy, check for firmware updates for both routers.

     

    Let us know if any of that helps.

     

    ~Lyssa

  • Lyssa Level 6 Level 6 (14,780 points)

    Hmm.

     

    My next step would be to shut off one of the routers and just test one, then the other, and see if that makes any difference.

     

    In my limited experience, if one computer can connect but a variety of other devices cannot, this usually means the router needs an update and in some cases it means the router is failing.

     

    Are there a lot of other wireless networks nearby? If so, perhaps changing the channel for yours would help.

     

    ~Lyssa

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.