Skip navigation

Warning: SUID file "System/Library/CoreServices" has been modified and will not be repaired.

111061 Views 71 Replies Latest reply: Apr 2, 2014 6:12 PM by BillBlaakk RSS Branched to a new discussion.
  • PhuBaiYou Calculating status...

    I don't want a debate - just a concrete, autoritative official statement from Apple - why is that so difficult? If Apple's disc utility produces false information why would anybody rely on it? Remove it from the OS or fix it. It's perplexing that Apple remains silent on the matter and all I get is well intentioned techs that parrot somebody else. That is not tech support.

     

    However, using 2 Macs I believe I found the culprit that creates this issue:

     

    Using an OS 10.6 disc I did fresh installs. On one Mac I permitted all post install "updates" to be installed and sequestered the other Mac from any updates. Running the disc utility on the non-updated Mac produced a clean report, but the updated Mac produced 32 permanent incorrect java permissions, 5 "RemoteMangement" and one SUID warning. Inspite of "correcting" the disc utility permissons a re-verify indicated the same incorrect permissions - over and over again.

     

    On the non-updated machine I prepared to install one update at a time and running the disc utility after each update. I didn't get far - the "Remote Management" install and "java" related updates immediately produced the permissions issues. Re-installing OS 10.6 w/o the updates seems to have solved my issues with the  disc utility. So, I did a second  re-install and updated only java and found a clean bill of health for my OS 10.6.8. So, without the "remote management" update I have no issues to report. Perhaps we need a better understanding of just what remote management does and who can access it? It might explain why my wife's iMac wakes up in the middle of the night?

  • fiddleaway Level 1 Level 1 (5 points)

    1st gen Intel Mac running latest updated version of 10.6.8 as of this date

     

    About 10 days ago, I began to get system freezes ..... except for allowing my mouse to move the cursor, the OS completely ignored all other mouse or keyboard inputs, and the only way to recover was to hold down the power switch (or pull the plug).  The freezes became more frequent and eventually required me to cycle power and restart in Safe Mode, then do a controlled (software) shutdown, then re-cold start ... the forced power switch shut downs appeared to be degrading the OS.

     

    This behavior me to use Disk Utility to view and repair permissions.  When I did, I got all of the (apparently faux) permissions warnings (which 'repair' doesn't fix) that people have complained about in this thread.  Specifically I'm getting 74 permissions violations in the following general categories:

     

    • Java class files that were globally executable now globally non-executable and visa versa
    • Java libraries with owner access changed from root to an administrative uid
    • Apple remote management language directories converted to files ("...should be drwxr-xr-x , they are -rwxr-xr-x", for example)
    • Java framework file names that should be direct are now links
    • A flashplayer plug-in resource that should only have admin group access has root access, and it should have write access for user and group, but has global read only access
    • The SUID warning that started this thread
    • /private/var/root/ and two of it's resources having an added ACL

     

     

    I trust the expert advice in prior posts here:  these permissions notices are due to Snow Leopard updates that Disk Utility fails to account for.  Ergo, the freeze problem I'm having is unlikely to be related to the permission violations.

     

    However, it is very easy to imagine how all of the name aliasing along with a few privilege changes involving the root could be the work of malfeasance.  Furthermore, with 70-some-odd warnings that are now to be ignored, it is extremely difficult to tell if any actually indicate a problem that possibly should be addressed.

     

    I am very unhappy that Apple has apparently chosen not to provide mitigation for this issue.

     

    ps - my original message is an off-topic example to explain how I came to be confused by the faux permission warnings given by Disk Utility and how they can cause someone to lose a lot of time chasing a non-problem.  If by chance anyone has a clue about the freeze behavior I'm seeing, please direct me to somewhere I can find out about it.

  • 55plus Level 1 Level 1 (10 points)

    Hi, I had an imac built in August 2007 and when I installed Snow Leopard 10.6.3 on it I got the frozrn screen-I could move the cursor around with the mouse but clicking on anything did nothing, as you experienced, the only solution was to force shut down by pressing the startbutton in for 10 seconds or so.

     

    I came first to this forum and found that at that moment there were 74 pages filled with this problem, it turned out to be the graphics processor, some iMacs had an old one originally intendd for those little 11.5 inch screen e-books, those processors were not good enough to run SL.

     

    At the beginning of the discussion people reported they had called Apple and either got a new iMac or had the graphics chip replaced for free. I live in Amsterdam so I contacted the Machouse,there was no Apple Store here back then,and they said it was the graphics chip but they were forbidden by Apple to replace anymore, I contacted a private company here that is Apple certified and asked if they would replace the chip. They said they had been doing that but Apple had said to stop or they would lose thier Apple certfication. I had already noticed that the Netherlands Craig's List had 27 iMacs for sale very cheap, I kept watching but no one took the bait and bought one. I used macTracker to find out the current value by using the serial number-it said the iMac was worth $168 then.

     

    if I were you I would make an account at macforums and ask there about this,I believe Apple has removed the 74 pages of complaints about that since it didn't look good for the profits.

     

    I bought a new Mini in Nov. 2012 and it came with Mountain Lion installed,no joy there but I am not a hacker so I can't build my own PC to run OSX on-actually I don't see why I would want to run  an Apple DOS on a PC. I am hoping I am allowed to stay in ML for some time but yesterday there was an update and it had yet another build of the ARDagent.app which seems in system profile to be called Core Services or something-i was not allowed to upgrade iMovie or iPhoto because" I didn't have Maverick installed!!!" I knew from reading the other forums that mavericik like SL and Lion and ML have never been tested to see if Apples own video[Final Cut proX] and audio[Logic pro] apps work, they don't. Logic loses all audio output if I run permission repairs and it is that ARDAgent.app that is never repaired that causes that. I had bought Apple Care so I was able to get real support from an Apple Enterprise company that specialized in audio apps.They said to reset the user ACL's, that helped one time but later the audio dropped out again and Apple care said to use the improved DU in the recovery mode to repair permisions-this did not even report a problem with ARDAgent.app or Core Services and by chosing utilitoes <terminal and typing just res and hitting the tab key I got into password reset mode where one can repair user ACL's.

    HTH Macforums great site! do it.

  • fiddleaway Level 1 Level 1 (5 points)

    Thank you 55plus !!!

     

    What you report is consistent with what I am seeing.  Looks like it may be a graphics card.

     

    I have noticed that just before the freezes, my display flashes.  I thought this was caused by system resources that had been munched.  As I write this, there are periodic instants of small green rectangles that randomly appear (but so far no freeze has occured).  I transferred my HD image to a different internal drive, just to make sure it wasn't a drive problem ... it remains to be seen if freezes stop now.  But the momentary flashes on the screen continue.

     

    You may have heard the grumbling from gen 1 intel Mac Pro owners that Apple decided to artifically obsolete these older intel mac pros and not allow Mountain Lion to be loaded onto them even though they had 64-bit CPU's and plenty of horsepower to run it.  It is true that the gen 1's needed a graphics card upgrade and new EFI, but apple stood firm in not allowing these units to have the required h/w grades.  People had to go a bootleg route if they wanted to make there machines compatible with ML.

     

    The problem has only surfaced recently even though I've been running SL for several months without a hitch ... so maybe the graphics card has just worn out.  Sounds like I'm not going to have an easy time replacing it.

     

    I really hate the fact that such a powerful machine that more than meets the needs I have must be replaced in its entirety rather than me being able to replace a major component.  But that's the age we are in.

     

    Thanks for getting back to me.  It was a big help!

  • 55plus Level 1 Level 1 (10 points)

    Oh the green rectangles, yes and the day my iMac finally died it refused to diplay anything but the whole screen white with one wide green verticalstripe in the center.

  • fiddleaway Level 1 Level 1 (5 points)

    Thanks 55plus - the "green rectangles" commonality is more affirmation that I'm on the right track.  I'd like to discuss more, but I think it would be better to go to "HTH macforums" and find or start a topic on this.

     

    Would you give me a link the HTH macforums.  I don't seem to be able to find it.  I'll keep looking, but a link would help.

  • 55plus Level 1 Level 1 (10 points)

    Hi fiddleaway, HTH is just an acronym for Hope This Helps. I remember after takng the iMac to the new Apple Store for repair they called the next day and said it is OK come get it. When I got it home I tried a you tube videio and it was over; the screen froze and green rectangles began again and then that final white screen with a 13 inch wide vertical green stripe in the middle-it was the flash players that the graphics set couln't deal with. I had paid bloody Apple €275 for one replaced 2GB Ramm but they didn't check what I had brought it in for- videos.

    mac forums is

    http://www.mac-forums.com/

  • fiddleaway Level 1 Level 1 (5 points)

    Thanks 55plus - I'll try that forum.  I've also been told they still might help me at the Apple store even though they're pushing Maverick's these days .... if I do, I'll be sure to tell them to specifically check the graphics card ... if they want to sell me some more memory, I could probably use an extra 2 gigs, but I am 99 44/100% sure that main memory is not the problem.

     

    This problem gives every indication that the graphics card has a bad memory bank which causes the freeze when the system uses it.  Coming up in Safe Mode seems to reset the condition somehow, and so far, it doesn't seem like the problem occurs when I'm in safe mode.

     

    You've been very helpful.

  • fiddleaway Level 1 Level 1 (5 points)

    Substituting in a known good graphics card fixed my problem, 55plus.  Thanks a million.

  • DavidMac Level 2 Level 2 (385 points)

    I regret upgrading to Mountain Lion 10.8.5.  It not only has messed up my iTunes "permission" repairs, but also updated my Canon Printer Driver, and I'll have to re-install iTunes 11.0.5 and my previous Canon Printer drive.

     

    Avoid the 10.8.5 update at all costs.

  • Spanky D. Rascal Level 1 Level 1 (90 points)

    Josheph Kriz's post is actually the best answer. I'm running 10.9.2 on my 2013 iMac and recieved the same error as paula185. I copied the file from my 2008 MBP (MacBook Pro), also running 10.9.2, as suggested by Joseph Kriz, and got the following:

    User differs on...should be 0; user is 502.

    Group differs on...should be 0; group is 20

    Permissions differ on...should be -rwsr-xr-x; they are -rwxr-xr-x

    After running permissions repair:

    Screen Shot 2014-03-24 at 9.18.08 AM.png

  • BillBlaakk Calculating status...

    I've been running a '08 MacBook for a while now, and it's been reasonably ok. Recently aqcuired another (same age roughly) and have been trying to integrate it into an audio setup with my PC. Then after just 4 days the problems mentioned here began. First... the audio died (driver status says it's fine, and running. Audio software tells me to 'connect to an audio card'. None of the devices show up for selection. Thought it was due to soundcard's age (last driver was 2012) but couldn't install, or uninstall the drivers. Or my UCX (Pro audio card). So I try to install Windows via Bootcamp and I keep getting messed about. Repairs needed on already 'repaired' permissions. Needing 10GB spare (despite having about 150GB) on the partition. System freezes.

     

    Pretty sure DavidMac hit the nail on the head, at least it's when my problems started... "Avoid the 10.8.5 update at all costs". I've just spent literally a full week of my time installing all of my audio software, and then trying to integrate it into an existing setup.

     

    I'm avoiding Apple products like the plague in future. There's all this, and the recent MacBookAir overheating within no time at all (no ventilation... too thin). I love my iPad, fantastic bit of hardware, but really.... they can be tons of hassle too. Especially in terms of App compatibility and your silly 'window' of opportunity to downgrade. And did someone mention their own products not working on their own machines???

     

    Apple should spend more time on the portion of your customer base that invests a lot of money in your stuff and only wish to use it 'out of the box' as intended, as opposed to trying to battle hackers (who are always going to win) from supplying people with something, to amend a thing which they probably wouldn't even buy if they were unable to jailbreak, or whatever.

     

    Tut.

1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.