Skip navigation

mavericks ad hoc/computer-to-computer broken

1129 Views 2 Replies Latest reply: Feb 11, 2014 6:25 PM by TheEray RSS
robjlee Calculating status...
Currently Being Moderated
Nov 5, 2013 7:15 AM

I posted on the first day mavericks was out and couldn't find anyone having the same problem - but now i have 3-4 friends with the same issue, and none of us can find an answer.

 

on mountain lion, we were able to create an adhoc/computer-to-computer network and chat through bonjour on Messages. We would do this WITHOUT WIFI (there is no wifi in the room we're in) and no ethernet connection, it was purely computer-to computer.

 

Once we upgraded to Mavericks, no longer can do so. it allows one of us to create a computer-to-computer network, and we all appear to be conneted to it fine, but when we try to log into messages and use bonjour it says there is a connection error.

 

We've checked all settings and they appear fine, and we've really scoured the internet looking for answers. Sorry for the re-post, but i'm hoping since it's been a few weeks now someone has figured something out.

MacBook Pro (15-inch Mid 2010), OS X Mavericks (10.9)
  • Ralph Johns (UK) Level 9 Level 9 (66,835 points)
    Currently Being Moderated
    Nov 6, 2013 1:56 PM (in response to robjlee)

    Hi,

     

    The Computer to Computer network obviously does not go through a computer.

    However it will still need to use either Ethernet or WiFi to connect to the other computer.

     

    In System Preferences > Network > Advanced Button > TCP/IP tab you should get a Self Assigned IP address.

    The computers that join the network should get an IP address in the same range.

    My iMac as Network host

    Screen Shot 2013-11-06 at 21.49.18.png

    I joined my MacBook Pro to this Network and it had an IP that ended .22

     

    I then tested the Bonjour on both and found that the iMac would not open the Buddy list (and therefore never showed up on the iChat 5/Snow Leopard MacBook Pro).

     

    This may be linked to the lack of DNS  info.

    See this article http://support.apple.com/kb/HT3789

    At this point we leave what I know and am confident about.

     

     

     

     

     

     

    3Sigcopy2.png
    9:56 pm      Wednesday; November 6, 2013

     

      iMac 2.5Ghz 5i 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • TheEray Calculating status...

    Apple seems to see this problem as a low priority, but it is very frustrating.  One of the main reasons I bought a mac was because of the ad hoc network capability and it worked great until OSX Maverick.  I called Apple tech support and they just told me to go buy a router, just as if I had a PC.  I don't understand why this can't be fixed ASAP.  This is the screenshot I read to tech support and they told me they couldn't help:

    IMG_0135.PNG

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.