Skip navigation

I am unable to scan from my HP all in one printer/scanner

274 Views 2 Replies Latest reply: Feb 14, 2014 12:25 PM by klarg RSS
eleanorfromhunton bridge Calculating status...
Currently Being Moderated
Feb 11, 2014 5:47 AM

Since installing Mavericks I am unable to scan using my HP printer/scanner.  I have uninstalled the software and tried to just use Apple method - but really cannot find out how to scan and save.  Does anyone have any ideas?

MacBook Pro, Mac OS X (10.0.x)
  • jeremy_v Community Specialists Community Specialists (1,750 points)

    Hi eleanorfromhunton bridge,


    Thanks for visiting Apple Support Communities.


    Be sure to use the steps in these articles to set up and scan with your scanner:


    OS X Mavericks: Set up a scanner


    OS X Mavericks: Scan an image


    If the steps above do not work, these printer troubleshooting tips may also help with scanner troubleshooting:

    1. Delete the affected printer, then add the printer again.

    2. Reset the printing system, then add the printer again.

    3. If the issue still persists, reset the printing system again.  Download and install your printer's drivers. Then, add the printer again.

    4. Contact the printer vendor or visit their website for further assistance.



    Troubleshooting printer issues in OS X





  • klarg Calculating status...

    I hope that Jeremy V's solution works for you, but it did not work for me with my HP Officejet 6500 E709n (USB connection).


    Long story:

    Solutions on the web included many stupid non-solutions.  The two most plausible ones were to “Reset the printing system” and “Do a clean reinstall of Mavericks”.  I tried “Reset the printing system” which in Mavericks is to do a control/click in the printers list box ( ) and select the popup option “Reset printer system” (reset methods for earlier OS X versions were a little different).  Anyway this seemed to be a disaster. Not only did it not improve the HP 6500 situation, now it would not let me  properly (re)add the Brother MFC-5550cn all in one that had been working fine.  At this point, I did not want to do a “Do a clean reinstall of Mavericks,”  I just wanted the Brother back in operation.  So I decided to use Time Machine to get back to where I was before.  Since I could not clearly identify all the files involved, I did a full restore which took about 3 hours.  Not only did it take a long time, I was surprised to find that a number of programs required going through the registration/set up dialogs - rather a pain. I did fetch a manual download of drivers for the Brother all-in-one. I got the Brother back working (except for the Print/Scan tab business - but the Brother has it own scan stuff).  Finally I decided to add back the HP all-in-one as generic printer/ no scanner, and Mavericks surprised me by actually downloading and installing the correct drivers complete with working scan tab.  Problem solved - finally.


    For folks with other printers, you might want to check the list at

    ( )

    to see if there are drivers for your printer.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.