Skip navigation

No internal cam working on Maverick 10.9 Update

7012 Views 26 Replies Latest reply: Mar 26, 2014 4:02 PM by geebo2b RSS
  • GrgP Calculating status...
    Currently Being Moderated
    Feb 4, 2014 9:00 PM (in response to elijah286)

    Hi there,

    Following a recommendation of the local Apple Customer Service, after they performed a 5min test and could not find any hardware issue on my MBA, what fixed the issue was for me to:

    1) backup the MBA with Time Machine

    2) perform an internet recovery (command+alt+R at startup) which reinstalled a fresh copy of the OS

    3) reinstall the user accounts (I have found this site quite handy: http://pondini.org/TM/15.html)

    In between steps 2 and 3, the camera was up and running with Photo Booth and now I have it all working smoothly and can do FaceTime etc...

    Hope this helps.

  • Gary Bonner Calculating status...
    Currently Being Moderated
    Feb 5, 2014 2:37 PM (in response to EZ Jim)

    I tried the restart/re-install  procedure.. Unfortunately, my IMac just endlessly loops the restart procedure if I hold the command and R button on the gray screen. That is, it shuts off, I hear the restart chime, and it starts to boot, over and over and over non-stop until I let go of the buttons.  

  • nerdoo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2014 2:03 PM (in response to jams1361)

    The follwing helped me for now, not requiring reboot:

     

    • Quit all open apps that may try to use the FaceTime camera
    • Open Terminal, found in the /Applications/Utilities directory in OS X
    • Enter the following command string exactly, then hit return:
    • sudo killall VDCAssistant
    • Enter the administrator password when requested, this is required to execute a command with superuser privileges as prefixed by sudo
    • Relaunch the app that was attempting to use the camera

     

    At this point the front camera should work again as if nothing was ever wrong with it.

    Link to original fix page:

    http://osxdaily.com/2013/12/27/fix-there-is-no-connected-camera-error-mac/

     

    Hope this helps others.

     

    Cheers!

  • Gary Bonner Level 1 Level 1 (35 points)
    Currently Being Moderated
    Feb 15, 2014 2:45 PM (in response to nerdoo)

    Thanks,

    I guess this would work but I have a problem.

     

    Password entry blocks input.

     

    no letters allowed for typing...script just stops here.

     

    I read online that I have to type password blind, which I surmise is to turn off the screen.

     

    How do I do that and leave the computer running and then reactivate the screen??

  • Gary Bonner Level 1 Level 1 (35 points)
    Currently Being Moderated
    Feb 15, 2014 2:56 PM (in response to nerdoo)

    Disregard my 1st reply. If I type in the commands as you show with spaces..the password cannot be entered. If I type the command with no spaces I can enter a password but I get a '"command not found' message.

     

    So, it would be nice if MAC would fix this. They broke it, they sohoud fix it.

  • SLeh Calculating status...
    Currently Being Moderated
    Feb 20, 2014 10:29 PM (in response to jams1361)

    I've lost faith in Apple. I have a Macbook Air 13" Mid 2012. I bought it in November 2012. I barely use it except for the occasional Netflix, movies, excel and word. I don't take it with me. It should be in perfect condition. Two days ago, I tried using FaceTime and it said "No Camera Available". That's odd considering it was working perfectly fine, so I googled it and found that MANY Mac users were having similar issues. I decide to take it to the Genius Bar. The wait was just as long if not longer than the meeting with the Genius Bar Rep. In 10 minutes, he told me it was a hardware issue and my options were to replace the screen for $500 or to send my laptop in for $200. I mentioned that many people were having the same issues. The response I got was "It's a hardware issue, so those are your only options."I decided to call Apple Support today to completely reset my laptop back to its factory settings. I let him know that my camera was not being detected. The Apple Rep said he had a similar issue last year, but luckily he was still under warranty. Great...I reset my computer and camera is still unavailable. Sigh. 

     

    It seems a bit ridiculous that we're already paying a premium for Apple products and this is the type of crap we put up with. I'm sure Apple knows about this issue and has seen the threads. They are just choosing not to do anything about it. It would be nice if they could make a one-time exception to fix everyone's cameras without it costing an arm and a leg. Would that really hurt their profitability? It used to be that buying an Apple product meant you received a high level of customer service along with a great product. That stopped as soon as they built up a loyal customer base. With all the competition out there, Apple will slowly start losing customers. Maybe when that happens, they'll start responding to these threads and maybe they'll start solving these issues? It's not like we're asking to solve world peace or hunger. Is it really too much to ask for?

     

    Has anyone ever noticed that the Genius Bar is ALWAYS busy. It's probably because Apple products break down so much and has so many issues. Just saying...

  • coffeecoffee11 Calculating status...
    Currently Being Moderated
    Feb 22, 2014 1:36 PM (in response to nerdoo)

    Thanks nerdoo!

     

    That fixed it for me.

  • kidlupin Calculating status...
    Currently Being Moderated
    Mar 4, 2014 6:59 PM (in response to EZ Jim)

    Have searched all over the internet for solutions to this for days now, but need someone with a little technical knowledge to help.

     

    Macbook 7,1 (2010) with 10.9.2 installed. My internal camera now intermittantly works (likewise under 10.9.1), so I'm confident it isn't a hardware problem. When it doesn't work I get the black screen in Facetime 'No Camera Available'. A hard / soft restart / shutdown does not solve this, nor does resetting PRAM nor SMC.

     

    When I use sudo killall 'VDCAssistant' or 'AppleCameraAssistant' then Terminal tells me there is no such process. I have also deleted keychains, verified permissions (for some reason my printer permissions change, even though Im not connected to a printer nor attempting to print anything, but I think thats a red herring). I have deleted preferences and passwords and Internet Accounts. I have logged in and out with my Apple ID in every available way, through the website and App Store, Itunes, you name it. Messages app included. I have tried connecting other (digital rather than webcam) cameras via USB and run iPhoto. I have tried running VLC, Google Hangouts, Skype, all of which were consistent with System Profiler : There is no video capture device.

     

    When I have gotten the camera back online, I'm not entirely clear what has solved it.

     

    What I do know is this : in Facetime my 'preferences' option is greyed out. Further, when I select 'Turn Facetime On' it greys out and never completes. So what is Facetime doing at this point? I had noticed that it wanted a password from me when I first upgraded to OS 10.9.2 but that hasn't happened since.

     

    One assumption might be that the OS is failing to load some sort of driver for the camera at start-up, but this wouldn't explain why it sometimes works, sometimes doesn't (I don't vary the content of my system, its the same apps on there all the time). Another idea might be the widely suggested one that there is a process failing to be killed by another app, and given that the OS doesn't allow two apps to share the same camera, the solution is to kill the process. However a little detective work with Activity Monitor / 'top' in Terminal doesn't reveal any obvious processes linked to the cameras operation. So why is System Information not able to find the camera? That seems like a driver problem, to me anyway.

     

    I see a lot of folk are having the same problem. I'm currently touring South America, so fixing this would be a big help to me.

  • geebo2b Calculating status...
    Currently Being Moderated
    Mar 4, 2014 10:15 PM (in response to kidlupin)

    I finally took the risk and completely re-installed Mac OS 10.9.1 Which now is 10.9.2.

     

    Bingo , it did solve the problem. My cam now works. It hadn't worked for a couple of months since the initial install. I checked my cam using TechTool Pro 7 and the cam worked fine when Techtool checked it. But none of my apps, like Photo booth, or Ichat or anything worked. I would just get a black screen with a spinning load ball that would never load.'

    I tried everything and finally risked the re-install.

     

    YAY I got my cam back.

  • kidlupin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 5, 2014 4:48 AM (in response to geebo2b)

    Glad to hear that worked for you. I'm not in a position to be able to do a clean install right now, and even with that I've read enough folk saying that it has only worked for them briefly. I think that suggests something else might be happening.

  • geebo2b Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2014 4:02 PM (in response to kidlupin)

    Well you are right about the failure  of the Icam after the re-install..happened to me BUt..I found a workaround that is currently working on a regular basis.

     

    I own Tech Tool Pro 7. If I open what ever app is using Icam, 'Photobooth, Ichat /messages etc..initially the cam won't work.

    BUT If I navigate to the Video Check which includes an ICAM test and hit start..the I cam turns on (If there is no hardware problem)  and Tech tool , somehow causes the Icam to work for whatever App I need it for.

     

    So I just leave Tech tool Pro running with the Icam Test checked to Start..and then my Photo Booth or Ichat cam works. Haven't tried it for other apps yet.

     

    I can only run 1 app at a time for the Icam..If I try to turn on some other app using Icam w/o closing out of current app, it freezes and stops the Icam. So for each app that uses the Icam..I have to restart the Tech tool pro 7 Icam check  . I am watching myself on my Ichat as I typy this now.

     

    Good luck..and maybe someday Mac will get off thier High Horse..admit the problem AND FIX it. Until then Tech Tool PRo 7 with the I cam test running. Good luck.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.