Skip navigation
This discussion is archived

"Headsets are not supported on your Bluetooth hardware."

7455 Views 140 Replies Latest reply: Dec 10, 2006 8:25 PM by Pratibha Srinivasan RSS
  • David Grayson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 3, 2006 3:53 PM (in response to David Grayson)
    Anybody know if the new 10.4.6 update fixes the issue of headsets not being supported on 10.4.5?
    G5 1.8 single, Mac OS X (10.4.5)
  • Israel Curtis Level 1 Level 1 (10 points)
    ok - for all those tired of trying to run the updater, only to get stuck in the cycle of searching..preparing...nothing - Make sure your adapter is not plugged into a hub! Plug it directly into a usb port on the computer. The moment I did this, the updater was successful!
    G5 dual 2Ghz, Mac OS X (10.3.9)
  • Luke Stempien Calculating status...
    Currently Being Moderated
    May 29, 2006 6:53 PM (in response to David Grayson)
    I'm running 10.4.6 and attempting to get a Jabra headset to pair with an iBook through a new Iogear Bluetooth 2.0 USB Adapter (Class 1, product ID GBU321). Anyways it doesn't work, I get the classic your adapter does not work with headsets. I can't say I really understand this on either Iogear or Apple's part. The Mac logo is on the Iogear box as well as a blurb about how it fully supports the bluetooth standards including headsets. Apple never comes out and goes you have to buy a DLink adapter if you expect anything to work, it just suggests you buy one from their online store. They promote bluetooth capatability with OS X 10.4 which one would sort of assume ment that everything should work together.
    Power Macintosh G5, iBook, Mac OS X (10.4.6)
  • teplin99 Calculating status...
    Congrates on your bluetooth success, I'm not having such luck. If you don't mind, where did you find the 2.1241 firmware update link and what USB (if any) bluetooth adapter are you using? I am trying to use a motorola headset with their adapter and I have also tried a new iogear bluetooth adapter that is class 2 and mac compatible. It easily allowed me to connect my G4 to my cell phone, but all I get are the usually error messages about headsets not being supported by the hardware.

    Thanks,

    Spencer
    G4, Mac OS X (10.4.6)
  • Alexander Traud Level 4 Level 4 (2,690 points)
    For both of your USB adapter there exists threads here in Apple Bluetooth discussions. Please go for a D-Link DBT-120 USB adapter.
  • james123456 Calculating status...
    Currently Being Moderated
    Jul 14, 2006 9:19 PM (in response to keith daniel1)
    Hello Keith,

    I've spent hours going through the same **** that you have.
    I've plugged in and unplugged the D-LINK adapter. I've updated my Firmware, I've repaired disk, zapped p-ram, reset nvram and all, created a new user, restarted many times, plugged the D-link directly into computer and not the keyboard and all this with no success.

    Same as you when I go to update firmware it just keeps saying "searching for device to update..." and "preparing to update device..." aand after about 5 minutes it stops and the buttons become clickable but nothing happens. When I go to quit it tells me that it wasn't updated.

    Also I did notice that when I go to set-up a new bluetooth device it notices my motorolla headsetbut when I click to set up it tells me it that headsets aren't supported with my bluetooth hardware. My bluetooth does recognize my cell phone though and communicates with it. I minly got it for skype.

    I spent 2 hours on the phone with apple and finally spoke with a product specialist who said it wouldn't work. What ever the **** that meant. I spent another 3 hours searching forums and have found lot's of people complaining about the same problem. This one in particular is a good article. <http://www.macfixit.com/article.php?story=20060106075526729>

    I still have had no success.

    Any suggestions would be greatly appreciated.
    James
    Mac OS X (10.4.7)
  • M. L. Welles Calculating status...
    Currently Being Moderated
    Aug 3, 2006 8:52 AM (in response to Mac Rob)
    Mac Rob:

    I HAD exact same situation as you. Same model G5, same Dongle and version (DBT120 b4)

    Nothing I repeat, nothing worked. I followed all the suggestions (removing bluetooth .plist preferences, resetting the PRAM, etc.) But it made no difference.

    The only thing left to try was to reset the SMU, as there was a hint in the maxfixit article that this might help, but before opening the case, I tried a different computer.

    On my wife's G3 ibook, the upgrader worked just fine.
    .

    One thing I did notice, is that it apparently got confused as to device id's when I looked at the console. On the endlessly failing install on the G5, it said it was trying to update "V:0x0000000 D:0x0000000" , on the install that succeeded, it updated "V:0x0000a12 D:0x0000001".


    GRRRRRR! Whoever wrote AND QA'd that firmware upgrader should be ashamed of themselves. I expect more from apple...



    Powermac G5 (late 2005)   Mac OS X (10.4.7)   Dlink 120
  • Aj Newman1 Calculating status...
    I just went over this entire forum trying to get my Motorola H3 Headset set up with my Powerbook.

    I couldn't get the firmware 1.2 update to work, until I stumbled across the firemware 1.2.1 update...which then worked. May be some fixes in newer version for anyone still stuck.

    http://www.apple.com/support/downloads/bluetoothfirmwareupdate121ppc.html
  • Pq4789 Calculating status...
    I'm getting the same problem on my mac mini. The two bluetooth devices don't seem to be compatable with each other.

    Or is it the fault of my mac?

    The devices I am using:
    DBT 120 H/W vers B4
    and
    Motorola Bluetooth Handsfree Headset HS850.

    Bluetooth hardware specs say I have successfully paired the devices but am not connected.

    Headset shows up in Sound Systems preferences output but not the input.

    One technician suggested that my system does not have HFP profile. Thought I could download the profile, but it doesn't seem to exist.

    The goal here with these new bluetooth purchases was just to enable VOIP service. I seem to have been on a goose chase because I don't think these devices are able to do what they are advertised to do.
    mac mini, Mac OS X (10.4.7)
  • Ryan Bailer Calculating status...
    I am having the SAME problem. I'm so tired of reading all these posts, I feel for you all!

    I originally was trying to connect a BT headset using a BT adapter from Iogear, but after reading all these posts about the DBT-120, I went out and got one (B4). I plugged it in, ran the firmware updater, but the progress bar in the updater seems to stop after awhile. The Status section goes back and forth between "Searching for a device to update" and "Preparing to update device...". It does this for a few minutes, and then goes to "idle". However, the progress bar does not disappear (though it stops moving). Very odd program.

    All these posts say that the firmware update takes a long time, so I wait (even though it says 'idle') for awhile (30 minutes), and nothing changes. So then I try to quit the firmware updater, and I get a message saying, " The Bluetooth firmware has not been updated. Are you sure you want to quit?" At first I hit "Cancel", and ran the update again (which it normally should not let me do if it was in the middle of the update). However, after trying that a few times, I hit "quit", and tried to connect to my headset again, with no success.

    I tried the above steps, all 4, exactly as shown. No success. Any suggestions?

    I'm running a Dual G4 1ghz 10.4.7. When I try to run the 1.2.1 updater, it says "this computer does not need this update".

    Thank you. UGH!

    R
    mgoblue
    Mac OS X (10.4.3)
  • Walter Rafelsberger Calculating status...
    I'm running a Dual G4 1ghz 10.4.7. When I try to run
    the 1.2.1 updater, it says "this computer does not
    need this update".


    If found a solution. First I tried Bluetooth Firmware Updater 1.2 like so many, but it had no effect (After hitting "Update" it returned to Idle-Status after a few minutes with error messages from 5 attempts in the console).

    I downloaded Bluetooth Firmware Updater 1.2.1 (from http://www.apple.com/support/downloads/bluetoothfirmwareupdate121ppc.html) and when I tried to install it, it prompted with the same frustrating "This computer does not need this update."

    Then I did the following:
    I mounted the image and copied "BTFWUpdate1.2.1.pkg" from it to the desktop. After that control-click the file and select "Show package contents". A new window opens with a single directory named "Contents". Inside that directory look for a file named "Archive.pax.gz" and move it to the desktop. Double-Click the file on the desktop. If all goes well it should create an "Applications"-Folder with the Bluetooth Firmware Updater-Utility inside it. Now you finally have a working 1.2.1-Updater. You can copy it to your utilities-Folder, but you don't have to, it works from everywhere.

    Kind regards,
    Walter

    Dual G5 2.7GHz   Mac OS X (10.4.7)  
  • Ryan Bailer Level 1 Level 1 (55 points)
    Walter, GREAT advice. Thank you so much. It seems to have worked. I've since returned the Bluetooth headset I was using, as I didn't like the fit. However, I'll be getting a new one soon. However, when I went to setup a new Bluetooth headset, it started to search for one (even though there wasn't one available), which is further than it's gone in the past.

    Thank you again. I really appreciate it.

    Ryan
    mgoblue
    Mac OS X (10.4.3)
  • j4net Calculating status...
    Were you trying to use a microphone-enabled BT headset? I just got the Plantronics 590A and was told by their support folks I needed support for "the HSP and HSP in addition to audio profile," whatever that means.

    I've not yet installed the BT Updater 1.2 for OS 10.3.9 so I don't know if all this will work together. Like your quest for VOIP service, I want to record some podcasts and make some Skype calls. Hence the built-in microphone.

    Joe
    G4 Dual 450, Mac OS X (10.3.9)
  • Ryan Bailer Level 1 Level 1 (55 points)
    I was trying to use a BT headset (Jabra), in order to use Skype on my PowerMac G4. The BT headset had a built-in microphone (which all of them do...I'm not sure what the use of a BT headset would be w/o a built-in mic.).

    Hope this is helpful!

    Ryan
    mgoblue
    Mac OS X (10.4.3)
  • j4net Level 1 Level 1 (0 points)
    So, installing the firmware worked and your BT headset/microphone can now be used for Skype and other voice needs?

    By the way, how long did the actual installation of firmware take you?

    Joe
    G4 Dual 450, Mac OS X (10.3.9)
1 ... 6 7 8 9 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.