1 2 Previous Next 19 Replies Latest reply: Jan 6, 2007 10:14 AM by sphereboy
quarterwit Level 1 Level 1 (0 points)
Okay, currently if I search for "email" using either Find or Spotlight, I get one result—a readme file. Needless to say, I should get much more.

The following solutions I have tried:

—Dragging HD to Spotlight's Preferences' "privacy" tab and away again ("re-indexing" takes all of 20 seconds...)
—Doing "sudo mdutil -E /" in Terminal (as above)
—Deleting Spotlight preferences
–Running Cocktail and Yasu, thereby deleting my cache, running all cron scripts and fixing permissions
—Deleting Spotlight's invisible folder
—Deleting mds crash state invisible file
—Assuring Bluetooth is not next to Spotlight in menu bar

Occasionally, some of these methods would give me a few results, but in no case anything like what I'd expect. The results using the Finder are the same.

I am at my wits' end, and would be very grateful for any solution to this problem!

Thank you in advance,


Mac OS X (10.4.7)

Mac OS X (10.4.5)
  • 1. Re: Spotlight/Find not working!
    sherry johnson Level 4 Level 4 (2,715 points)
    hi lawrence--

    have you tested spotlight in a new user to determine whether or not the problem is user-related or system wide?? have you tried repairing the disk booted to the install disk to check for directory damage?? [ 8 ) ]
  • 2. Re: Spotlight/Find not working!
    Tom in London Level 4 Level 4 (1,585 points)

    Whilst you're tinkering about with this, I imagine you need to find your files. There is a better way than Spotlight. Download a piece of freeware called "Easyfind" and use it instead.

    Spotlight is a toy for nerds. Easyfind is a serious search tool for people who have work to do and files to find !

    Here's Easyfind:

  • 3. Re: Spotlight/Find not working!
    quarterwit Level 1 Level 1 (0 points)
    Thanks, but that's the response I see on every bloody thread here!

    I do not want other software, I want spotlight to work.

    EasyFind doesn't search metadata, and what's more, it has an ugly icon.
  • 4. Re: Spotlight/Find not working!
    Tom in London Level 4 Level 4 (1,585 points)
    I agree about the icon. But it's only the icon. The WHOLE of Spotlight is ugly, from its fundamental concept to its perplexing UI.

    If you can get Spotlight to work - reliably, quickly, and all the time - we can close down this entire forum!

    Good luck anyway.
  • 5. Re: Spotlight/Find not working!
    Mike N. (nahyunil) Level 6 Level 6 (8,265 points)
    Are emails the only file type you are having problems with?

    As far as the Finder goes
    "The results using the Finder are the same"

    Searches from Finder exclude email messages by default, and I haven't yet seen a way to force them to show.

    From the menubar, or the Spotlight window, can you get your messages to show by typing anything else–name of sender, content term, etc?

    Also, just to be sure... Are you using Apple's Mail.app or a different email client?
  • 6. Re: Spotlight/Find not working!
    quarterwit Level 1 Level 1 (0 points)
    It's not just emails, no. For instance, I have the program MPEG StreamClip on my desktop; it can't find that.

    It might be significant that the program Highlight, which forces indexing, does make this appear in spotlight; however, it's not very thorough, and a folder dragged onto it will not result in everything therein being indexed.

  • 7. Re: Spotlight/Find not working!
    Attila Level 3 Level 3 (610 points)
    Same problem here... it worked perfectly before, then something apparently happened and I can't get Spotlight to work...

    os x 10.4.7, Intel
  • 8. Re: Spotlight/Find not working!
    sphereboy Level 1 Level 1 (0 points)
    Same here. Spotlight is not searching in my home directory. I haven't done anything out of the ordinary. Just stopped working.
  • 9. Re: Spotlight/Find not working!
    sphereboy Level 1 Level 1 (0 points)
    I went ahead and re-installed the Combo Update 10.4.7 and it seems to have cleared up the situation.

    Spotlight seems to be working properly again.

    Spoke to soon. Now it only shows recent items. Not showing all files. Bummer
  • 10. Re: Spotlight/Find not working!
    Old Toad Level 10 Level 10 (115,665 points)

    Welcome to the Apple Discussions. You don't want to use Easyfind. It's the slowest app I've used in a long time. It took around 20 seconds to find what it took Spotlight 2 seconds. And it only found 2 of the forty items that Spotlight did.

    You might try using Spotlightindexer to force index your User/Library/Mail folder (or the entire Library folder for that matter). I successfully indexed much of the system folder and system library folder with it.

    Note: There's a 3rd party GUI front end to Spotlight called NotLight. it lets you use wildcard characters in your search. Quite a powerful search application.
    Do you Twango?
  • 11. Re: Spotlight/Find not working!
    ChristianKnappskog Level 1 Level 1 (0 points)
    I found a way to fix this on my own mac. - It appears that Spotlight fails to properly index files once the «Sptolight is indexing, please wait...» dialog-thing appears. Thus adding and removing the entire HD to the provacy list triggers this, and fails to index it.

    If you do the same procedure recommended by Apple, but in smaller portions, say your «Application» folder first. Then it is indexed. - Continue to do this with your home folder and so on.

    -Add a folder to the privacy list.
    -Search for "." (period)
    -erease searchstring
    -Remove folder from blocklist
    -search for period "."

    Spotlight should now index that folder and the results should grow as you wait. Wait until the amount of results stops increasing, it may pause for a few seconds, so give it a moment.

    This is the procedure that worked for me, searching for period is because every file contains period. - I went from getting a total of 193 results, to getting 16'911 results now.
  • 12. Re: Spotlight/Find not working!
    Alan Mitchell Level 1 Level 1 (55 points)
    I recently had a Spotlight failure, which I think may be related to the latest Security Update installation. I could start a query but when I put in any of my file names Spotlight always came up empty. Also I lost all of my printer definitons, and I could not add a printer since the driver could never be found. I repaired permissions to no avail. Then I reinstalled the latest OS X Tiger update from late June 2006 and restarted my computer. I started Spotlight and it re-ndexed my hard drive. Now everything is working as it should, and all of my printer definitions have re-appeared. Maybe this will help, although the problem may not be exactly the same.
  • 13. Re: Spotlight/Find not working!
    sphereboy Level 1 Level 1 (0 points)
    it's a good solution to keep in mind, but in my opinion re-installing an OS shouldn't be the only way to fix a problem. Obviously whatever happened will be fixed when you re-install an OS, unless it was a hardware based problem you were having.

    i have been able to follow some of the suggestions above and things are going better. Only thing that won't get indexed is the Application folder.
  • 14. Re: Spotlight/Find not working!
    Scott Robert Level 2 Level 2 (350 points)
    download this app "Spotless"

    Disable indexing, Delete all your indexes, and enable indexing. Restart.

1 2 Previous Next