Skip navigation
This discussion is archived

Bluetooth Mighty Mouse Problems

5070 Views 16 Replies Latest reply: May 27, 2007 2:16 PM by annzeise RSS
1 2 Previous Next
Gregga Calculating status...
Currently Being Moderated
Aug 24, 2006 8:56 PM
My wireless Mighty Mouse that I ordered with my Mac Pro has very inconsistent performance no more that 4 feet from the tower. It seems to stick and stutter regardless of the surface. The problem disappears and then reappears. Have ensured that all old drivers have been removed and have gone as far as doing and archive and reinstall of OS X. I have tried third party mouse software to no avail. The strange thing is that it appears to work well with my 14" iBook G4. Any ideas/help?
Mac Pro 2.66 2GB, 500 GB HD, Mac OS X (10.4.7)
  • PunkusMaximus Calculating status...
    Currently Being Moderated
    Aug 24, 2006 9:16 PM (in response to Gregga)
    FWIW, I just tried mine as far as the limits of my room would allow - about 6ft and it seemed to work OK (not that I tried it for very long.) Straight line of sight - my Mac Pro is on top of my desk.

    A couple suggestions:

    - Are you also using a wireless keyboard? Does it work at the same distance?

    - Is there anything between your computer and mouse that might degrade the signal? (I.e. a desktop or the like?) If your G4 is on top of the desk and the Mac Pro below, this might be a clue.

    - I think I saw that the antennas on the Mac Pro are located on the bottom of the unit (I'm sure someone will quickly correct me if this is not true.) Might be a factor in where you have it positioned.

    Take care,
    P.M.
    Mac Pro, Mac OS X (10.4.7)
  • Miltano Calculating status...
    Currently Being Moderated
    Aug 27, 2006 4:41 PM (in response to Gregga)
    I have the same problems. Apple Care shipped me a new mouse and it did not solve the problem.

    My specific issue is that the mouse is not consistently responsive to movement. Very difficult to use. I end up using the mouse with my Wacom instead.

    Milt

    Mac Pro   Mac OS X (10.4.7)  
  • Gerald Edgar Level 3 Level 3 (615 points)
    Currently Being Moderated
    Aug 27, 2006 6:58 PM (in response to Miltano)
    I have the same problems. Apple Care shipped me a
    new mouse and it did not solve the problem.

    My specific issue is that the mouse is not
    consistently responsive to movement. Very difficult
    to use. I end up using the mouse with my Wacom
    instead.



    My wireless Mighty Mouse is fine. When I turn it on, it takes a few seconds to be recognized again, but after that WOW.
    Mac OS X (10.4.7)
  • jrminc Calculating status...
    Currently Being Moderated
    Sep 14, 2006 6:11 AM (in response to Gregga)
    I'm having this exact same problem. The Mac Pro tower is on the floor, the mighty mouse is on a desk above. I received a replacement from apple and am having the same intermittent problems....anyone know of anything to fix this?
    Mac Pro, Mac OS X (10.4.7), Dual 3ghz | 2gb ram
  • bosmacs Calculating status...
    Currently Being Moderated
    Sep 14, 2006 7:07 PM (in response to jrminc)
    I'm having the same problem as well, and there are several other threads in the discussion forums here concerning the same issue -- just search for 'mac pro bluetooth'. It seems to be a range issue; mine is irritatingly sketchy (lags, stutters) just 2-3 feet from the box on my desk. Beyond that, it's pretty much unusable. I opened the side of the box just for kicks, and that seemed to extend the functional range by a foot or two. AppleCare had me reset my pram and smc to no avail. I am of course interested in any possible solutions...
    Mac Pro, Mac OS X (10.4.7)
  • Dr Dave. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 3, 2006 5:48 AM (in response to bosmacs)
    "just for kicks...." WOW, that did it for me!

    This mouse has been driving me crazy (actually, more crazy in my case!). My cpu is sitting on a shelf above my monitor -- the shelf is 20" above my desk.

    As soon as I took the side off my cpu, the mouse started to work perfectly.

    Go figure....

    David
    Mac Pro, Mac OS X (10.4.7), ...all tricked out
  • warheart777 Calculating status...
    Currently Being Moderated
    Oct 3, 2006 9:02 AM (in response to Gregga)
    I have the same issue. It has to do w/the software. Reason why...
    1. Works fine under Windows.
    2. Had the same problem on my Mac Pro and my friend got one and had the same issue.
    Most likely it's something that will be accomplished in a software update.
    Mac Pro 2.66GHz, x1900XT, Mac OS X (10.4.8)
  • Dr Dave. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 3, 2006 9:51 AM (in response to warheart777)
    Hi arheart777:

    I'm going to argue with that....just for fun.

    I had the horrible feeling that it's a design issue. If my MM is performing badly AND the only thing I change is to remove the side cover, AND it works perfectly, this tells me that there is some internal (to the box) interference.

    If you use the mouse on a windows box and it works fine...then move to the MAC and it does not...yes, it could be software, but in my view, likely hardware...or both!

    David
    Mac Pro, Mac OS X (10.4.7), ...all tricked out
  • Schatten Calculating status...
    Currently Being Moderated
    Nov 3, 2006 11:08 AM (in response to Gregga)
    Wireless signals have a hard time penetrating the heavy-duty aluminum cases that the Mac Pros & PowerMac G5s use.

    If I recall correctly, to compensate for this the G5 towers used to ship with a small antenna adapter for the wireless functions; one for Bluetooth & one for Airport. Is this not the case anymore? They would look like small T-Shaped white plastic thingies. They'd plug into the back of the tower. If you have them, plug them in. If you don't, call AppleCare & ask if they're supposed to ship with the machines.
    Powermac G4 Dual 533, Mac OS X (10.3)
  • Malcolm Rayfield Level 7 Level 7 (28,070 points)
    Currently Being Moderated
    Nov 3, 2006 2:39 PM (in response to Gregga)
    There are reports of some Mac Pros with mislabelled antenna wires attached to the wrong cards (AirPort vs Bluetooth), causing reduced range. See
    <http://discussions.apple.com/thread.jspa?messageID=3202197>
    Quicksilver dual 800 MHz, Mac OS X (10.4.8), ATI Radeon 9800 Pro Mac Edition 256 MB
  • swellfonder Level 3 Level 3 (510 points)
    Currently Being Moderated
    Nov 3, 2006 3:08 PM (in response to Gregga)
    After about a week of flawless MM movement, I started to experience the same thing. Mouse and Mac Pro sit on my desk so range is not an issue. I went back to my Logitech MX 1000 which works great with my Mac Pro.

    I am now using the MM with a D-Link BT adapter on my G4. No more problems with the MM.
    Mac Pro 2.66, Mac OS X (10.4.8), 2GB RAM, 2xRE2 500GB, Hitachi 400GB, Seagate 160GB
  • HaraldS Level 2 Level 2 (270 points)
    Currently Being Moderated
    Apr 30, 2007 9:11 AM (in response to Gregga)
    Same issue here still today. Mac Pro sits under the desk. I do believe it is software, when I boot into BootCamp, Windows with the Apple drivers has no trouble!

    -- Harald
    MacBook Pro 2.16 Ghz, Mac Pro 3Ghz Quad, Mac mini 1.42Ghz, others, Mac OS X (10.4.9)
  • David DeCristoforo Level 5 Level 5 (6,175 points)
    Currently Being Moderated
    May 1, 2007 9:31 AM (in response to HaraldS)
    FWIW I had a BTMM which was horrible to use. I installed the Steer Mouse drivers and afterwards thought "Why does apple not simply include this driver with the MM???". It is vastly superior to Apple's driver. It's 25 bucks but well worth it for either the BT or wired version of the MM.



    PS I ended up reverting to the wired mouse because even with the better driver, my BT mouse kept dropping the signal and at least 60% of the time, refused to operate when the computer came out of sleep.
    Mac Pro (Quad), 4 GB RAM, 1X160, 2X250 GB HDD, Mac OS X (10.4.9), 17" MacBook Pro
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.