Skip navigation

MBP audio no longer plays from my speakers...Optical light stays on

78211 Views 151 Replies Latest reply: Nov 11, 2013 6:14 PM by iBlacc RSS
1 2 3 ... 11 Previous Next
Pockets745 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 27, 2006 10:30 PM
Ok, so the other day, I'm using my MBP in the studio, and patch a cord out of the line out jack to listen through the monitors. Ever since then, I no longer have audio through my internal speakers, and the optical light is on all the time. No volume control, and the audio page in sound prefs only shows the digital option. Not something I'm going to just deal with. They WILL make this good. BTW, this is my first post, but I've been reading nightmare stories from all of you out there, and someone at Apple needs to step up to the plate and get these issues resolved. These units are too expensive for us to have to put up with this shoddy example of workmanship. If these were cars, they would have been recalled. Are they not making enough money on the Ipod stuff?


MBP   Mac OS X (10.4.7)   2.16 gig 15" 100 gig HD 2 gig ram
  • Alexandru Level 1 Level 1 (10 points)
    You have the same problem as myself. I've managed to temporarily restart internal speakers by inserting a needle in the socket and short circuit the pins (without pushing on them!!).

    The short version is like this (from my experiments today):

    1. nothing inserted: one of both pins of the socket are grounded and internal speakers are activated
    2. something inserted: if impedance present on pins, means headphones/line-out
    3. something inserted: if no impedance is on pins means optical (afaik toslink is made on plastic, right?)

    Maybe somebody should confirm these ideas.

    Bottom line, you have to replace Left I/O board or try to push and pull a jack in the socket, maybe the bent pin(s) will come to normal position again.
    Macbook Pro, Mac OS X (10.4.7)
  • homertime33 Level 4 Level 4 (1,105 points)

    Ok, shouting to apple on a message board that they do not read won't get you help for your problem.

    What you should do is schedule an appointment at a local apple store to discuss and show someone your problem, or call applecare to discuss your problem.

    They can't help you unless you tell them to, and they're not listening here.

    I hope they can help you fix your audio problem - but unfortunately you won't get an official answer, nor a perfect fix unless you contact them directly
    MBP 2.0GHZ, Mac OS X (10.4.7)
  • Dj_B Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2006 3:54 AM (in response to Pockets745)
    Had the same problem as thousands of you, re: dodgey cheap mutiple output 3.5mm plug. When will they learn one hole for one thing. They try to be too smart for their own good. Anyway, internal speakers weren't working so I tried inserting headphones in and out, but no luck. Then tried inserting a toothpick, but again no luck. Finally succeeded, against my best judgement, to insert a metal object into an optical output. By fiddling about I was able to "realease" the contact that allows the computer to make an assessment on whether a headphone/toslink or "nothing" is inserted. The contact is in the 7 o'clock position. By isloating this contact I gave it a gentle push downwards and it seems to have fixed the problem, but be gentle as there are plenty of things to ruin inside that little connector. Good Luck
    MacBook Pro 15", Mac OS X (10.4.8), Bootcamp+WinXP
  • lucasdambergs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2006 9:21 AM (in response to Dj_B)
    This problem just cropped up on my MacBook Pro. Has anyone had any success getting this fixed under Applecare? This is a new laptop that I just got through Applecare to replace a defective one, which I also got through Applecare to replace the one I bought in 2003...

  • barncat Level 1 Level 1 (0 points)
    This has now happened on my Macbook. Apple has to do something. The reason to buy an apple is that they WORK, if they don't work there is no reason to buy one!!! I am so mad at apple I can't even see straight.

    Bottom line is that apple needs to recall their shoddy products. They also need to improve their build quality.

    BTW this is my 4th apple notebook and my 8th apple system (my first was a Mac Classic circa 1990). If they don't make this right I will never buy another apple computer again.
    Macbook, Mac OS X (10.4.7), Macbook 2.0, Dual 1.8g5 tower
  • Neil Phillips Level 3 Level 3 (735 points)
    A whole day - that's terrible ----- compared to all the real problems in the world. For every laptop with a problem (and I know it is frustrating if it's your laptop), there a thousand perfect ones.

    A little less anger and a bit more laissez fare will make you feel a lot better...and lower your blood pressure.
    Powerbook G4 12, Macbook Pro 15" 2 Ghz, iMac G5,20,BT, 250GB, 1GB RAM,, Mac OS X (10.4.7)
  • Ben Blier Level 1 Level 1 (5 points)
    I have this issue too, on a regular MacBook. I called Apple, and they basically told me, "You're screwed, suck it up." Only a little more polite, by saying, sure... take it to an Apple Authorized Repair place. I'm sitting here... with my brand new computer, that they gave me to replace a previously broken computer, which I bought after my previous computer fried it's logic board AND HD after going out of AppleCare (3 year plan)...
    My family has owned macs since my folks were in college (think first macs). Even while they worked at IBM we were on macs. I'm feeling neglected now, after all this.
    iBook G4, Mac OS X (10.4.2)
  • MikeCurtis Level 1 Level 1 (0 points)
    Yep - same problem.

    It just started recently, as in the last couple of days, and it never happened before.

    I'm thinking it was a Software Update that triggered it, so hopefully another Software Update can fix it. Give them a week to figure it out.

    If nothing by then, THEN ***** and moan.

    MacBook, Mac OS X (10.4.8)
  • Rodney Thomas Level 1 Level 1 (0 points)
    I can't find the "g-spot." So what do I do, just stick the metal in (I'm using an unfolded paper clip) and restart?

    MacBook Pro   Mac OS X (10.4.8)  
  • Adam Ullman Level 1 Level 1 (5 points)
    Oops, I spent ages poking around in the wrong hole. I was poking in the optical out instead of the headphone jack. Was easy as anything once I had worked out the right hole, just have to push a little sensor and then that red light goes off...
    MacBook Pro
  • Oshdog Level 1 Level 1 (0 points)
    Yes, I've had the exact same problem with my imac... frustrating!
    20" Imac Intel Duo Core, Mac OS X (10.4.8)
  • BCMVA Level 1 Level 1 (0 points)
    Okay, add me too! I'm going to try the poking around in the hole thing to see if it works. My MBP was purchased on 11/06/2006, so it is unacceptable to be having this kind of unsupported problem already. Just my humble opinion!
    Macbook Pro, Mac OS X (10.4.8)
  • BCMVA Level 1 Level 1 (0 points)
    Worked like a charm! Thanks!

    Macbook Pro   Mac OS X (10.4.8)  
1 2 3 ... 11 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.