3 Replies Latest reply: Jul 25, 2008 11:44 PM by TheKevinWong
TheKevinWong Level 1 Level 1 (0 points)
Hi. I've been trying to update my 5G iPod to 1.2, but every time i try to do this in iTunes on Windows, a box pops up telling me that this can't be done because the iPod is being used by another program. What does this mean and how can i remedy it? Thanks

Windows XP Pro
  • 1. Re: Can't update iPod; i Pod being used by other program
    iPod_nano_1_GB Level 5 Level 5 (6,810 points)
    Try going to "Task Manager" (Press the CtrlAltDelete keys to open).
    Click on the "Processes" tab.
    Find "iPodService.exe", and click on "end".

    Also, be sure that no other users are logged on to your computer, as this may be causing the problems.


    To try to prevent this problem from happening in the future, try assigning your iPod a different drive letter, following these instructoins below, and see if it works for you:


    Log onto your administrator account on your computer, logging off of any other users.

    1 - Don’t plug in your iPod yet.
    2 - Go to "START -> Control Panel -> Admin Tools (if you don't see this, click on "classic view" button on the left panel) -> Computer Management."
    3 - Click on the "Disk Management" button in the left panel area.
    4 - Now, with "Computer Management" and Control Panel windows opened, reset your iPod, and connect it.
    5 - Right-click on your iPod's listing there (after a few moments when it gets recognized in this drive window), and click on "Change Drive letter and Paths". Then the "Change..." button.

    Here's what it should look like:



    Assign your iPod the letter "M" "N", "O" or the like (further along in the alphabet).

    For more details, see this article:
    Windows confuses iPod with network device / Changing drive letter


    I hope this helps you!

    -Kylene


    If any post helps or solves your issue, please mark it that way accordingly. Thank you for helping the boards!
  • 2. Re: Can't update iPod; i Pod being used by other program
    Sailortilt Level 1 Level 1 (0 points)
    Hi,
    I've been having the same issue since I upgraded to iTunes 7. I've tried all of the fixes I've found here to no avail, including the fix above -- I'm still getting the same error. I am unable to update, restore, or sync properly. Are there any other clues as to what may be causing this?
    Thanks!
    Devlyn

    IBM Clone   Windows XP Pro  
  • 3. Re: Can't update iPod; i Pod being used by other program
    TheKevinWong Level 1 Level 1 (0 points)
    Answered