Skip navigation
This discussion is archived

C2D weird locking up/freezing/hanging?

26283 Views 192 Replies Latest reply: Nov 11, 2008 5:12 PM by Lokesh Nara RSS
  • jkottke Calculating status...
    Currently Being Moderated
    Dec 1, 2006 8:47 AM (in response to George Haritonidis)
    Just to add to the discussion, I've been experiencing this problem with my 15" 1.67 GHz Powerbook as well. Cmd-tab and poof...nothing works except for the mouse. (Two other people in my office have this problem as well, one has a 17" MBP and the other a black MB.) It happens every few weeks or so (first instance occurred 2-3 weeks after I bought it), but has happened 3 times in the last two days, prompting me to try and track down the problem, which led me here.

    I bought this computer about 3-4 weeks before the MacBook Pros came out (mid-Dec), so it's not a chip problem but it could be another piece of hardware that they just recently started putting in them...like a graphics card maybe?
    1.67 GHz Powerbook / 2Gb RAM, Mac OS X (10.4.6)
  • Ethanee Level 2 Level 2 (350 points)
    Currently Being Moderated
    Dec 1, 2006 9:10 AM (in response to jkottke)
    Like Ian, I am starting to think this could be a bug in the graphics library, it looks like an exception occurred that wasn't handled very well. I don't know how reliable the hardware test is, but I think that should eliminate problems with the graphics card. Perhaps the next step is to find some way of reliably replicating it, for instance one might write a simple program that keeps keying in cmd-tab, cycling through all the open windows. I don't know how or if that's possible, but if so, hopefully that will cause the bug to appear much faster. Then someone can bring it to Apple and duplicate the problem before them.

    Btw, I guess there must have been people who submitted bug reports? Is that via the same feedback channel at
    http://www.apple.com/macosx/feedback/
    ?
    MBP CD, Mac OS X (10.4.8)
  • Erin Dalzell Calculating status...
    Currently Being Moderated
    Dec 1, 2006 10:35 AM (in response to Ethanee)
    Just for sh*ts and giggles, I wonder what happens if you use a different cmd-tab switching program, like Proteron's LiteSwitchX (http://proteron.com/liteswitchx/)? I have been using it for years with no problems and I am currently running it on my white MB running 10.4.8.
    iMac
  • Ian Searle Calculating status...
    Currently Being Moderated
    Dec 1, 2006 10:39 AM (in response to Erin Dalzell)
    I have tried not using cmd-tab. Though, I failed at not using it at all (old habits die hard). I was able to substantially reduce my usage of cmd-tab and still ran into the problem.

    I'll give liteswitchx a try.
    Thanks!

       
  • L.E. Kun Calculating status...
    Currently Being Moderated
    Dec 1, 2006 12:06 PM (in response to Ian Searle)
    Just to add: this happens on my MacBook CD. It started happening frequently and I reinstalled and then it didn't happen for a while. Now it happens infrequently.

    I echo much of what has been said: Often happens on cmd-tab switch, but other than that, no other common denominators. I don't have any haxies or low level system software (like a fan control program installed). I don't even have CoreDuoTemp installed.

    I had heard it was a hard drive failure. That your hard drive is parked and when you command-tab it goes to rev up and doesn't – hence the freeze except the mouse.

    To be clear, for me everything is frozen on screen except the mouse.
    Blackbook, 2GB Ram, Mac OS X (10.4.8)
  • Erin Dalzell Level 1 Level 1 (130 points)
    Currently Being Moderated
    Dec 1, 2006 12:19 PM (in response to Ian Searle)
    LiteSwitchX allows one to use cmd-tab. I too, am addicted to it.
    iMac
  • cameronfactor Calculating status...
    Currently Being Moderated
    Dec 1, 2006 4:25 PM (in response to George Haritonidis)
    I've had this same problem on and off with different models since the G4. I posted about it a year and a half ago:

    http://overstated.net/2005/03/23/os-x-keyboard-locking-issue

    It hasn't happened on every rev of the OS or every model I've had, but I have had the problem occur on multiple machines (and the comments show that many other people have as well).
    Powerbook G4, Mac OS X (10.4.8)
  • Ian Searle Level 1 Level 1 (20 points)
    Currently Being Moderated
    Dec 1, 2006 4:56 PM (in response to cameronfactor)
    Wow, thanks for posting that link. I had that problem on an older 15" Powerbook Ti model. But, I don't think this is the problem we are discussing herein. That is, when the keyboard freezes, you can still use the mouse to quit applications and logout. But, with this freeze, the mouse moves, but clicking and moving operations don't do anything. Also, I've tried cmd-opt-esc (force-quit) when the freeze happens and nothing.

    But, I'm sure glad to read your post on the keyboard freeze. If that ever happens, I'll know how to recover without logging out or rebooting. Thanks!

       
  • Nick2005 Calculating status...
    Currently Being Moderated
    Dec 5, 2006 11:03 AM (in response to George Haritonidis)
    Like some others who responded to your post, I'm experiencing the same problem. I've had the system (MacBook Pro, 17", C2D) for almost a week, and during that time, I've had 5 of these lockups/hangs.

    Just to reiterate the details:

    When the machine "hangs", I can move the mouse, but nothing responds when I click on it.

    When listening to music with iTunes, the music continues even while the machine is "hung".

    While the machine is "hung", I can SSH into it (suggested by another poster). Furthermore, I can then "kill" the WindowServer, which causes the machine to return to the login window (suggested by that same poster). Once at the login screen, I can log in and continue to use the machine without restarting.

    In an attempt to fix the problem, I've
    - reformatted the system (with the "zero" option),
    - reset the PMU, and
    - reset the System Management Controller.
    These steps haven't fixed the problem.

    In an attempt to diagnose the problem, I've
    - run Apple's diagnostics several times,
    - run Disk Utility to repair permission/disk more times than I can count, and
    - run the full suite of tests from TechTool Pro.
    Nothing turns up a hardware problem.

    So now the question becomes:
    How do we get Apple's attention re: this issue?

    I called the other day and spoke with a technician -- Kevin. He told me that "Mac OS X has no bugs in the general operating system." I laughed. I'm not saying that this problem is necessarily a software bug, but his claim is rediculous. With that kind of attitude, how do the OS developers ever receive bug reports? After speaking with a supervisor --Harley-- I received a similarly rediculous response.

    Maybe posting these details in this forum will help? We'll see.

    MacBook Pro 17" (C2D)   Mac OS X (10.4.8)  
  • Nick2005 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 5, 2006 6:08 PM (in response to George Haritonidis)
    The problem occurred
    (a) three times while importing my music library (~3500 songs) into iTunes via its "Add to Library..." option in the "File" menu,
    (b) once immediately after pressing command-space to use Spotlight (the search box was fading in when it hung), and
    (c) once moments after starting my system and signing in (I don't recall the particular task).

    I seemed to be able to repeat the problem during the iTunes import. (To finally import my whole library, I imported batches of 500 or so songs, because it hung every time I tried my whole collection.) At that time, I had never tried SSHing to the "hung" machine...

    For the fun of it, here's what I'll do:
    (a) remove all of the songs from my iTunes library and
    (b) attempt to import them again in one big batch.
    It seems like a long shot (I wonder whether it's a different problem?), but it's worth a try. If it hangs, I'll try SSHing to the machine and if that works killing the WindowServer.

    I'll post my results as soon as I have them.

    To answer your question, my graphics card is the ATI Mobility Radeon X1600 (256 MB).

    MacBook Pro 17" (C2D)   Mac OS X (10.4.8)  
  • Nick2005 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 5, 2006 6:42 PM (in response to Nick2005)
    It looks like I'm experiencing two types of freezing (aren't I lucky).

    The iTunes locking is reproducible (I just reproduced it for the fourth time) but different than the other two instances of locking.

    For the iTunes locking, my HD essentially stops. I can move the cursor and select programs on the dock. The selected programs bounce but refuse to load; apparently nothing can access the HD (i.e., no clicking). I tried SSHing to the machine but it wouldn't work. Interestingly enough, I could still ping the machine (which makes sense, since it shouldn't require any HD access).

    For the iTunes locking, I will bring my computer into an authorized service centre, reproduce the problem, and probably get the HD replaced.

    We still have the apparently separate issue of non-HD related hanging...


    MacBook Pro 17" (C2D)   Mac OS X (10.4.8)  
1 2 3 4 5 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.