Skip navigation
This discussion is archived

G3 Powerbook Wallstreet, battery won't charge, new battery won't boot.

4870 Views 7 Replies Latest reply: Jan 5, 2007 7:32 PM by jpl RSS
rrfriends Calculating status...
Currently Being Moderated
Dec 3, 2006 11:46 PM
Got new battery. Reset. Won't boot, even with power plugged in. Tried new battery in both sides. Tried booting with control And command held down. Nothing works. Is it dead?
G3 Powerbook 500 mhz, Mac OS X (10.4.8), new battery
  • jpl Level 7 Level 7 (28,285 points)

    I am not sure which model G3 you have. You mention the Wallstreet in the topic title but also 500MHz and 10.4.8 in the hardware at the bottom of your question. Let's make sure what you have since it has a bearing on troubleshooting:

    A few questions...

    - Were there any symptoms of a hardware problem last time it was used?

    - Have you properly reset the power manager? Make sure you use the correct procedure for your model.
    PB 1400/117, PB G3/233 Wallstreet, iBook/800, Mac OS X (10.4.6)
  • jpl Level 7 Level 7 (28,285 points)

    There is the possibility that your Pismo (Powerbook G3 FireWire M7572) has suffered a corrupted power manager that will not clear with a normal reset. This occasionally happens to powerbooks which are allowed to sit in a discharged state for a length of time.

    There is a simple remedy:

    - disconnect the power adapter and remove the main battery;
    - remove the DVD-ROM drive from the media bay;
    - lift off the keyboard (do not disconnect keyboard ribbon cables...just lay the keyboard face down on the palm rest);
    - disconnect the internal backup battery;
    - now connect just the power adapter and press the power button;
    - if the powerbook starts up normally, shut it down by pressing the power button;
    - reconnect the internal battery and again test startup; if successful, shut down and reassemble; if it fails to start, disconnect the internal battery, then will have to replace the battery. However you can still use the powerbook while waiting for a replacement.

    Here is a guide to the battery:

    Enlarge the bottom picture; the round battery is brown in a black case with a red/white/black pigtail connected to the logic board. Use a pair of needlenose pliers to lift up the white connector.

    If you still have no start, test another power adapter; the PB1400/300/any G3/clamshell iBook power adapters are interchangeable.
    PB 1400/117, PB G3/233 Wallstreet, iBook/800, Mac OS X (10.4.6)
  • jpl Level 7 Level 7 (28,285 points)

    Glad the fix was simple. Thanks for the update.
    PB 1400/117, PB G3/233 Wallstreet, iBook/800, Mac OS X (10.4.6)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.