Skip navigation
This discussion is archived

Wireless Connection Frustration

1159 Views 12 Replies Latest reply: Jan 13, 2007 8:59 AM by Stuart Goldenberg1 RSS
musocp Calculating status...
Currently Being Moderated
Jan 4, 2007 11:19 AM
I have recently bought a 2ghz c2d macbook and am having absolutely no luck connecting onto our existing wireless network. Airport picks it up but after trying to connect comes up with the message 'An error occured trying to connect to 'name of network''. I have contacted Apple and have changed various settings but Airport is normally so simlpe as to just be able to connect onto existing networks. This particular one works fine with our Windows PC.

We were using a WEP password on the network which I wondered might complicate the mac but I took the Macbook to a friend who has the same router without any encryption and it would not connect to that. I have had success connecting onto a Belkin MIMO router but that was not a consistent connection, sometimes showing the 'error' message and sometimes connecting on succesfully. Can anyone shine some light on this problem and what does it mean is the problem when it comes up with the 'error' message?


I am using a D-Link DSL-G604T/UK ADSL modem router and am with Virgin Broadband.

Macbook white   Mac OS X (10.4.8)   2ghz c2d
  • Mark Parrinder Calculating status...
    Currently Being Moderated
    Jan 4, 2007 12:46 PM (in response to musocp)
    Having just set up my dads new MB with our old 604T router we found the same problem. im not too sure how we managed it but i think we restarted the whole network and it started to pick it up. if you have altered some settings within the router have you made sure you have saved and restarted them else it wont take effect. The router's management pages didnt load up well in safari and we used the windows machine on the network to alter settings.

    sorry i have been a bit vague on the answer but it is possible to connect and i had the same error message as you.

    Mark.
    12 PowerBook G4 1.5GHz, Mac OS X (10.4.2)
  • imranorchid Calculating status...
    Currently Being Moderated
    Jan 4, 2007 1:49 PM (in response to musocp)
    I just bought the new Macbook Pro and I'm having the same problem (so is a friend of mine who also bought the same model). Airport detects our closed wireless network, but won't connect to it. I was first able to connect to an open network, but now can't even do that.

    I took it to the apple center and they couldn't detect anything physically wrong with the computer, especially since it connected to their network without any problem!

    It would be great if somebody could provide some sort of solution as we've tried just about everything and this is growing increasingly frustrating.
    Macbook Pro, Mac OS X (10.4.8)
  • judeandrea Calculating status...
    Currently Being Moderated
    Jan 4, 2007 9:08 PM (in response to imranorchid)
    I am having the same exact issue with my brand new Macbook. I am a traditional PC notebook user and the 3 PC notebooks all connect fine with the wireless router that we have - Netgear WPB824 RangeMax. My Macbook connects fine with Safari/internet with an ethernet cable connected to the Netgear router. So I don't think the issue is with the router or the Motorala cable modem router with my ISP (Comcast), since this is what the Apple customer service person tried to tell me this morning while I sat on the phone for a very long time with no help in solving the problem. She suggested that I take it to the Apple store in person. But it sounds like that may not help.

    Like you, I connected to an unsecure wifi in my area for about 30 seconds and then it disappeared and it no longer works. I do have safari connect to the initial yahoo page but any links to other content on that page does not work and then I get the same message - I am not connected to the network/server/etc. ...

    Help?
    MacBook, Mac OS X (10.4.8), Wireless Connection Problem
  • aloha2ian Calculating status...
    Currently Being Moderated
    Jan 4, 2007 9:38 PM (in response to musocp)
    I am unable to connect to the network as well. I am not even receiving a signal. My friend is able to easily connect to the network on his MacBook.
    15" MacBookPro 2.0 with 512 MB, Mac OS X (10.4.7)
  • Paul Isaac Calculating status...
    Currently Being Moderated
    Jan 5, 2007 11:50 AM (in response to musocp)
    BINGO! I have exactly the same problem and exactly the same modem (the D-Link DSL-G604T). I've spent about two hours on the help line and this is what we found: I have two macbooks. The first, bought in Septwmber, works beautifully. The second, bought last week, finds the network just like yours but comes up with the same error when I try to connect.
    The last person I spoke to on the help line (I got steadily passed upwards) said that the only difference between these two laptops was the dual core processor and that the core 2 duo was new and, sorry, but he had no solution for me. Probably Apple only guarantees their Airport card to work with their own base station, he said, but he wasn't sure and he said he would escalate it to the Apple engineers in the US and let me know.
    I will definitely keep you informed if I hear anything back, as we are almost kindred souls! I can't tell you how much grief I've had over this, especially when my local Apple Store (I live in the Netherlands) essentially told me to ** off.
    Paul
    (paul.isaac@planet.nl)
    macbook, Mac OS X (10.4.8)
  • judeandrea Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2007 12:21 AM (in response to Paul Isaac)
    I have my problem solved! I went to the Apple Store today and the genius said that he has seen this problem and there is no 'sure fix' but he had the same problem at home and he had to reinstall the wireless router in his home. This is the same solution that some others in this discussion had to do as well. I also spoke with my brother in law since they are experienced Mac users and he did not have the problem on his PowerBook but my sister did with her iBook when they were setting it up. He said that it had to do with the existing wireless router encryption set up so he reset the settings and re-set up the wireless router.

    I had the WPA encryption set up (standard password) but switched to a WEP passkey set up and it worked like a charm. Disabling it all together worked but I wanted my network to be secure and not have others piggyback off of it.

    Good luck to all!
    MacBook, Mac OS X (10.4.8)
  • Paul Isaac Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 6, 2007 3:17 AM (in response to Paul Isaac)
    Following the suggestions here, I tried completely restoring my router back to the factory settings and then setting it back up again. Nothing. The Core 2 Duo still doesn't work, but the MacBook I bought in September still does, as do the two windows PCs on my network.
    Now I'll wait and see what answer the Apple help guys come back with. Meanwhile I fear I may have to buy a different router
    Paul
    macbook, Mac OS X (10.4.8), D-Link DSL-G604T
  • Bobeth10 Calculating status...
    Currently Being Moderated
    Jan 9, 2007 4:48 PM (in response to musocp)
    hey guys, i need some hlp, i have an airport extreme and i'm not able to connect to more than 1 computer at a time. Anyone know wats wrong?
  • Duane Level 10 Level 10 (117,955 points)
    Currently Being Moderated
    Jan 9, 2007 4:51 PM (in response to Bobeth10)
    jakemartin10, Welcome to the discussion area!

    Ensure that the AirPort Extreme base station (AEBS) is configured so that the option to distribute IP addresses is ENABLED.

    BTW, in the future you should start a new thread instead of tagging onto another one with a completely different problem.
    iBook G4 14" 1.42 GHz [1.5GB-60 GB], iMac G5 20 1.8 GHz [2 GB-160 GB], Mac OS X (10.4.8), iBook 466 SE Graphite [DVD-576M-40 GB-AirPort],iMac G4 700/768, iPod Photo 30 GB
  • Paul Isaac Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 13, 2007 4:38 AM (in response to Paul Isaac)
    One week later and I never heard back from the Apple help line. Therefore, from all I've learned I come to the conclusion: The Core2Duo doesn't work with the DSL-G604T ADSL router and Apple have no solution at present.

    I solved my problem by borrowing a wireless access point of someone and connecting it to the G604T. Now older Macbooks connect through the G604T and Core2Duo version through the access point.

    MacBook   Mac OS X (10.4.8)   D-Link DSL-G604T
  • Stuart Goldenberg1 Calculating status...
    Currently Being Moderated
    Jan 13, 2007 8:59 AM (in response to musocp)
    Your very interesting post has had me jumping thru hoops this past couple hours!

    I have the same D-Link DSL-G604T as you and I have tried to recreate your problems.

    My set up is the D-Link DSL-G604T with an ethernet wired Airport Express base station and 3 more remote Airport Express's. Having no problem with my internet connection at all I powered off my Airport Express base station and tried to connect direct to the D-Link DSL-G604T. Again, no problem. It DOES work with both my G4 Power Book AND my Intel 25" iMac!

    Here are some tips which may help you:

    1. When you set up the D-Link DSL-G604T it does respond well to Safari. It is better to access the router's home page with MS Explorer, using Explorer for Mac or better yet through a Windows machine or Windows virtual machine (viz. including Windows on Bootcamp or Parallels).

    2. Having changed any set up details on the router, you must go to tools/system commands/save all/restart or the changes will not be saved.

    3. For some reason known only to D-Link and the Good Lord (no, not Steve Jobs, THE Lord!) a wireless encryption key wants a space between every 2 characters. I have a 64 bits key that looks like this: xx xx xx xx xx

    4. When trying to connect your Mac you can leave out the spaces, but try WEP 40-128 bit hex as well as WEP

    5. The easiest way to test a new wireless set up is to remove the WEP protection on the router first and try to connect your Mac without it. This will narrow down when your problem is. If it works you can add WEP protection and try again.

    In summary, the D-Link DSL-G604T works fine with Intel and non-Intel Macs, but hates Safari.

    A final work around for you is this:

    Buy an Airport Extreme, hard wire it to the D-Link DSL-G604T, set it up as a base station and connect through that. Give the Airport Extreme a different SSID though or your Mac will not know which network it is trying to reach.

    I hope this helps!

    iMac 24" 2.33 GHz Intel Core 2 Duo, 3 GB 667 MHz DDR2 SDRAM   Mac OS X (10.4.8)   Apple Wireless Keyboard and wireless Mighty Mouse

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.