6 Replies Latest reply: Jan 6, 2007 4:04 PM by JDHOW
JDHOW Level 1 Level 1 (0 points)
I have 2 windows XP pcs, DLink Router 524 and I just purchased a macbook. When I connect with no encryption WPA or WEP my safari works fine. When I change the router to WPA with a password it works fine for about 10 - 30 mins. After that all of sudden Safari just stops working. The top right shows the signal is there, I can close safari and then reopen and still it says no connection. Any ideas??? I am new to a mac and loving it other than this WPA stuff.

MACBOOK, Mac OS X (10.4.8)
  • 1. Re: Loosing connection
    judeandrea Level 1 Level 1 (0 points)
    Have you figured out your problem? I am also having a similar problem with my Netgear wireless router with my new Macbook. I will also post a similar question and see if there are any responses.
  • 2. Re: Loosing connection
    JDHOW Level 1 Level 1 (0 points)
    i emailed my local apple dealer today and the response is as follows:

    WPA is not a problem, my dlink is and older model however, try this. in the system preferences add your isp server dns' and select ipv6 underneath Dns servers and turn from automatic to off. I haven't tried it yet and am going to this Sat. I will let you know if it works...unless of course if you try it then please let me know.
  • 3. Re: Loosing connection
    JDHOW Level 1 Level 1 (0 points)
    Tried and doesn't work.
  • 4. Re: Loosing connection
    JDHOW Level 1 Level 1 (0 points)
    I've come to the conclusion that it is not my router (unless it is too old), there a quite a few people in this discussion group that are having the same type of problem with different types of routers therefore i believe it is the airport that is causing problems....therefore i give up on trying to encrypt it..if anyone does get theirs working then i would really appreciate being contacted. Thanks.
  • 5. Re: Loosing connection
    judeandrea Level 1 Level 1 (0 points)
    I have my problem solved. You may want to try this if you have not already. Try to reset your wireless router (back to default settings as if you just purchased it), then reinstall it or re-set it up.

    The genius at the Apple Store said that it is freakishly weird and it is not the AirPort but perhaps a combination of new technology (the AirPort) with old/existing software - the wireless router set up prior to trying to connect with AirPort.

    So, I went home and reset the wireless router. I also had to use a different encryption setting WEP vs. WPA since the WPA (standard password) would not work. It took me a few times to experiment. I tried just seeing if my MacBook would connect with no password or encryption, and it connected perfectly. However, I did not want people piggybacking off of my network, so I wanted to add encryption. The WPA did not work on the MacBook - my computer would still show connected but then Safari and Firefox would not work. So I tried the WEP setting and it worked perfectly.

    Good luck!
  • 6. Re: Loosing connection
    JDHOW Level 1 Level 1 (0 points)
    I did what u suggested and poof you are correct it worked, unfortunately I haven't browsed the net for more than 5 min yet but I am hopeful. I have been told that WPA is more secure than WEP though. I am going on a training course next Saturday and I will ask more information about the WEP and WPA. I will also ask about connecting with WPA and keep you informed.