Skip navigation
This discussion is archived

Server monitor not working (hardware monitor)

1409 Views 10 Replies Latest reply: Mar 1, 2007 4:35 PM by themonkman RSS
Jonas Eklundh2 Level 1 Level 1 (10 points)
Currently Being Moderated
Jan 11, 2007 2:57 AM
Just finnished installing my brand new maxed out Intel Xserves. And the Server monitor isn't working.

This thread:
http://discussions.apple.com/thread.jspa?messageID=643361

Didn't solve my problem. hwmond is running on the Xserves but each server line just says "Waiting for response". My /System/Library/ServerSetup/SetupExtras file doesn't even HAVE a Disabled key. It has Label, OnDemand, Program, ProgramArguments and ServiceIPC keys, but no Disabled. And the hwmonds is running anyway.

I have opened server monitor on the xserve itself and tried to open it to itself with no luck. I have configured Lights out management by choosing Server->Configure local Machine and added another IP there with different login, but I can't connect to either IP. Firewalls are all turned off.

Running /System/Library/ServerSetup/SetupExtras/hwmondSetup just says "already loaded"

Server Admin works, I can log in and edit services. Workgroup manager also works.

When i run the hwmond as root on the server, it says "Failed to communicate with the front panel" which could be due to hwmond already running, but I can't turn off the process since launchd (?) launches it again.

When I choose "Configure local Machine" the password I entered is always blank, but maybe that's by design.

Since these servers aren't installed yet I have them in my office and their IP's are temporary, so I read this:

http://docs.info.apple.com/article.html?artnum=106830

And it says that for this environment I should set the hostname to "localhost" in /etc/hostconfig. Done. Nothing changed.

I've googled this and searched here but found nothing. I'm running out of options... What should I do?
Xserve Quad 3Ghz Intel, Mac OS X (10.4.8)
  • Wolax Calculating status...
    Currently Being Moderated
    Jan 24, 2007 3:03 AM (in response to Jonas Eklundh2)
    I have exactly the same problem!

    New Intel Xserve. Fresh Setup. "Waiting for response"..

    tried all the settings u tried with the same results!

    Have you found a solution now??
    Xserve 3GHz Quad-Xeon, Mac OS X (10.4.8)
  • Michael Ojaste Level 3 Level 3 (530 points)
    Currently Being Moderated
    Jan 25, 2007 4:38 AM (in response to Wolax)
    Mac Pro 2 x 2.66Ghz intel 2006, Mac OS X (10.4.8), ATTO SCSI320 2CH, Highpoint 2322 SATA 2 RAID
  • tmoldovan Level 1 Level 1 (10 points)
    Yes, setting up the LOM Access has resolved the "Waiting for response" issue for me.
    Mac OS X (10.4.7)
  • Antonio Rocco Level 6 Level 6 (10,095 points)
    Currently Being Moderated
    Feb 14, 2007 2:59 PM (in response to Jonas Eklundh2)
    How did you do the install?

    I know it sounds daft as the latest XServes have built in video ports so headless installs should be a thing of the past but . . did you target disk mode the XServe to another mac and do the install from there?
  • tmoldovan Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 15, 2007 6:44 AM (in response to Antonio Rocco)
    I set the server on a desk and do a fresh install off a DVD with the "erase HD" option. Then I install and configure the software I need (Software update, Sophos, power options, etc.) I did not configure LOM at that point, because I wasn't sure how to do it, and I needed to deploy the server. (luckily LOM was easy enough to set up after it was deployed.) Once the server is ready, I connect a FireWire HD to it, which has OS installed on it and boot from that.
    That way my server is just an attached disk, and I use Disk Utility to create an image of it, which I then deploy on other servers.

    I've had an issue with the G5 XServes where such a method required relatively simple modification before the server monitor would work:
    http://docs.info.apple.com/article.html?artnum=301046

    But, I've not had to do that with the Intel XServes.
    Mac OS X (10.4.7)
  • Antonio Rocco Level 6 Level 6 (10,095 points)
    Currently Being Moderated
    Feb 15, 2007 12:34 PM (in response to tmoldovan)
    I dont understand why you are doing what you are doing, but do you get the problem with Server Monitor when you boot from the Server itself?

    I can see why Server Monitor wont work if you are booting the server from an external hard drive. Is the System on the external drive a clone of the System on the XServe?
  • tmoldovan Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 15, 2007 1:55 PM (in response to Antonio Rocco)
    Antonio,
    there's a misunderstanding, I'm only installing the images of the FW drive, I'm not running the servers off of them after the install.
    (And actually I don't have a problem any more, it was resolved once I set the LOM up.)
    Mac OS X (10.4.7)
  • Antonio Rocco Level 6 Level 6 (10,095 points)
    Currently Being Moderated
    Feb 16, 2007 1:48 AM (in response to tmoldovan)
    Thanks.

    Can you please click Yes by the side of Did this topic solve your issue? We can close this thread and move on to another one AND I get some brownie points.

    Happy Days
  • Wolax Level 1 Level 1 (20 points)
    Currently Being Moderated
    Feb 20, 2007 11:20 AM (in response to Jonas Eklundh2)
    Hello...

    here the final solution I found after 1 month (I gave up a while ago after even the apple support got no solution)

    Problem: Intel Xserve says "Waiting for response" in "Server Monitor"

    Solution:
    (Make sure you are useing the LOM-IP and Username/Password and not the one from the server directely)

    The whole secret is: Use the Server-Tools from the disk shipped with the server and NOT the Server-Tools from the Apple page!!

    Sounds stupid but it's true...only the Server-Tools from the disk are working completely!


    Hope to help all the other people with that stupid problem.

    bye

    Xserve 3GHz Quad-Xeon   Mac OS X (10.4.8)  
  • themonkman Calculating status...
    Currently Being Moderated
    Mar 1, 2007 4:35 PM (in response to Wolax)
    Wolax,

    That fixed my problem. Thank you!!! Apple really has to become better at providing thorough documentation. It doesn't seem to tell you which IP to put in (iLO or Server IP) or which username, either. Also, I was using the Server Monitor from Apple's website too, which was probably causing some issues as well.

    You rock!
    Macbook 2Ghz Core Duo, Mac OS X (10.4.8), 2GB RAM, 100GB HDD

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.