Previous 1 2 Next 21 Replies Latest reply: May 14, 2007 5:35 PM by bradimmanuel Go to original post
  • Apex81 Level 1 (0 points)
    Hey, I'm having the same problem that was noted above, but when i do the apachectl configtest i get this output(1.1.1.1 was used to hide my ip):

    [Tue Mar 6 19:13:16 2007] [warn] default VirtualHost overlap on port 16080, the first has precedence
    [Tue Mar 6 19:13:16 2007] [warn] default VirtualHost overlap on port 16080, the first has precedence
    [Tue Mar 6 19:13:16 2007] [warn] NameVirtualHost 1.1.1.1:16080 has no VirtualHosts


    Mac Pro   Mac OS X (10.4.8)  
  • Celia Wessen Level 4 (1,155 points)
    You must have two of the same virtualhost settings. It might not show up in ServerAdmin (config errors never show up in ServerAdmin). Take a look in /etc/httpd/sites. The sitename.conf files should be in there. Make sure that there are no two files with the same sitename AND port number. In this case, there should be two files 000xdefault16080.conf and 000ydefault16080.conf.

    OR did you touch the /etc/httpd/httpd.conf file by hand? You might have placed a VirtualHost directive in the wrong place or you may have added reference to other .conf files that include the same statements.

    What you could do first, is to determine if you need WebPerfCache. If you don't know what it does, you probably don't need it. Go into ServerAdmin and turn it off for the site 1.1.1.1.
  • Tony Andrews1 Level 1 (15 points)
    I'm not sure why removing the quotes would have fixed the problem. I am having the exact same issue... several hosts set up, but no matter what url I use the default site appears.

    I tried what you just described above (and every other suggestion) and the problem continues.
  • Tony Andrews1 Level 1 (15 points)
    Good grief.

    I read another (older) post after looking through this one and have found the problem.

    If you look at the "Aliases" tab for the first site on the list you will probably find an asterisk. Delete the asterisk and see if you still have the same problem. The asterisk should go on the last site listed.
  • Dave Slayton Level 1 (0 points)
    After 5-6 hours of trying various suggesting / checking config files etc, here's what worked for me.

    GUI - Add to the aliases tab for each site
    www.mysite.com

    Although mentioned in Apples docs, didn't indicate it was required.
    My first site worked fine without this, guess I assumed web server would understand it needed to reply to www.domain -
  • Simon2.3 Level 1 (20 points)
    Hi There.

    Many thanks to the poster of the * pointer!!


    My httpd.conf seemed fine, and i was completely baffled.

    Every site i had entered manually into the sites pane had a pesky * record created for it by the kind GUI


    This problem seems specific to 10.4.8
    i did not have this problem 10.4.6
  • bradimmanuel Level 1 (0 points)
    I just encountered this on a fresh install OS X Server Universal. Updated to 10.4.9 plus security patches, before any configuration was added. Oddly enough, things worked at first but then stopped working. Removed the * was the key.

    Thanks!

    Brad
Previous 1 2 Next