Skip navigation
This discussion is archived

Safari 3 crashes everytime it opens.

12687 Views 96 Replies Latest reply: Jul 2, 2007 2:37 PM by Tom34 RSS
1 2 3 ... 7 Previous Next
BillieXP Pro Calculating status...
Currently Being Moderated
Jun 11, 2007 12:58 PM
I have windows XP Pro and I downloaded Safari 3 because I am a Mac user and I wanted Safari on my XP machine. I crashes every time that I try to open it up. It pops up the box Safari has a problem do I want to send it to Microsoft. Any help would be greatly appreciated.
I built the computer, Windows XP Pro
  • mdweaver7485 Calculating status...
    Currently Being Moderated
    Jun 11, 2007 1:05 PM (in response to BillieXP Pro)
    Just wanted to add some of my own experiences to this.

    Crashes when accessing Java/JavaScript pages.

    Also found issues with username/passwords in the urls.

    Crashes on Sharepoint with authentication.

    Crashes on Citrix MPFS4.0 web interface.

    Maybe some of this applies to you.
    Windows XP
  • Federico Parodi Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 11, 2007 1:27 PM (in response to BillieXP Pro)
    Same here. It seems like WinSafari is having the same troubles of the first edition of iTunes 7.2, which didn't work on older processors.
    iBook G4 1GHz, Mac OS X (10.4)
  • Loweded Wookie Calculating status...
    Currently Being Moderated
    Jun 11, 2007 1:36 PM (in response to BillieXP Pro)
    I can't login to our proxy.

    As soon as I enter my details and click login the app crashes.
    1.66Ghz Intel Mac Mini, Mac OS X (10.4.9)
  • wikedguy Calculating status...
    Currently Being Moderated
    Jun 11, 2007 2:31 PM (in response to BillieXP Pro)
    I am having this same problem - "Safari has encountered a problem and needs to close" blah blah

    I agree with Federico Parodi, it looks very like the problem with iTunes 7.2.0.35, which has now been fixed.
    That crash was apparently caused by "an SSE instruction set that is not present on some older CPUs". For some reason, Apple do not have any hardware that matches this configuration in their QA lab. Any Apple techs looking might wanna check that out.
    Only difference I notice is that, for me, Safari looks as though it's about to load, then crashes. With the iTunes crash, it went straight to the error with no delay. I just see the top of the Safari window, then it crashes. Still, it looks similar.
    Oh well - firefox is probably better anyway.

    PC   Windows XP  
  • marktech101 Calculating status...
    Currently Being Moderated
    Jun 11, 2007 2:44 PM (in response to BillieXP Pro)
    Yes. I have the same problem; I just installed the beta of Safari for Windows on my Pentium 2 400 MHz machine. It rune windows XP Pro and crashed instantly. However, I also installed it on my XP Home 3 GHz system and it runs fine; i thing it does have something to do with an SSE instruction.
    PC 3 GHz or PC 400MHz, Windows XP Pro, I have two - one new, one old
  • ArchiTex Calculating status...
    Currently Being Moderated
    Jun 11, 2007 2:48 PM (in response to BillieXP Pro)
    Does not load the GUI...menus missing, no way to navigate...won't allow any text to be input...have downloaded twice!
    Dell Dimension 8300, Windows XP Pro
  • Sarpel Calculating status...
    Currently Being Moderated
    Jun 11, 2007 2:55 PM (in response to BillieXP Pro)
    I have the same problem, I have downloaded 3 times, didn't make any difference.
    MacPro, Mac OS X (10.4.9)
  • nt_gd Calculating status...
    Currently Being Moderated
    Jun 11, 2007 3:05 PM (in response to Loweded Wookie)
    I have the same issue. In my application log I see the following:

    Log Name: Application
    Source: Application Error
    Date: 6/11/2007 2:19:47 PM
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: XXXXXXXXXXXXX
    Description:
    Faulting application Safari.exe, version 3.522.11.3, time stamp 0x466c3cec, faulting module CFNetwork.dll, version 1.185.6.0, time stamp 0x466c263f, exception code 0xc0000005, fault offset 0x0000af81, process id 0x155c, application start time 0x01c7ac6e3374fb8e.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2007-06-11T21:19:47.000Z" />
    <EventRecordID>9495</EventRecordID>
    <Channel>Application</Channel>
    <Computer>computername</Computer>
    <Security />
    </System>
    <EventData>
    <Data>Safari.exe</Data>
    <Data>3.522.11.3</Data>
    <Data>466c3cec</Data>
    <Data>CFNetwork.dll</Data>
    <Data>1.185.6.0</Data>
    <Data>466c263f</Data>
    <Data>c0000005</Data>
    <Data>0000af81</Data>
    <Data>155c</Data>
    <Data>01c7ac6e3374fb8e</Data>
    </EventData>
    </Event>

    Dell D620   Windows Vista  
  • fredsm Calculating status...
    Currently Being Moderated
    Jun 11, 2007 3:06 PM (in response to Sarpel)
    me too :'(
    Acer Travelmate, Windows XP
  • Anthony MacCarthy Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 11, 2007 3:12 PM (in response to BillieXP Pro)
    I'm a Mac User and it's crashing everytime I try and launch. I'm running 10.4.9 and everything on my system is right up to date... I hope someone has a fix by morning... I'm off to bed here in Ireland... I'm starting to see double... been a long day....

    Nightie night...
    MacPro 3GHz with 30" ACD and 8GB RAM, Mac OS X (10.4.9), G5 PowerMac 2Ghz Dual / PowerBook G4 Titanium / PowerMac G4 / PowerMac G3
  • deusbrackers Calculating status...
    Currently Being Moderated
    Jun 11, 2007 5:10 PM (in response to wikedguy)
    I'm running on Vista Ultimate on an Intel Core2Duo E6600, hardly an old CPU and Safari crashes me instantly when I launch the program
    Custom, Windows Vista
  • NaCl Calculating status...
    Currently Being Moderated
    Jun 11, 2007 5:16 PM (in response to BillieXP Pro)
    I'm having the same problem here...

    I'm quite disappointed. I would expect that from Microsoft, but not from Apple.

    The problem is probably not the processor, since a friend with a Duron could get it to work.
    Athlon XP, Windows XP Pro
  • codeman38 Calculating status...
    Currently Being Moderated
    Jun 11, 2007 6:43 PM (in response to BillieXP Pro)
    Indeed, this does appear to be another case of the dreaded SSE instruction bug, at least from what I can tell.

    The exception code in the crash report that I'm encountering is 0xc000001d (illegal instruction) - just like in the iTunes bug.

    The exception occurs in Virtual PC for PowerPC Mac (which has no support for SSE instructions), but I don't get the error on a real Pentium 3.

    PowerBook G4 1.6GHz   Mac OS X (10.4.3)  
  • codeman38 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 11, 2007 6:42 PM (in response to NaCl)
    Apparently Durons do support SSE instructions, or at least there were several references to such support that I found with a Google search.
    PowerBook G4 1.6GHz, Mac OS X (10.4.3)
1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.