Skip navigation
This discussion is archived

No Connection Through Linksys

6654 Views 25 Replies Latest reply: Oct 23, 2007 7:20 PM by punchline RSS
1 2 Previous Next
Christopher Archer Level 1 Level 1 (30 points)
Currently Being Moderated
Jun 30, 2007 11:46 PM
Again...Apple has out done themselves. This iPhone is absolutely amazing and I love it to death. However, he's my situation. I got the phone from a Cingular / AT&T store in my shopping center where I work. Went back to work and activated it and hopped on the net to see how it worked...AMAZING. Went to my other job later that night where we have a new Apple router. Got on Safari...and again...AMAZING. Got home even later that night and went to get online to show my mom and I just sat there spinning. I've read through some other posts and tried a few things (Unplugging the router to do a hard restart...telling the iPhone to forget this network) and nothing has worked. Any suggestion? Linksys WRT54G
MacBook (Intel Core Duo), Mac OS X (10.4.9), 100GB HD, 2GB RAM, 1.83GHz
  • Sean Kosanovich Calculating status...
    Currently Being Moderated
    Jul 1, 2007 12:09 AM (in response to Christopher Archer)
    I'd suggest to maybe follow the steps outlined in this post....

    http://discussions.apple.com/thread.jspa?threadID=1019041&tstart=0

    It worked for everyone so far, however all of us seem to have Belkin routers. It can't hurt though, right?
    eMac, Mac OS X (10.3.8)
  • Boblive77 Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 1, 2007 1:56 AM (in response to Christopher Archer)
    I'm having a similar issue... The iPhone does not switch to my home wi-fi automatically (via Linksys router). I have to manually make it switch by going into settings. The setting for "Ask to Join Networks" is on... I tried following the steps in the link provided... but the DNS number that I found from my router was already programmed in by iPhone.
    MacBook Pro, Mac OS X (10.4.10)
  • Johnster Calculating status...
    Currently Being Moderated
    Jul 1, 2007 4:42 AM (in response to Christopher Archer)
    I too have had the same issue. Apple told me to call Linksys, Linksys was no help. Looking for a work around or patch but Linksys says, we don't support Apple. Though the lady from India was very curious about my lovely iPhone, (C; Hoping to hear of a solution and if so will post here.
    core 2 duo, Mac OS X (10.4.10)
  • rgcrowley Calculating status...
    Currently Being Moderated
    Jul 1, 2007 6:47 AM (in response to Christopher Archer)
    Same problem with the wireless access point WAP54g. Iphone found everything fine but no web access.

    Surely someone at apple reads these posts. Surely someone at apple uses a linksys home network.
    imac 17, Mac OS X (10.4.10)
  • williadw1955 Calculating status...
    Currently Being Moderated
    Jul 1, 2007 7:26 AM (in response to Christopher Archer)
    I have a linksys router and can get on with no problems...

    Possibly, the problem is you have your router set to not broadcast the wireless SSID to the world. Log into your router and, under wireless, you will see the selection

    Wireless SSID Broadcast: Enable Disable

    Check the Enable and I think you Iphone will find your signal, provided you have entered the correct WEP Encryption paraphrased password.

    As soon as you disbale the SSID Broadcast though, the iPhone will drop the connection.

    This, in my opinion, is a flaw in the iPhone. It should maintain the signal . I have 1 PC and 2 laptops in the family that do so with no problem
    Self Built AMD Super Computer, Windows XP
  • Jemhad Calculating status...
    Currently Being Moderated
    Jul 1, 2007 9:41 AM (in response to Christopher Archer)
    I had the same problem with my WRT54GS and I updated my firmware to version 1.52.0 since that version "resolves issue with IP address assignment via DHCP on some particular devices" quote from linksys website. Now the iPhone uses the wifi connection perfectly.

    Hope this is of use

       
  • toddster Calculating status...
    Currently Being Moderated
    Jul 1, 2007 10:31 AM (in response to Christopher Archer)
    For what it is worth... I had the same problem with my Linksys wrt54g wireless router. After trying a few things without success, I reset the router (put the button on the back for 30 seconds) & then re-ran the setup cd that came with the router. Not an elegant solution but now the iphone can play over wi-fi.
    imac g5, Mac OS X (10.4.3)
  • SFC @rcher Level 2 Level 2 (400 points)
    Currently Being Moderated
    Jul 1, 2007 12:08 PM (in response to Christopher Archer)
    Nothing listed here has worked for me. I have the same lynksys router and i have tried secure, unsecure etc etc etc. It will simply not connect and i have been looking for a solution for two days now, trying everything that works for others...so please keep the ideas coming...otherwise everything was smooth hassel free and workin great!
    Sony VAIO VGN-A790, Windows XP
  • Netgear Rouetr - same issue Calculating status...
    Currently Being Moderated
    Jul 1, 2007 6:10 PM (in response to williadw1955)
    I'll try it out. If this works, thanks a ton!!
    G5, iPhone
  • morph686 Calculating status...
    If this doesn't work, please add a little more info on the type of setup: WPA or WEP, B/G/mixed, etc. I have a WRT54G and have had no problems using my iPhone on it.
    Dell 9100, Windows XP Pro, 8GB iPhone & 80GB iPod
  • txladykat Calculating status...
    Currently Being Moderated
    Jul 1, 2007 6:43 PM (in response to Christopher Archer)
    i had the same problem with the 54gs linksys. the only way i was able to get on was to disable my security code (which I am not crazy about cause neighbors love to jump on my bandwith). Now i can connect using wifi, but it doesnt stay connected. periodically i have to back into connections and tell it to connect.
  • Ray Haneski Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jul 1, 2007 6:46 PM (in response to morph686)
    I have a wrt54g and connected with no problem.
    I am using mac filtering, only allowing connections from certain mac addresses so I first added the iphone wifi address into the mac filter list on the router.

    My network id is broadcast and the iphone picked it up and showed it with a lock (meaning it is secured) I tapped on the network to enter the password as wep hex, it connected and now joins it automatically.

    make sure the firmware is up to date in the linksys.
    Ray
    Powerbook g-4 17 inch, Mac OS X (10.4.8), 1.5 ghz 1gb ram
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.