8 Replies Latest reply: Sep 20, 2007 2:04 AM by 88b&w
scottinhawaii Level 1 Level 1 (5 points)
The only domain I was able to successfully get up and running in iWeb 08 is only 7 pages. It's a trial to convince some clients to redesign their site. I started it in iWeb 06 as the Modern Theme. I liked the new Modern Frame theme, and went through all seven pages and changed them, fixing them up and saving after each page. Everything looked great until I quit iWeb 08 and started it back up. The theme has switched back to Modern, although when I go into switching the theme again, iWeb seems to think that these pages are already on the Modern Frame theme as it is greyed out as a choice of theme.

Anyway theme switching doesn't work either. The one project I thought I could use iWeb 08 for and it's useless. I'm shocked that Apple would release this junky application.

Macbook 2.0 ghz, Mac OS X (10.4.10)
  • 1. Re: Theme Switching not working
    Paula F. Level 2 Level 2 (355 points)
    Have you read about iWeb '08 here? Paula

    There are also tutorials, plus more to read:

    http://www.apple.com/ilife/iweb/
  • 2. Re: Theme Switching not working
    scottinhawaii Level 1 Level 1 (5 points)
    LOL. A tutorial isn't going to change the fact that the application just doesn't work.

    I changed the theme. Made the pages pretty. Saved. Reopened iWeb and the changes were gone.
  • 3. Re: Theme Switching not working
    Cyclosaurus Level 6 Level 6 (12,915 points)
    would you like to experiment?
    the only common in what you described is the beginning of theme name, to begin this experiment; *please make copy of your domain.sites2.*

    the experiment begin here:

    1) open your Modern theme domain
    2) switch theme to Baby theme
    3) save, *publish to a folder*, quit iweb, check the publish folder, make sure it is in Baby theme
    4) open Baby theme domain, switch to *Modern Frame* theme
    5) save, *publish to a folder*, quit iweb, check the publish folder, make sure it is in *Modern Frame* theme

    if all went well, publish your domain as you would, and check it again.
  • 4. Re: Theme Switching not working
    Robert DuBose Level 2 Level 2 (305 points)
    I am beginning to wonder if the problems that I am having are also theme based. My symptoms are that I can edit a site (created from scratch) in iWeb 2.0, but after making a number of changes and saving them, when I would go to publish it to a folder on my Mac to preview the site, iWeb would crash part way through the publishing process. When I'd next open the domain file, the several of the pages would be missing images. (Not just custom images that I'd put there, but also components like the "Made with a Mac" image.)

    With a lot of experimentation I've been able to (I believe) narrow it down to the blog that I have in the domain file. If I delete that (leaving only photo albums), the site saves and publishes fine, and can be edited without problems. If I go back and add in an empty blog, the app will crash again when I try to publish it.

    The reason I'm posting this as a reply to your thread is that I've found that if I switch the blog theme away from the one I was using (Gazette) to anything else, it seems the problems will go away. I don't know if I've got a bad template for the Gazette theme, but I wonder if others have seen something similar. I haven't tried reinstalling iWeb to see if I do have a corrupted theme template, as I want to continue to try to edit to see if it will crash or not when using another them than Gazette.

    At this stage I'm still trying to collect as much data as I can (including crash dumps) so that I can pass on whatever might be useful to Apple, along with the conditions that were tried.
  • 5. Re: Theme Switching not working
    scottinhawaii Level 1 Level 1 (5 points)
    I tried your experiment.

    It publishes to a folder fine. However, when I close and reopen iWeb it's reverted back to the Modern Theme, but the greyed out one is now Baby.....
  • 6. Re: Theme Switching not working
    Cyclosaurus Level 6 Level 6 (12,915 points)
    sounds like a real bug... you should report it.
  • 7. Re: Theme Switching not working
    Tuckerman Level 1 Level 1 (0 points)
    That's interesting. I thought my iWeb 98 update wasn't working at all. Lost text, jumbled text in wrong font, unable to edit. I was fearful of having to redo the whole thing when (with frustration) I changed theme from White to Modern. Suddenly everything reappeared. I seem to be able to use many of the themes - but not White or Black or - but I can used most of the others just fine. When iWeb trys to use one of the themes that doesn't work it takes a LONG time to open. So I rather conclude that you're right - there's a theme problem here. Where are themes kept? And weren't there some from the first iWeb and more added with the upgrade? Or maybe (?) it's a font problem???

    Hummm? Tuck
  • 8. Re: Theme Switching not working
    88b&w Level 1 Level 1 (5 points)
    I am also having a theme problem. I rebuilt my old site with iWeb '08, and published it fine. Today I opened it up to make some changes, and the site that was created with the old theme is missing things, mostly backgrounds for that theme. The odd thing is that when I look at the domain package contents, the files are there.

    The other site that was created from scratch using a new theme is fine.