1 2 Previous Next 19 Replies Latest reply: Sep 16, 2007 3:57 PM by eljay4
Andrew Campbell-Burt Level 1 Level 1 (50 points)
Each time i turn on my new iMac or wake it up it refuses to auto reconnect to my Wireless network. Have to manually connect it up by typing name and key in despite this info being in preffered networks list.

Only thing that came to mind is not showing the SSID, ie its invisible. That said 3 other iBooks in my house all have no issues... + tried my mothers MacBook, also perfect. Tried clearing Keychain access to WEP hex key. Removing network from 'Preffered network list' restarting and re-entering it...

Any ideas please?

iMac 24" 2.8Ghz, Mac OS X (10.4.10)
  • 1. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Cray7 Level 1 Level 1 (0 points)
    I just installed my new 24" iMac 2.8Ghz and noticed the exactly same problem.

    I have three different wireless networks available to test:
    Airport network (Extreme+Express in WDS mode, SSID hidden, WPA2 Personal)
    Airport Network (Express, SSID visible, WPA Personal)
    D-Link 802.11b network (SSID visible, WEP 128)

    Most of the time I can connect to each network manually by selecting "Other.." from Airport menu but iMac does not auto reconnect to any of these networks when they are added to preferred networks list. Their network keys are succesfully stored to keychain. I have 90%-100% signal to all of these networks.

    My other Macs (MacBook Pro, iMac G4 20" and iBook) are able to connect and auto reconnect without any problems. All computers including this new iMac 24" has latest Mac OS X 10.4.10 and all software updates installed.

    Occasionally iMac also loses all (even SSID visible) networks from Airport menu. Also when this happens clicking the Aiport menu displays "spinning beach ball" for several seconds.

    First sign of wireless network trouble I noticed was when I first started the new iMac and tried to connect to Aiport network with the Setup Assistant at first boot. iMac did not detect any of these available networks even if I manually entered their SSIDs and encryption keys. This tells me that problem is not due to misconfiguration made after "fresh from factory"-boot.

    I am going to call Apple support today.
  • 2. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    dgrutsch Level 1 Level 1 (0 points)
    I noticed the same on my new iMac 20" with the 2.4 Ghz CPU. Exactly the same behaivor. With the IBook G4 all works fine and i never noticed Problems with Wireless Connectivity.
  • 3. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Andrew Campbell-Burt Level 1 Level 1 (50 points)
    I managed to fix it, what I did was enable SSID. Then I changed the password encryption from WEP 40 hex to WPA using the same password. Rebooted the D-Link 4300 router.

    Then in OS X wiped all previous passwords and preferred network lists. Then rebooted went to Network Config and added the new network as a preferred network. Within a split second the wireless status picked up the new higher level encrypted network and joined it.

    Restarting and waking from sleep is now solved. All works as normal. Other Macs were configured in the same manner.

    Hope that helps.... I think its not a hardware issue, just have to trick the iMac into connecting permanently
  • 4. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Visiteur Level 1 Level 1 (0 points)
    I had the same symptoms intially: my new alu 24" 2.4 GHz iMac couldn't connect automatically ( Airport Extreme base, Airport Express WDS, WPA2 personal, SSID hidden).
    In the end I got round the problem by simply unhiding the SSID, making sure I did this on the Express WDS as well as on the Extreme Base unit.
    I have another two Macs on this network connecting OK, so I've no idea why the iMac was having a problem - nor have I investigated further!
    Unhiding the SSID is not so drastic: at least neighbours can see (& avoid) your channel.
  • 5. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    nsinlaguna Level 1 Level 1 (0 points)
    I am having this problem as well. Mine differs a little however.

    I did a systems migrate from my previous G4 iMac. Upon wake up, the signal strength on the top right is black. after 10 seconds, it goes out. I have to manually click on it and select my network (which is visible I dont hide the SSID).

    I am loathe to change anything on my Linksys router since 3 other machines (windows) connect to it as well.

    In the network settings, it still list my SSID and the default network. it's been happening since the day i got the unit 2 weeks ago (the day after they came out). I'll keep you guys updated about what happens.
  • 6. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    dgrutsch Level 1 Level 1 (0 points)
    Tried with unhidden SSID but even does not work. It is i a little bit strange, the iMac doesn't connect to the WLAN at all but the iBook G4 does it all the time.
    All Router configurations where immediately reflected on the iBook but on the iMac nothing changes. I think this might be a software problem, the iBook runs also on OS X 10.4.10 but is not a Intel.
  • 7. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    James Looker Level 1 Level 1 (15 points)
    I am also having this problem with my 24inch 2.16 ghz iMac with the "n" patch applied. On startup it can never find my network even tho it is in the preferred list and always tries to connect to a neighbors secured network. On startup from sleep it just refuses to connect making me have to do it manually. It's driving me nuts!
  • 8. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Cray7 Level 1 Level 1 (0 points)
    I don't think enabling SSID broadcast qualifies as a fix for this problem.

    All other Macs I have work perfectly with the existing hidden (no SSID broadcast) network but my new iMac 24" 2.8Ghz does not.

    I do not want to broadcast my network ID's to neighbours just because there is hardware or software driver bug with the new iMacs.

    This issue needs a real fix from Apple.
  • 9. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    MacAndersen Level 1 Level 1 (0 points)
    The same issue here with the new iMac 24" 2.8 GHz.

    Network: AirPort Extreme base station, original round, V5.7. Closed 802.11b/g network with hardware access control, 128 bit WEP security. DHCP sharing a single IP adress (DHCP and NAT) using 10.0.1.1 addressing. No problems with my "old" 2 GHz Core Duo also running 10.4.10, one MacBook Pro and two G4 iBooks.

    The new iMac is able to connect without problems by entering network name and password from the AirPort menu or using Internet Connect. However, it forgets the network after restart, even if entered as a preferred network. Tried the following based on different sources with no success at all:
    1. Repairing permissions.
    2. Deleting preferred network including corresponding keychain record, restarting and re-entering information.
    3. Changing the AirPort channel.
    4. Deleting a number of preference files and restarting (in ~/Library/Preferences, com.apple.internetconfig.plist, com.apple.internetconfigpriv.plist, com.apple. internetconnect.plist)
    5. Resetting NVRAM.
    I guess the next step will be reinstalling the System...
    A response from Apple would be really nice.

  • 10. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    James Looker Level 1 Level 1 (15 points)
    I fixed mine by:

    Removing all the preferred network from the list in Network.
    Restarting
    Adding my network a fresh including the password.

    My iMac now automatically connects to the network after a restart and after waking from sleep.
  • 11. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Riccix Level 1 Level 1 (0 points)
    Same problem (iMac 2.8GHz) plus frequent failures to connect to Server/Internet. Once I have manually (again!) logged on to the Airport the indicator stays bold but the connection repeatedly fails. Safari network diagnostics shows red or yellow for Internet and Server but this spontaneously recovers for a few minutes then fails again - it's very disruptive hheeellllppppp. This problem appeared after about 2 days.
  • 12. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Riccix Level 1 Level 1 (0 points)
    Tried connecting via ethernet and problem still there.
    Tried new router and problem solved.
    Hope this works for similar snags to mine.

    This is my 4th router in about 3 years!
  • 13. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    shaiboy_uk Level 1 Level 1 (35 points)
    Hi,

    I bought a new iMac 20" 2ghx on Saturday from the New Apple store in Glasgow Scotland, got home and all seemed fine till I restarted after updates and it wouldn't find the wireless connection even though saved under preferred networks. Had to re-enter the wireless details including WEP password, then connected fine, SSID hidden. But then restart and went again. I turned the SSID to broadcast and then restarted and it was fine.

    Spoke to a Genius in the store the following day, and said they didn't know of any issues, as far as they were aware the new iMac's used the same wireless cards as old iMac's so shouldn't be any issues.

    So going by other people having same issues their seems like a problem, and Apple don't know about it.... If Apple are listening, any chance fixing this one?

    Thanks
  • 14. Re: 24" iMac 2.8Ghz problem with wireless reconnection wake up
    Cray7 Level 1 Level 1 (0 points)
    Good news. Apple is doing something about this issue:

    Yesterday I got call back from Apple (tier 2) technician. He emailed me Apple service software that collects debugging information (logs, network packet captures etc) . Later I sent him back the collected data after reproducing the problem on my new iMac 24" 2.8 Ghz.

    He believed this to be an airport driver issue and not a hardware issue with the new iMacs.

    Hopefully the collected information will help Apple locate and fix the problem.
1 2 Previous Next