Skip navigation
This discussion is archived

Help!! Started upgrade and it failed; now my startup HD is not recognized!

1862 Views 7 Replies Latest reply: Jul 6, 2008 11:26 AM by yotimbo60 RSS
yotimbo60 Calculating status...
Currently Being Moderated
Oct 30, 2007 10:40 PM
Help me please!

I started a Leopard installation and chose "upgrade" (going from 10.4) to my "Macintosh HD", which is my startup HD. Leopard started to install, but then I got an "Install Failed Mac Os X could not be installed on your computer" message. So I exited the installation program, removed the DVD and restarted the computer. A white screen came up with a flashing grey "world globe" in the center. This did not look good, so I re-inserted the Leopard DVD and manually turned off the computer and then manually started it again.

And my startup HD is not recognized by the installer. When I try to install Leopard, the installer does not see the "Macintosh HD", just another internal set of RAID HDs, which I do not want to be the startup disk. I need to get back to the one that was there two hours ago. If I take the DVD out and restart, it goes back to the flashing world globe logo on a white screen.

I tried using Disk Utility from the Leopard DVD and it does show the "Macintosh HD" drive (along with the two RAID drives) but when I click on "Verify Disk" or "Repair Disk" I get this message:

Verifying volume "Macintosh HD"
Checking Journaled HFS Plus volume
Invalid B-tree node size
Volume check failed.
Error: Filesystem verify or repair failed

In addition, a window pops ups saying First Aid failed, for basically the same reason.

I read in some of the other discussion that some people had luck by waiting 10 or 20 minutes for Leopard to recognize their HD but this has not worked, since I think Leopard basically started to install and erased some stuff.

Has Leopard fried my HD? Any thoughts anyone?
Mac Pro 2.66GHz Quad Xeon (2 Dual Core), Mac OS X (10.4.10)
  • Macsterguy Level 1 Level 1 (80 points)
    I know this is no help...
    My Leopard is un-opened and being returned.
    Ans to think we payed for this abuse!

    I have seen 100's of post like yours here. Have a look and you will find many.
    I hope that it works out for you...
    G4, G5 iMac, 12" Powerbook, Work: 21 Mac's, Macbook (my son's), iPone, Mac OS X (10.4.10)
  • Sylvia Slater Calculating status...
    The same thing happened to me on my G5 iMac. A little scarey but eventually it booted, then I ran disk utility on it and it said everything was OK.
    iMac G5, Mac OS X (10.4.10)
  • DJ.RO Level 1 Level 1 (60 points)
    same thing basically happened to me. I had no other choice but to archive and install, and still there are lots of issues. Leopard needs to get its act together...
    15.4" MacBook Pro 2.0GHz/1.5GB RAM/80 GB, Mac OS X (10.5.1), eMac 1 GHz/512 RAM/80 GB 30GB Video iPod/1G iPod Shuffle
  • Brett Suann Calculating status...
    I had a very similar problem. Being a techno-pinhead I just put in the installation disk. It gave the only option as 'Erase and Install' and quit. That was the last time I spoke to my Mac. Everytime it started up it just shutdown again. I started it up from the Leopard disk and tried to verify or repair the hard drive but got a similar error:
    Verifying volume "Macintosh HD"
    Checking Journaled HFS Plus volume
    Invalid node structure
    Volume check failed.
    Error: Filesystem verify or repair failed

    And that was it. Of course I didn't back it up first so after hours of trying to find solutions it's back at a service provider at the Apple Shop...but I'm not holding out much hope. I've probably lost all of the data on it....so if you really need to install Leopard (and I'm still hoping it's worth it) then MAKE SURE YOU BACKUP FIRST!
    G5, Mac OS X (10.4.1)
  • Mark Sieber Level 1 Level 1 (15 points)
    I don't know how this will affect the Leopard install, but I just had the "World Globe" show up on boot for the first time after running Leopard for five weeks.

    I found this thread http://www.applefritter.com/node/21599 which explains that the the "World Globe" indicates the computer is trying to boot from network. A poster suggests holding down the option key at that screen to get a choice of boot disks. The choice of disk vs network boot can be changed in System Preferences-->System-->Startup Disk (once you can access System Preferences.)

    I hope this helps...it may remove one variable during the installation process.

    Note also that holding the N key at boot chooses the network boot--this could occur accidently.

    Mark S
    MacBook Pro, Mac OS X (10.5.1), Airport Home Network
  • TripleChime Level 1 Level 1 (110 points)
    Disk Warrior may be able to repair your disk directory structure. I had 3 Firewire partitions on one drive and one full drive get corrupted in a similar manner while using my "Upgrade" installation of Leopard 10.5. Disk Utility could not repair them but Disk Warrior was able to repair them back to normal usage despite reporting "severe" directory damage. Disk Warrior also found and repaired minor problems on several other Firewire drives.

    I now have an "erase and install" Leopard that I built up on an external drive without using Migration Assistant. I have recreated all settings by hand and reinstalled all applications (that I am sure are Leopard compatible) from their installers. This is working well with only a couple of tiny inconsequential glitches so far.

    Fortunately, I had made multiple bootable backups of my Tiger installation and had also saved all of my important files like photos and iTunes Library onto optical media as well.
    Macs Since 1984!, Mac OS X (10.5.1), trying out Leopard Family Pack on 12" G4 Powerbook 1.5 GHz.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.