Skip navigation
This discussion is archived

Leopard Does Not Recognise My Password - Help!!

10798 Views 58 Replies Latest reply: Nov 23, 2007 2:11 AM by Philipp Gutzwiller RSS
  • Jonathan Tatlow Calculating status...
    Currently Being Moderated
    Oct 31, 2007 4:59 AM (in response to Julian Brown)
    I upgraded from 10.4.9 to 10.5 yesterday and had a similar thing - only said "Other..." and I could not sign on. None of the "gobbledygook" methods helped - a bit scary anyway. This morning I spoke to the local Apple supplier, who suggested I re-run the install, but click on "Options" and select "Archive & Install". (The default is just "install", which is what I ran first time.)

    At the end of the "Archive and Install" the user names were back, and everything seems normal.

    I hope this works for you.
  • holls at whidbey Level 1 Level 1 (0 points)
    I finally went ahead with an archive and install strategy too, but it didn't help.
    Fortunately, it does not appear that I'm much worse off as far as loss of files. The old user folders still appear to be intact, although I can not access my main user account (and I think it may be gone for good with the archive and install). Hopefully I can figure out permissions and get data available.
    Mac OS X (10.5)
  • Paul Laskin Level 1 Level 1 (25 points)
    I had a similar problem and fixed by the following manual method.

    I have a backup (SuperDuper created image) of my hard drive prior to upgrading to 10.5. That image has 3 users; 2 Admin and one Standard.

    After doing a clean install of 10.5 and then using Migration Assistant to copy over the 3 users only 1 account acted as an Admin account. No matter what I tried I could not get the 2nd account to act as Admin. Plus, funny things were going on like the screen saver required the root or admin account username and password to log back into the currently active account.

    So, I deleted the 2nd user (non-functioning admin account).
    Did a reinstall (upgrade only) of Leopard.
    Then created a user with the same name and password as the old '2nd user' giving that user Admin rights.

    I then logged in as the 1st Admin user and via System Preferences / Accounts.
    Set the Group and User ID for the 2nd Admin user to the same number as it was on my 10.4 install. (Right Click on the 2nd User to see the GID and UID).

    Finally, I logged in as the 2nd user. Checked to see that the screen saver worked and started copying over all my files for the 2nd user off of my backup.

    The only thing that doesn't work properly now is with the Standard user (user 3). I still need to enter either root, user1 or user2's credentials to exit the screen save. I'll probably just delete user 3 and do the manual copy to get things working. .. later.

    One more thing -- I now doubt that the reinstall of Leopard helped. Migration Assistant (whether run manually or as part of the install) appears to be doing something funky.
    MacBook Pro C2D, Mac OS X (10.5)
  • Andrew Ellis1 Calculating status...
    Currently Being Moderated
    Oct 31, 2007 9:48 AM (in response to Paul Laskin)
    I had a worrying couple of days - used AppleCare for the first time in the 22 months since I bought my notebook.

    Problem exactly as described - took a more senior product specialist to get it to work but he stuck with it and saw it through. He got very worried when having got me to reset the root account password so I could get in my old user profile was not visible. Bit scary as I had not backed up my data fully for a couple of months.

    Had to create a new disk image and copy old profile across then delete the old one.

    Works now - I have everything save for my old Safari bookmarks.

    I would not have been able to do this without someone on the end of a phone. Part of me resents these issues but on balance I am well impressed with the AppleCare response.

    Am in process of first Time Machine backup (which is taking about one hour per Gig by the way)
    PowerBook G4, Mac OS X (10.5)
  • ben_faulkner Calculating status...
    i have tried this but it still does the same with the System Administrator or root (just does not log in) i do not know what to do now...
  • Jim Leonard Calculating status...
    Thanks to Ted,

    Well I finally resolved my login by using the new Sys Admin etc, now I have to find previous files etc also. All this appears to be due to "File Vault" the iBook I upgraded was fine without File Vault!

    I am just glad I did not upgrade my MacBook Pro.

    I did try several of the other fixes but this seems to be the best when there is limited space on the disk as with mine.
    MacBook Pro 15", Mac OS X (10.4.7)
  • Rob2885 Calculating status...
    I encountered the same problem with Leopard. The login dialog box appeared amid the galaxy, I typed the name and password, the background turned blue and then the login dialog box reappeared. I spent an hour on the phone waiting for Apple Support, then was walked through a series of commands after single-user startup (referenced earlier in this discussion chain). But this did not help. The Apple Support person said in closing that choosing "Archive and Install" (as opposed to Install) from the Options menu on the Leopard installation disc was a known way to fix the problem. So I did this, reinstalling Leopard and archiving the old system. It worked.

    My question is.... if this is such a significant problem should Apple reissue installation discs to those of us who are early adopters ? It's sort of like paying too much early on for the i Phone and then getting a rebate. I have several other computers that I'd like to install Leopard on but am gun shy at this point.
    iMAC, Mac OS X (10.5)
  • Mark Block Level 2 Level 2 (270 points)
    Currently Being Moderated
    Nov 4, 2007 7:58 PM (in response to Rob2885)
    I agree with Rob2885. Apple should reissue Leopard installer discs if requested.

    I paid extra for a "Family Pack" just to be a good guy. I first did the install on my PowerBook and it hosed the Keychain, but that wasn't such a big deal. Next up was my wife's Intel iMac, and we now can't log in. I've tried all the solutions listed in this thread short of Archive & Install, but no luck. I'm now logged in as root to research the problem. There seems to be no easy way to log into my wife's account.

    I've spent hours on this, but I guess I'll have to bit the bullet and do an Archive & Install, which is a pain in the ***. Bad show, Apple. I've upgraded from 10.2 to 10.3 to 10.4 and now to 10.5 on many different family Macs. Leopard is the first OS update that has given me any trouble. There's no way I'm putting it on the G5 until these installations issues are addressed by Apple.
    PowerBook Titanium 1GHz / Dual 2.5 G5 / Intel iMac, Mac OS X (10.5)
  • artful Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2007 6:33 AM (in response to Rob2885)
    Your solution sounds like the simplest. Only one question: did you check “Preserve Users and Network settings”? I’m afraid if I do, I’ll end up in the same endless loop. If I don't, I’m not sure which of my previous users files and home folder will be available. What worked for you?
    iMac, Mac OS X (10.5)
  • artful Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2007 6:37 AM (in response to Rob2885)
    This is my first trip to the message board. I was trying to reply to Julian Brown post yesterday:

    Your solution sounds like the simplest. Only one question: did you check the “Preserve Users and Network settings”? I’m afraid if I do, I’ll end up in the same endless loop. If I don’t, I’m not sure which of my previous users files and home folder will be available. What worked for you?
    iMac, Mac OS X (10.5)
  • eatapc Calculating status...
    Currently Being Moderated
    Nov 5, 2007 7:25 PM (in response to artful)
    Artful, to cure the inability to log in (on my wife's iMac) after the Leopard install, I just tried an Archive and Install, checking "Preserve Users and Network Settings." Unfortunately, I'm still in that endless loop. I can't log into the account. I hate Leopard. It's installed on my PowerBook (where it lost my Keychains), but I get depressed looking at it, knowing what horrors await people trying to install it. After all the delays releasing it, the install DVD is a POS.

    I guess a clean install is now my only option. I did back up her User folder before the installation disaster, so I suppose I can get most of her settings back.
    Titanium Powerbook, G5, Intel iMac, Mac OS X (10.5)
  • eatapc Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 5, 2007 7:27 PM (in response to eatapc)
    BTW, I'm the Mark Block who posted just above. (And who has posted 28 times before.) Because my Keychain was hosed (I think), the support forum wouldn't let me log in without creating a new account. Very odd.
    Titanium Powerbook, G5, Intel iMac, Mac OS X (10.5)
  • Vaughan Clarkson Calculating status...
    Currently Being Moderated
    Nov 10, 2007 10:23 PM (in response to Williams)
    I got the same error message to the dscl command (eDSUnknownNodeName) when in single-user mode. I was stumped then, because I couldn't log on to any account, not even root (except in single-user mode). Here's the steps I then followed to get it working:

    1. From the command line in single-user mode, I typed 'passwd' which allowed me to enter a new root password (I just re-entered the old one!).
    2. 'reboot'.
    3. When the computer had rebooted, I was able to log in as root (System Administrator), but still no sign of my usual user account.
    4. Logged on as root, I ran Software Update to get the Keychain update (not sure if this is a necessary step). Reboot again.
    5. Logged on again as root, I was then able to do as another contributor to this forum suggested (though I can't find the post now to give credit): I opened System Preferences and added a user with all the same details as the account I'd had 'pre-Leopard'. A pop-up informed me that it had found a directory with the same name and did I want to use that one as the home directory? I said yes.
    6. Logged out as root. Now my usual user account appeared on the login screen and I could log in to it. Everything then worked fine.

    Anyway, I hope this might help someone!
    PowerMac G5 Dual 2 GHz + iMac G4 + PowerBook G4 + Mac mini G4, Mac OS X (10.5)
  • Vicki Gerdes Calculating status...
    Currently Being Moderated
    Nov 12, 2007 7:24 PM (in response to Soldi)
    When I followed this link:

    http://docs.info.apple.com/article.html?artnum=306840

    I did as instructed, and when I typed in this:

    launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist

    and hit Return, I got a message that said "Socket is not connected."

    What am I doing wrong?

    Message was edited by: Vicki Gerdes
    MacBook Pro (Intel Core 2 Duo), Mac OS X (10.5)
  • Vicki Gerdes Level 1 Level 1 (45 points)
    Currently Being Moderated
    Nov 12, 2007 7:33 PM (in response to Vicki Gerdes)
    Please see previous message.

    Message was edited by: Vicki Gerdes
    MacBook Pro (Intel Core 2 Duo), Mac OS X (10.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.