Skip navigation
This discussion is archived

Leopard Router Problems

1842 Views 7 Replies Latest reply: Nov 19, 2007 7:01 AM by GlennB RSS
Bruce Sprague Level 1 Level 1 (25 points)
Currently Being Moderated
Oct 29, 2007 8:44 AM
I have noted many posts of users suddenly getting router problems after the Leopard installation.

I too had problems with my MacSense XRouter MIH-130A XRouter Pro router AFTER the 10.5 update. I found that after EVERY Mac reboot OR coming out of sleep, my internet connection was lost! My Safari and Mail were useless. I figured at first it was my cable internet provider, and rebooted the cable modem and router, and that fixed it...until the next reboot or coming out of sleep.

To troubleshoot, I then I bypassed my router, and went from the cable modem directly into the Mac, and had NO problems at all. Went back into the router browser setup page, and played with all functions, but this did not help fix the problem. Something about Leopard has changed things and is a little more picky....I suspect that the IP address is getting lost until things reboot......something that Tiger had no problems with.

Sooooooo.....today I just got a new Apple Airport Extreme router.....and bingo, ALL works well! I am happy with the Airport Extreme....it will give me more flexibility than the old router had.

As a side note, my Safari is bringing up web pages faster than I have ever seen.
Macbook Duo, Macbook Duo 2, iPod 60Gb Video, Mac OS X (10.5)
  • magnatar Level 1 Level 1 (135 points)
    Currently Being Moderated
    Oct 29, 2007 9:07 AM (in response to Bruce Sprague)
    On router issues, usally the prob is one of not having DHCP selected on the Mac, which is the default setting. If you have DHCP set but when looking at the network prefs in System Prefs, you see the IP address at 169.xxx.xxx.xxx, then that means the router/dhcp server is not talking to the mac.

    If that happens, bring up the terminal and try checking the network connection. Use ping to check in the following manner;

    - local interface ( as reported by 'ifconfig -a' )
    - then the router address ( most times 192.168.1.1 )
    - then the ip address assigned to the modem/gateway by your ISP
    - then the DNS server/s
    - Last but not least www.apple.com
    Apple II+ to Quad Intel, Mac OS X (10.4.10)
  • The hatter Level 9 Level 9 (58,535 points)
    Currently Being Moderated
    Oct 29, 2007 9:16 AM (in response to magnatar)
    When I got my Mac Pro a year ago I noticed it seemed slower than expected, especially as I aslo went from 768K DSL to 1600k. ISP wanted to check out why I was only getting 1200K or slightly less.

    Since then I've seen a lot of feedback on MacFixit about Intel Macs, and in my case and others, either firmware update or a new router did the trick. Vista users are having some of the same problems and need to look for "certified" or compatible with new OS.

    I now get 1600k - same router model, only 4th generation rather than 1st.
    Mac Pro 2GHz 6GB WD Caviar, Raptor, Mac OS X (10.4.10), Nvidia 8600 GTS Cinema HD Sonnet 2EP APC RS1500 Vista x64 Home Premium
  • MOWellsEsq Calculating status...
    Currently Being Moderated
    Nov 5, 2007 12:26 PM (in response to Bruce Sprague)
    I have the same router, the XSense XRouter Pro 130A. Since installing Leopard on my MacBook Pro, I have been freezing up the router when I try to check my mail with Leopard's Mail app. This makes my wife quite unhappy when she is trying to use the Internet. Resetting the router clears the issue. The router is close to seven years old, I guess it will have to be replaced. But I would like to understand why this is happening. I suspect the DHCP server is wigging out for some reason. I'm at a loss to what changes could be made to either the router settings or the MacBook Pro's network setting that would stop this from happening.
    MacBook Pro 2.33 mHz, Mac OS X (10.5)
  • Roy Pembroke Calculating status...
    Currently Being Moderated
    Nov 6, 2007 1:01 PM (in response to Bruce Sprague)
    I am having the same problem - the (wireless) internet connection is lost on sleep, start or restart. I have just spent some time on the phone to my ISP's help desk and we experimented with a number of ways round this problem and none worked. The conclusion of the ISP help person was that Leopard does not seem to recognise and pick the router's password from the Keychain. The password is not saved in the relevant Network Prefs panel but it is saved in the keychain. Put it back in the NP's panel and it connects.

    Another little problem I hope will be dealt with on the first update?
    iMac Intel, Mac OS X (10.5)
  • vvebsta Calculating status...
    Currently Being Moderated
    Nov 17, 2007 3:46 AM (in response to Bruce Sprague)
    We should start a list of all the routers people are using with Back to My Mac/printing/airdisk...etc. that AREN'T working with Leopard.

    Mine is a westell wireless router. Leopard wont even recognize it.
    iMac 20" 2.33ghz Intel Core 2 Duo, Mac OS X (10.4.8)
  • MFerreri Calculating status...
    Currently Being Moderated
    Nov 19, 2007 5:16 AM (in response to Bruce Sprague)
    Hi, Bruce,

    me too have the same problem, when my iMac reboot, I must to reboot my router (SMCBR18VPN), and than online again....
    Searching to the SMC intenet site but nothing about Leopard or this issue.
    In Apple support http://docs.info.apple.com/article.html?artnum=306803 there is a line about UPnP, I've enable it, but the result is the same, no fix, I must to rebbot the router.

    Someone have a fix?
    iMac INTEL G5 20" 2G ram, Mac OS X (10.5.1)
  • GlennB Calculating status...
    Currently Being Moderated
    Nov 19, 2007 7:01 AM (in response to Bruce Sprague)
    I am using a wireless connection. I was always able to automatically in tiger when waking from sleep. In leopard I have to wait almost 30 seconds for it to connect unless I connect manually. I can also connect to my neighbors router and if it is not on I connect much faster. Sometimes it connects to the neighbors before it connects to mine. I have in the network prefs to connect to my router first.
    iBook, Mac OS X (10.5.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.