1 2 3 Previous Next 109 Replies Latest reply: Jun 25, 2008 2:31 PM by gambier
Gabriel Chavez-Tafur Level 1 Level 1 (0 points)
Hello, hello,

I just installed Leopard, but now every now and then the CPU use goes up to 190% with a process called DirectoryServices. Forgive my ignorance but what's going on? Applications don't work after a few seconds and all I am left to do is force shut down the computer and re-start. Any help is greatly appreciated!

MacBook Pro 2.0 1.5GB RAM., Mac OS X (10.5)
  • 1. Re: Directoryservices 190% CPU
    Craig Roberts1 Level 2 Level 2 (405 points)

    What is OD server version?
    Did you upgrade or reinstall to 10.5?

    DirectoryService is the process running that handles all manner of Directory Services such as lookups, Authentication, etc. Perhaps info to questions above will help.

  • 2. Re: Directoryservices 190% CPU
    Gabriel Chavez-Tafur Level 1 Level 1 (0 points)
    Hey Craig,
    Thanks so much for replying. I upgraded from 10.4. I don't know what you mean by OD server version... sorry! I use my macbook pro at home and at school. Any ideas?
  • 3. Re: Directoryservices 190% CPU
    pmsaue0 Level 1 Level 1 (0 points)
    I am having the same issue with my macbook. Yesterday I tried to resolve the issue with an SMC reset, which worked initially (as does a restart)... but today when I heard the fan whirring and couldn't even open Activity Monitor, I knew the issue wasn't resolved.

  • 4. Re: Directoryservices 190% CPU
    reubx Level 1 Level 1 (0 points)
    I'm having the same issue this morning on my MacBook Pro - upgrade from Tiger to Leopard. I've also seen various other flaky issues around focus and cpu stability, but none that I can repeatably identify yet.

    I really like leopard in general, but I'm very surprised at the nature of the initial issues I've seen. Low-level scheduling, daemon and stability issues are not the usual "version 1" bugs.

    Apple - fix this now please.
  • 5. Re: Directoryservices 190% CPU
    Benjik Level 1 Level 1 (0 points)

    you're not alone. I'm having the same issue with a MacbookPro2,2. Sometimes, everything's quiet and suddenly, I notice 6000rpms vans and 195%cpu DirectoryService.
    The only thing I can do is to press the shutdown button during 5 sec to shutdown my MBP. It's very unpleasant. I took a mac not to have to reboot my computer and I hate doing it.

    I hope this problem (and others like Airport problem for example) are taking seriously by Apple.
  • 6. Re: Directoryservices 190% CPU
    'T. Level 1 Level 1 (0 points)
    I'm having exactly the same problem Leopard on my MBP. DirectoryService has gone wild and is using 170%+ of the CPU. The fans are going crazy as a result.
  • 7. Re: Directoryservices 190% CPU
    pmsaue0 Level 1 Level 1 (0 points)
    Perhaps it would resolve the situation to trash the contents of the folder "DirectoryService" in the "Preferences" folder (path: "+Macintosh HD+">"Library">"Preferences">"DirectoryService") I've tried this potential solution after experiencing this particular problem, and so far I haven't experienced the excessive CPU processing again. Fingers crossed.

  • 8. Re: Directoryservices 190% CPU
    Hedzer van Dijk Level 1 Level 1 (0 points)
    Same problem here, DirectoryService eating my cpu. Two times I was at the keyboard and could simply force quit it, one time (i'm guessing) the screensaver was on (with password) and I just got the spinning beachball, had to shutdown the machine. No problems on my Mac Pro, it's only the MBP that seems to have problems. I only had them (so far) when Airport was switched off and no other network connection was active.

    I've been unable to find anything useful in the log files.
  • 9. Logitech?
    buffettfan33 Level 1 Level 1 (0 points)
    I too am experiencing this problem...

    Out of curiosity, do any of you have Logitech Control Center (LCC) installed for a mouse or keyboard or installed Application Enhancer (APE)? The reason I ask is that I was having no problems with Leopard until last night when I installed LCC for my new MX Revolution mouse.

    I believe this problem is similar to what was happening to the people who were getting a blue screen after upgrading from Tiger.
  • 10. Re: Logitech?
    Hedzer van Dijk Level 1 Level 1 (0 points)
    No, the only thing special on my MBP is Parallels Desktop. However, it's not running when it happens. I've been running the machine for the entire yesterday evening with a network connection, no problems. Today I'm at work, no networking connection and within an hour it's already occurred again.
  • 11. Re: Directoryservices 190% CPU
    Fred van Os Level 1 Level 1 (0 points)
    I've got the same problem as well. after 40 min. or so, the fan goed crazy, and cpu usage used by DiretoryService is over 160%.
  • 12. Re: Directoryservices 190% CPU
    Hedzer van Dijk Level 1 Level 1 (0 points)
    Hm, I did a Repair Disk Permissions this morning and haven't had the problem since. It fixed one problem in DirectoryService:
    2007-11-09 11:18:03 +0100: Permissions differ on "Library/Preferences/DirectoryService", should be drwxrwxr-x , they are drwxr-xr-x .

    I'll post tomorrow if it's occurred again or still working
  • 13. Re: Directoryservices 190% CPU
    jcschro66 Level 1 Level 1 (0 points)
    I am having the same problem with a MacBook.
  • 14. Re: Directoryservices 190% CPU
    cakedaddy Level 1 Level 1 (0 points)
    Hi all,
    I chmod'd /Library/Preferences/DirectoryService to 775 as well, and then killed DirectoryService. The launchd restarted DirectoryService and the 99.4% CPU usage has dropped to 0%.

    I also have Parallels installed (not sure if this is relevant but thought to comment). An interesting test could be to set the directory perms back to 755 and then use the new Dtrace tools to check it out.
1 2 3 Previous Next