Skip navigation
This discussion is archived

Importing at 128kbps AAC is not working!!!!

10998 Views 108 Replies Latest reply: Feb 23, 2008 6:32 PM by Babaganoosh RSS
  • Quaid Calculating status...
    Currently Being Moderated
    Nov 11, 2007 3:20 AM (in response to SLADE666)
    Thanks SLADE666, I'll look for the Mac version of QuickTime 7.2.
    iMac, Mac OS X (10.5)
  • ee Level 2 Level 2 (165 points)
    Currently Being Moderated
    Nov 11, 2007 7:40 AM (in response to Quaid)
    QuickTime 7.2 for Mac can be found over here: http://www.apple.com/support/downloads/quicktime72formac.html

    But the installer will not work if you have 7.3 installed... and uninstalling 7.3 isn't easy (I tried and failed).
    Power Mac G5, MacBook, iPod, iPod shuffle, Mac OS X (10.4.7)
  • Will Bueche Level 1 Level 1 (60 points)
    Currently Being Moderated
    Nov 11, 2007 10:36 AM (in response to RTW\'s)
    Nope, the Windows version is affected as well. Importing with AAC at 128 kbps results in songs ranging from 124 to 129 kbps. So, no importing from CDs until Apple fixes this problem.

    Since this unwanted variable bit rate can reportedly be fixed by downgrading to an earlier version of QuickTime I guess QuickTime is what is broken -- on both Mac and Win platforms.
    Gateway NX250X, Windows XP Pro
  • smoerkels Calculating status...
    Currently Being Moderated
    Nov 11, 2007 2:51 PM (in response to matthewb87)
    i have the same issue. now its even harder to create audiobooks, because tools like dougs "join together" now greyed out the funktion "pass through", because the titels need to be in the same bitrate for this option.

    sorry for my bad english, i hope all understand ist. please apple fix it.
    iMac 20" CoreDuo, Mac OS X (10.4.10)
  • Gary K. Level 1 Level 1 (85 points)
    Currently Being Moderated
    Nov 11, 2007 3:14 PM (in response to matthewb87)
    I have Tiger 10.4.10 and this is also happening on my machine. I doubt this is a Leopard issue; more likely it is an iTunes and/or QT issue.

    Message was edited by: Gary K.
    MacBook Pro 2.16 2 Gig, Mac OS X (10.4.10), 8 gig iPhone, 80 gig Video iPod, a Maine Coon cat & a Dustbuster
  • Babaganoosh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2007 6:14 PM (in response to Gary K.)
    Interesting, in that QuickTime 7.3 (which is, AFAIK, the source of this problem) FIXED a bug for me:

    Before, certain songs would not play at all on my iPod (it would just skip over them) if they were encoded using VBR. I knew VBR was the problem because if I re-encoded those same songs without VBR, they would play on my iPod. Now that I have QT 7.3, I can re-encode those same songs again but WITH VBR, and they will play! So whatever the bug was that I was running into, QT 7.3 fixed it.

    As for this bug - bitrates being shown inconsistently when VBR is turned off - I have no idea. That's probably a legitimate bug. But I have a feeling that if you DO have VBR turned ON, the bitrates are supposed to show differently. Before QT 7.3, they didn't - even if I had VBR turned on, the bitrate as shown in iTunes (Get Info) would always show at 256Kbps. Now the bitrates are different, which is how I suspect it was intended. (Again, this is with VBR turned ON.)
    iMac Core 2 Duo, Mac OS X (10.5)
  • gsvandorn Calculating status...
    Currently Being Moderated
    Nov 11, 2007 10:37 PM (in response to matthewb87)
    Hi Folks,

    Just wanted to try shed some light on this situation from what I've found by looking around the net after reading this post. The good news, if you want to call it that, is that this is not a bug. Accoding to a thread from a different site, http://www.hydrogenaudio.org/forums/index.php?showtopic=58273, Apple has updated its AAC encoder, which by unfortunate coincedence is also the bad news. Apparently the new encoder first appeared in Leopard, which I am not personally running, but has been subsequently implemented in iTunes 7.5 / Quicktime 7.3. The relevant post from this thread describing the changes to the encoder is quoted below,

    "The newly released Apple AAC encoder offers four encoding modes:
    Constant Bit Rate (CBR)
    -- Recommended for live streaming --
    This mode achieves a constant target bit rate and is completely compliant to the CBR mode specified in the MPEG-4 standard. This mode is suitable for constant-bit-rate network transmission when decoding in real-time with a fixed end-to-end audio delay.

    *Average Bit Rate (ABR) - Default Mode*
    -- Recommended for controlling file size --
    A target bit rate is achieved over a long term average (typically after the first few seconds of encoding). Unlike CBR mode, this mode does not provide constant delay when using constant bit rate transmission, but this mode provides almost best global quality while still being able to strictly control the resulting file size and with less complexity than the CBR mode.

    Variable Bit Rate (VBR)
    -- Recommended for controlling the audio quality --
    The audio signal is encoded with constant (and settable) quality and virtually no bit rate constraints. This is the best mode to achieve consistent audio quality across many files with the smallest file size to achieve that quality. It also has the lowest complexity of all the encoding modes.

    *Variable Bit Rate But Constrained (VBR_Constrained)*
    -- Recommended as a compromise between VBR and ABR --
    This mode is similar to VBR but limits the average bit rate variation. The lower limit is the user-selected bit rate. Higher bit rate is adapted for difficult tracks and can generate up to 10% larger files than the ABR mode.

    *Note that QuickTime and the commandline tools on Mac can access all these four encoding modes. However, iTunes can only access ABR and VBR_Constrained.*"

    The take away from this, as far as I can interpret, is that checking VBR in iTunes use the *Variable Bit Rate Constrained* mode and leaving the VBR checkbox unchecked in iTunes uses the *Average Bit Rate* mode (the default according to the above quoted post), which would explain why bitrates are not consistent despite leaving the VBR checkbox in iTunes unchecked.

    If this is indeed true (and it seems like it is), then importing through iTunes (using the most recent versions of iTunes / Quicktime) will not yeild constant bitrates. The only suggestions that I can think of (1) downgrade your version of iTunes and Quicktime; and/or (2) write to apple feedback and tell them you want to be able to have an option to convert in Constant Bit Rate mode, which I did prior to posting this message. For the people using Windows, option (1) seems somewhat viable as you can uninstall both iTunes and Quicktime somewhat easily, but for the Mac users here uninstalling Quicktime is very difficult and the only safe way to downgrade Quicktime is to do an "archive and install".

    I hope this has been useful.
    MacBook Pro 1.83, Mac OS X (10.4.10)
  • Scott523 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 12, 2007 2:42 AM (in response to gsvandorn)
    Interesting discovery made!

    Well, I just found just a little good news about this issue. I check the "Convert higher bit rate songs to 128Kbps AAC" and after initiating the autofill, all songs were indeed 128Kbps (or so I hope..).
    White MacBook 2.0GHz Core 2 Duo |, Mac OS X (10.4.8), | 2GB Patriot RAM | 120GB Seagate HD
  • gsvandorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2007 6:59 AM (in response to Scott523)
    Where is this option found?
    MacBook Pro 1.83, Mac OS X (10.4.10)
  • Nigel Strudwick Level 1 Level 1 (85 points)
    Currently Being Moderated
    Nov 12, 2007 11:09 AM (in response to gsvandorn)
    It's only available on IPod Shuffles unfortunately (as far as I am aware). I have a shuffle and a 5th gen Ipod so I see the difference.

    I believe the logic is that if you have e.g. an 80gb IPod, it would take forever, whereas for a 1gb device it doesn't take too long.

    It would be a nice option for those with the time.
    Powermac G5 Quad & Powerbook G4, Mac OS X (10.4.9)
  • Quaid Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 12, 2007 12:49 PM (in response to gsvandorn)
    "Great" news, gsvandorn...

    ¿Is it really so hard for Apple to provide new features without destroying the old ones? It seems I'll be forced to use Tiger in a partition of my Mac in order to keep mi music "clear".
    iMac, Mac OS X (10.5)
  • gsvandorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2007 2:18 PM (in response to Quaid)
    It is indeed weird that Apple decided to add this "feature". Fortunately I don't use smart playlists using bit rate as a condition so I'm not up a creek in that regard, but if I was, I'd be a little distressed

    The other option, which you can use if you need constant bit rates is to use the MP3 encoder option instead of AAC. Apparently, not checking VBR in tunes under the MP3 option does give constant bit rate (though I haven't tried). The only issue with this is that 128kbps AAC is closer to 160kbps MP3 in sound quality, so if you want the same sound quality you may have to encode 160kbps, which will yield a larger file size.

    Additionally, I've read elsewhere (I don't have the link handy) that AAC never really used true constant bit rate to begin with and it was only with these new releases in iTunes & Quicktime (or Leopard) that we've been able to see the actual (true) encoded bit rate. One thing to test, if you are so inclined, is to encode a track that had been previously encoded and which is showing constant bit rate,i.e. 128 kpbs. After you've encoded this track get info on both of them and compare the file size of the newly encoded track with the file size of the older track. You may want to use the finder to get the file information as I think it will give you more accurate information on the size of the file. If the sizes are the same, then that would support the theory that up until now prior versions were just suppressing this information.
    MacBook Pro 1.83, Mac OS X (10.4.10)
  • gsvandorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2007 2:19 PM (in response to Nigel Strudwick)
    Thanks for the info. I thought I was going insane as I couldn't find this option with my 80 gig classic
    MacBook Pro 1.83, Mac OS X (10.4.10)
  • Quaid Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 12, 2007 3:09 PM (in response to gsvandorn)
    It's not just about playlists based on bit rate. Apparently, it affects the gapless playback of songs. I haven't tried that so I can't assure.

    MP3 encoding it's not an option for me. AAC quality is far better.

    +Additionally, I've read elsewhere (I don't have the link handy) that AAC never really used true constant bit rate to begin with and it was only with these new releases in iTunes & Quicktime (or Leopard) that we've been able to see the actual (true) encoded bit rate.+

    I have read about too. The point to me is not the real bitrate but the fact that iTunes now doesn't works as it used to do. If this will be the new way to enconde, I hope newer versions of QuickTime / iTunes allows us to show aproximate bitrate, like it apparently did before...
    iMac, Mac OS X (10.5)
  • gsvandorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2007 5:32 PM (in response to Quaid)
    In what way does it affect gapless playback? I have not heard about this, and for me, that is disconcerning as I use gapless a lot?
    MacBook Pro 1.83, Mac OS X (10.4.10)
1 2 3 4 5 6 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.