Skip navigation
This discussion is archived

Leopard Mail 3.0 does not work with Exchange 2003, Mail 2.0 does!

27235 Views 25 Replies Latest reply: Jan 18, 2008 12:27 PM by sterlingz RSS
1 2 Previous Next
luester Calculating status...
Currently Being Moderated
Oct 31, 2007 12:38 PM
Does anybody knows how to setup mail3.0 for working with exchange server 2003. in the previous mail 2.0 everything worked fine! I refuse to work with entourage due to the nice notice and task apps within mail3.
thx luester

IMAP is activated on exchange server!!
MBP 2,16 GHz 2GB, Mac OS X (10.5)
  • solcates Calculating status...
    We are trying to get Mail 3.0 to work with our Exchange 2003 server. Mail 2.0 was fine prior to our leopard upgrades.

    2 of us did upgrades... One was mine where i did an upgrade, and the other was a clean install. When i launch Mail 3.0 it will open then as soon as it starts to contact the exchange server, it will crash.

    The other install as i said was clean, and he created his exchange account, then as soon as he tries to "get mail" or synchronize, it crashes as well.

    We have IMAP on, OWA, and our smtp settings require authentication. all over SSL.

    any help out there?
    MBP, Mac OS X (10.5)
  • mangler Calculating status...
    It really looks like IMAP is broken in Mail 3.0. Can you get a tcpdump of the IMAP protocol?

    ck
    Mac OS X (10.5)
  • lindstromfoto Level 1 Level 1 (0 points)
    IMAP does not work at all in Mail 3.0, no remote folders shows up for prenumeration and you are right in thinking that it simply doesnt work.
    G5, Xserve, PB G4, Intel, Mac OS X (10.5)
  • Lee McMurtry Calculating status...
    I have Mail 3 running on two machines linking in to my office 2003 exchange server with no problems and another 4 in the office working fine.

    You might have tried this but just incase have you tried dropping in to the Terminal and telneting the server with the imap port ?

    Example telnet post.demon.co.uk 143
    MacBook, Mac OS X (10.5), MacBook Pro
  • bryanwalls Level 1 Level 1 (0 points)
    I updated my personal account, and just launched Apple Mail 3.0 using my old Tiger account settings. Worked fine to our Exchange 2003 server.

    I also created a new user account, and set the account up with my credentials using a script we'd designed for the Tiger version of Mail. It created the account and synced with no issues.

    However, we use IMAP accounts, not the "Exchange" account settings. So I see a Calendar mailbox.
    Mac Pro, Mac OS X (10.5)
  • bryanwalls Level 1 Level 1 (0 points)
    I tried to set up an "Exchange" account using the same data as my IMAP account -- so both were accessing the same content on and Exchange 2003 Server. It initially wouldn't authenticate or sync to the server, though it wasn't showing an error symbol next to the account. I disabled the account and then reenabled it, and it synced.

    Hmm. I can see the "Calendar" mailbox in both. The IMAP account has a "Journal" box with a "Junk" folder inside that I don't see in the Exchange version. IMAP has "Sent Items" in its list, while Exchange has "Sent Messages". Looking at the content of each box, I can confirm that a account set up as IMAP uses "Sent Messages" to store the outgoing content (listed in Apple Mail under "Sent"), while an Exchange account uses "Sent Items" for the same thing.

    Both accounts have a box named "Trash" in the account listing, as well as under the Trash mailbox. The listed box is different from the Apple Mail Trash listing. In my case, the two under the account listings have the same content, but the Apple Mail Trash mailboxes for each account have different content from each other, and from each other. Let me try to make sense of that.

    Under Mailboxes there exist the following listings: Inbox, Drafts, Sent, Trash, and Junk. Each of these expand and have entries for my IMAP and Exchange account. The Inboxes are the same, and Drafts are the same. Trash for the Entourage account is the "Deleted Items" folder on the Exchange server, while the IMAP account uses something else, I couldn't figure out what. Maybe a local box, though I have "Store deleted messages on the server" and "Move deleted messages to the Trash mailbox" checked for the account. Neither uses a box named "Trash". For Sent, IMAP uses "Sent Messages" while Exchange uses "Sent Items".

    Finally, the IMAP account shows a "Tasks" mailbox that is hidden in the Exchange account.
    Mac Pro, Mac OS X (10.5)
  • Frankns Calculating status...
    Have to jump in here and say the Leopard and Exchange apparently do not talk well.

    I have three messages in my Exchange Inbox that appear in OWA, in Thunderbird, and in Gyaz.

    Mail does NOT see them: not in the inbox or when I right click, get account info and look at all the messages.

    Essentially this makes Mail unusable for myself and the people we support.
    MBP 2.4 Core 2 Duo, Mac OS X (10.5)
  • nashman Level 1 Level 1 (0 points)
    Count me in as another user having problems talking to Exchange from Leopard Mail. This morning, it took probably 20 minutes for Mail to have the server go "online". Then, it went through this very long and drawn out caching process. And interesting to note - I wouldn't have known this had I only been looking at the newly introduced activity monitor on the bottom left of the main Mail window. It simply showed a mail download happening. The caching details were only visible when looking at the familiar Activity Monitor that had already been in Mail.

    Unfortunately, the caching activity stopped, but I still did not have any of today's mail in my Inbox! (And I knew it was there by checking Webmail on the account.)

    I quit mail, and restarted it, and it's caching again!

    Something is definitely out of whack here!
    MBP 17 2.16, Mac OS X (10.5)
  • nashman Level 1 Level 1 (0 points)
    On a related front - what does a user gain or lose when accessing Exchange as generic IMAP, versus the Mail option of Exchange, which I believe is a combination IMAP and WebDav? When setting up a new account in Mail, you can choose IMAP, or Exchange.
    MBP 17 2.16, Mac OS X (10.5)
  • nashman Level 1 Level 1 (0 points)
    The saga continues - I had been unable to have Mail show ANY mail that arrived in my account since I had checked yesterday. Verified by logging in via WebMail. This was with access defined in Mail as IMAP, not Exchange. (I had gone to generic IMAP with Tiger mail, because I had had problems with going in on an Exchange-based account!)

    Well, I disabled that account definition and created an Exchange account in Mail with the same login information, and now it's working! I may try to play detective further and go back and see if this was purely coincidence, but I do need to do some real work, unfortunately.
    MBP 17 2.16, Mac OS X (10.5)
  • Ernie Stamper Level 8 Level 8 (37,415 points)
    To All,

    I have tested setting up an Exchange Account on Exchange 2003, and it worked. In my case I set it up as Account Type Exchange, but I don't think that is the key.

    More info please.

    Ernie
    Mac Pro 8 Core, iBook, and QS G4 867, Mac OS X (10.5.1), 10.4.11
  • nashman Level 1 Level 1 (0 points)
    When you ask for more info, what do you want?

    In my case, I had a very reliable Tiger Mail Exchange-accessing account defined. Hadn't touched for I don't know how long. I upgrade to Leopard - cloned the drive and installed on top - and now I don't have a reliable Exchange-accessing account.

    I wonder if there is some hidden default parameter that is changed when doing an install over an existing Tiger OS?

    And it might be informative to note if those that are having problems are migrated/converted accounts, or newly created ones?
    MBP 17 2.16, Mac OS X (10.5)
  • Ernie Stamper Level 8 Level 8 (37,415 points)
    With an exchange account, and all its mailbox folders being on the server, it may be better to remove the account, and set it up fresh. If doing so, I would recommend using a Manual setup, which be initiated by holding down the Option key while clicking on the + key to add an account, rather than allowing the Mail setup assistant to do it.

    Ernie
    Mac Pro 8 Core, iBook, and QS G4 867, Mac OS X (10.5.1), 10.4.11
  • Frankns Level 1 Level 1 (55 points)
    I was able to configure successfully ... with the set-up assistant and without it. (I've installed twice now.)

    But the problem of Mail not seeing certain messages persists. It happens ~ x1 per day. Get Account Info and Show Messages also does not show the email. All rules are off. And while Mail does not see the message, Thunderbird does.

    This is a real show-stopper for me and the people we support.
    MBP 2.4 Core 2 Duo, Mac OS X (10.5.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.