1 2 3 4 5 Previous Next 70 Replies Latest reply: Jun 22, 2008 7:18 AM by archigos Go to original post
  • 15. Re: iCal Server error
    rutman286 Level 1 Level 1 (0 points)
    hmm, so is this something I can do anything about, or do I need to wait for an update from Apple or something?
  • 16. Re: iCal Server error
    rutman286 Level 1 Level 1 (0 points)
    I actually got this working after a while. Turns out for me the entire things was a DNS issue.
  • 17. Re: iCal Server error
    SPSIE Level 1 Level 1 (90 points)
    Would you mind explaining the DNS issue that resolved your problem? I still can't get Calendars to work off of the web.

    Continue to get the error "Error from server: Error processing calendar data (210)".
  • 18. Re: iCal Server error
    rutman286 Level 1 Level 1 (0 points)
    Certainly All I actually had to do was the following:

    * Go to Server Admin
    * Go to iCal
    * Go to Settings
    * Change the Host Name: to your local computer name

    It will most likely be set to whatever your DNS name of your machine is (in my case therutman.com).
    This was causing major problems for me. After digging through the logs a bunch, I discovered that what was really happening was the calendar program was searching for (in my case) therutman.com and not finding it. Once I changed the name in iCal service to my local server name (in my case arcadium.local), everything worked like a champ!

    Let me know if you get similar results. Hope this helps!
  • 19. Re: iCal Server error
    RickCogley Level 1 Level 1 (25 points)
    When I hit this one running Leopard Server on a Mac Mini, what I did was:

    Go to Server Admin
    Go to iCal, Settings
    Change the hostname to my local name "mysystemname.local"
    Server Admin prompts to restart iCal
    Test and still get error
    Go to Web, and restart
    Error goes away

    It seems like it is a name resolution problem.
  • 20. Re: iCal Server error
    mmoulton Level 1 Level 1 (0 points)
    Has anyone been able to get the web calendar working for groups?

    I can access individual user's calendars via iCal, however I can't seem to get the web-based calendar to work for any of my groups. I get the same error listed previously: Error from server: Error processing calendar data (210)

    -- Mike
  • 21. Re: iCal Server error
    Wayne Dyer Level 1 Level 1 (0 points)
    I'm having the same problems that you guys are having. I'm the calendar feature in my group wiki gives me the "Error from server. Error processing calendar data (210)" I've cleaned up all of my dns issues, but i'm still having the issue. any help would be appreciated....
  • 22. Re: iCal Server error
    Wayne Dyer Level 1 Level 1 (0 points)
    i set everything back to its defaults and it works like a charm. Has anyone been able to configure the services to function in locations other than the defaults? I have noticed that the default locations have for ical has the _calendar user and group and the default location for the wiki server has the _teamsserver user and group. I can't find these users to add to the new locations i want to setup...any suggestions?

    Message was edited by: Wayne Dyer
  • 23. Re: iCal Server error
    Bryson Gore Level 1 Level 1 (0 points)
    This worked for me. EXACTLY as described.

    Thanks a million.
  • 24. Re: iCal Server error
    Geoffrey Hutchison Level 1 Level 1 (25 points)
    I don't know if this will help. I also had the same problem -- and didn't find any help with the suggestions on this thread. I was running the web calendar over HTTPS and had enabled SSL for the iCal server in Server Admin.

    I still got the error message.

    It turns out that I had forgotten to select a certificate in the iCal settings in Server Admin. Once I picked the default certificate for SSL serving, and restarted the iCal service (and web service to be safe), everything worked great.

    I'm not sure why the default SSL certificate was not the default option in that popup menu, but it works great now.
  • 25. Re: iCal Server error
    indeks Level 1 Level 1 (0 points)
    this works...thx rutman
  • 26. Re: iCal Server error
    Alvaro Rodriguez Level 1 Level 1 (5 points)
    I followed the tips on this threads and was able to create calendars from the server computer and not the computers on the network. Then I had a big DUH moment. "The router has to have port 8008 open and pointed to your MacOS X server box". After I did that it started working from all computers.

    Now I can create events from "http://server.myexample.com/groups/workgroup/calendar/". I just need to find out how to subscribe to that calendar from iCal.

    Alvaro
  • 27. Re: iCal Server error
    wrtsmith Level 1 Level 1 (0 points)
    Hi Wayne,

    I moved both wikis/blogs and calendar to a new location (an external RAID). I used Terminal to chown the CalenderServer/Documents folder and the Collaboration folder to the _calendar and _teamserver user and group. I don't know if it's possible to change the owner any other way than using terminal. Alternatively, you could provide read & write access to all users and groups and that may work (though I've not tried it).

    Jeff
  • 28. Re: iCal Server error
    Picoscope Level 1 Level 1 (5 points)
    Hey there, Folks

    Well, I've tried everything listed on this thread, and got calendar services working properly for a few days. Then, suddenly I started getting 210 errors again. I noticed that some more suggestions were posted since my last view of this thread - tried changing my iCal Hostname to myservername.local as suggested. Still no dice.

    I was getting the following error in the iCal log before I made the above change:

    sqlite3.DatabaseError: database disk image is malformed


    After changing the iCal hostname, I restarted the iCal and Web services. Now I'm getting the following error in the log:

    sqlite3.OperationalError: SQL logic error or missing database

    Thoughts, anyone?

    Thanks!
  • 29. Re: iCal Server error
    Laz the Wiz Level 1 Level 1 (0 points)
    I was able to get the server going by modifying the the /etc/hosts file. You need to use the terminal for that (can be found under applications->utilities). Apparently the problem is that the name resolution doesn't work for its own server address.

    I added the following lines to it:
    127.0.0.1 macserver.home
    127.0.0.1 macserver

    macserver.home is the full name of my server.

    Hope this helps some folks.